[arch-commits] Commit in arrayfire/repos/community-x86_64 (4 files)

Sven-Hendrik Haase svenstaro at archlinux.org
Sun Dec 15 16:33:08 UTC 2019


    Date: Sunday, December 15, 2019 @ 16:33:08
  Author: svenstaro
Revision: 537753

archrelease: copy trunk to community-x86_64

Added:
  arrayfire/repos/community-x86_64/PKGBUILD
    (from rev 537751, arrayfire/trunk/PKGBUILD)
  arrayfire/repos/community-x86_64/doc_warn_not_error.patch
    (from rev 537751, arrayfire/trunk/doc_warn_not_error.patch)
Deleted:
  arrayfire/repos/community-x86_64/PKGBUILD
  arrayfire/repos/community-x86_64/doc_warn_not_error.patch

--------------------------+
 PKGBUILD                 |  130 ++++++++++++++++++++++-----------------------
 doc_warn_not_error.patch |   26 ++++-----
 2 files changed, 78 insertions(+), 78 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2019-12-15 16:33:06 UTC (rev 537752)
+++ PKGBUILD	2019-12-15 16:33:08 UTC (rev 537753)
@@ -1,65 +0,0 @@
-# Maintainer: Sven-Hendrik Haase <sh at lutzhaase.com>
-pkgname=arrayfire
-pkgdesc="High performance software library for parallel computing with an easy-to-use API"
-url='https://arrayfire.com'
-pkgver=3.6.4
-arch=('x86_64')
-pkgrel=2
-license=('BSD')
-depends=('cblas' 'fftw' 'lapacke' 'forge' 'freeimage' 'glfw' 'glew')
-makedepends=('cmake' 'graphviz' 'doxygen' 'opencl-headers' 'python' 'ocl-icd' 'cuda' 'git' 'ninja' 'boost1.69')
-optdepends=('cuda: Required for using CUDA backend'
-            'nvidia-utils: Required for using CUDA backend'
-            'libclc: Required for using OpenCL backend')
-options=('!buildflags')
-source=("http://arrayfire.com/arrayfire_source/arrayfire-full-${pkgver}.tar.bz2"
-        'doc_warn_not_error.patch')
-sha512sums=('febda2cd6f4a8d0bba2e5effaf92e93d37ab3283ff71f5fe1bd236fc71f3121c2e58988b20b97e457dee0077f67ea51406f17eac463c378d7655ad8be4aa3e53'
-            '63c745da51347fc94e02b031cb0606216f523acc350866658ebed7ac09115217a934285ecb731391f11c2934984f106564153eaca1b9c6d578db2b0904c0741d')
-
-prepare() {
-  cd "${srcdir}/arrayfire-full-${pkgver}"
-
-  patch -Np1 -i "${srcdir}/doc_warn_not_error.patch"
-
-  mkdir -p build
-}
-
-build() {
-  cd "${srcdir}/arrayfire-full-${pkgver}"
-
-  cd build
-  cmake .. \
-      -GNinja \
-      -DGOOGLETEST_VERSION=1.9.0 \
-      -DCMAKE_INSTALL_PREFIX=/usr \
-      -DCMAKE_INSTALL_LIBDIR=/usr/lib \
-      -DAF_WITH_IMAGEIO=ON \
-      -DAF_BUILD_CPU=ON \
-      -DAF_BUILD_OPENCL=ON \
-      -DAF_WITH_NONFREE=ON \
-      -DAF_BUILD_EXAMPLES=ON \
-      -DAF_BUILD_DOCS=ON \
-      -DCUDA_architecture_build_targets="3.0;3.2;3.5;3.7;5.0;5.2;5.3;6.0;6.1;6.2;7.0;7.2;7.5" \
-      -DCMAKE_BUILD_TYPE=Release \
-      -DCUDA_HOST_COMPILER=/usr/bin/gcc
-
-  ninja
-}
-
-# check() {
-#   cd "${srcdir}/arrayfire-full-${pkgver}/build"
-#
-#   # Some tests fail :(
-#   make test
-# }
-
-package() {
-  cd "${srcdir}/arrayfire-full-${pkgver}"
-
-  install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
-
-  cd build
-
-  DESTDIR="${pkgdir}/" ninja install
-}

Copied: arrayfire/repos/community-x86_64/PKGBUILD (from rev 537751, arrayfire/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2019-12-15 16:33:08 UTC (rev 537753)
@@ -0,0 +1,65 @@
+# Maintainer: Sven-Hendrik Haase <sh at lutzhaase.com>
+pkgname=arrayfire
+pkgdesc="High performance software library for parallel computing with an easy-to-use API"
+url='https://arrayfire.com'
+pkgver=3.6.4
+arch=('x86_64')
+pkgrel=4
+license=('BSD')
+depends=('cblas' 'fftw' 'lapacke' 'forge' 'freeimage' 'glfw' 'glew')
+makedepends=('cmake' 'graphviz' 'doxygen' 'opencl-headers' 'python' 'ocl-icd' 'cuda' 'git' 'ninja' 'boost1.69')
+optdepends=('cuda: Required for using CUDA backend'
+            'nvidia-utils: Required for using CUDA backend'
+            'libclc: Required for using OpenCL backend')
+options=('!buildflags')
+source=("http://arrayfire.com/arrayfire_source/arrayfire-full-${pkgver}.tar.bz2"
+        'doc_warn_not_error.patch')
+sha512sums=('febda2cd6f4a8d0bba2e5effaf92e93d37ab3283ff71f5fe1bd236fc71f3121c2e58988b20b97e457dee0077f67ea51406f17eac463c378d7655ad8be4aa3e53'
+            '63c745da51347fc94e02b031cb0606216f523acc350866658ebed7ac09115217a934285ecb731391f11c2934984f106564153eaca1b9c6d578db2b0904c0741d')
+
+prepare() {
+  cd "${srcdir}/arrayfire-full-${pkgver}"
+
+  patch -Np1 -i "${srcdir}/doc_warn_not_error.patch"
+
+  mkdir -p build
+}
+
+build() {
+  cd "${srcdir}/arrayfire-full-${pkgver}"
+
+  cd build
+  cmake .. \
+      -GNinja \
+      -DGOOGLETEST_VERSION=1.9.0 \
+      -DCMAKE_INSTALL_PREFIX=/usr \
+      -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+      -DAF_WITH_IMAGEIO=ON \
+      -DAF_BUILD_CPU=ON \
+      -DAF_BUILD_OPENCL=ON \
+      -DAF_WITH_NONFREE=ON \
+      -DAF_BUILD_EXAMPLES=ON \
+      -DAF_BUILD_DOCS=ON \
+      -DCUDA_architecture_build_targets="3.0;3.2;3.5;3.7;5.0;5.2;5.3;6.0;6.1;6.2;7.0;7.2;7.5" \
+      -DCMAKE_BUILD_TYPE=Release \
+      -DCUDA_HOST_COMPILER=/usr/bin/gcc
+
+  ninja
+}
+
+# check() {
+#   cd "${srcdir}/arrayfire-full-${pkgver}/build"
+#
+#   # Some tests fail :(
+#   make test
+# }
+
+package() {
+  cd "${srcdir}/arrayfire-full-${pkgver}"
+
+  install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+
+  cd build
+
+  DESTDIR="${pkgdir}/" ninja install
+}

Deleted: doc_warn_not_error.patch
===================================================================
--- doc_warn_not_error.patch	2019-12-15 16:33:06 UTC (rev 537752)
+++ doc_warn_not_error.patch	2019-12-15 16:33:08 UTC (rev 537753)
@@ -1,13 +0,0 @@
-diff --git a/docs/doxygen.mk b/docs/doxygen.mk
-index 5d4e0237..05c4e12c 100644
---- a/docs/doxygen.mk
-+++ b/docs/doxygen.mk
-@@ -769,7 +769,7 @@ WARN_NO_PARAMDOC       = YES
- # a warning is encountered.
- # The default value is: NO.
- 
--WARN_AS_ERROR          = YES
-+WARN_AS_ERROR          = NO
- 
- # The WARN_FORMAT tag determines the format of the warning messages that doxygen
- # can produce. The string should contain the $file, $line, and $text tags, which

Copied: arrayfire/repos/community-x86_64/doc_warn_not_error.patch (from rev 537751, arrayfire/trunk/doc_warn_not_error.patch)
===================================================================
--- doc_warn_not_error.patch	                        (rev 0)
+++ doc_warn_not_error.patch	2019-12-15 16:33:08 UTC (rev 537753)
@@ -0,0 +1,13 @@
+diff --git a/docs/doxygen.mk b/docs/doxygen.mk
+index 5d4e0237..05c4e12c 100644
+--- a/docs/doxygen.mk
++++ b/docs/doxygen.mk
+@@ -769,7 +769,7 @@ WARN_NO_PARAMDOC       = YES
+ # a warning is encountered.
+ # The default value is: NO.
+ 
+-WARN_AS_ERROR          = YES
++WARN_AS_ERROR          = NO
+ 
+ # The WARN_FORMAT tag determines the format of the warning messages that doxygen
+ # can produce. The string should contain the $file, $line, and $text tags, which


More information about the arch-commits mailing list