[arch-commits] Commit in deepin-cogl/repos/community-x86_64 (3 files)

Felix Yan felixonmars at archlinux.org
Tue Dec 24 17:02:03 UTC 2019


    Date: Tuesday, December 24, 2019 @ 17:02:02
  Author: felixonmars
Revision: 539983

archrelease: copy trunk to community-x86_64

Added:
  deepin-cogl/repos/community-x86_64/0001-Fix-building-with-libglvnd-1.2.0.patch
    (from rev 539982, deepin-cogl/trunk/0001-Fix-building-with-libglvnd-1.2.0.patch)
  deepin-cogl/repos/community-x86_64/PKGBUILD
    (from rev 539982, deepin-cogl/trunk/PKGBUILD)
Deleted:
  deepin-cogl/repos/community-x86_64/PKGBUILD

---------------------------------------------+
 0001-Fix-building-with-libglvnd-1.2.0.patch |   36 ++++++++++
 PKGBUILD                                    |   89 +++++++++++++-------------
 2 files changed, 82 insertions(+), 43 deletions(-)

Copied: deepin-cogl/repos/community-x86_64/0001-Fix-building-with-libglvnd-1.2.0.patch (from rev 539982, deepin-cogl/trunk/0001-Fix-building-with-libglvnd-1.2.0.patch)
===================================================================
--- 0001-Fix-building-with-libglvnd-1.2.0.patch	                        (rev 0)
+++ 0001-Fix-building-with-libglvnd-1.2.0.patch	2019-12-24 17:02:02 UTC (rev 539983)
@@ -0,0 +1,36 @@
+From 08b3f11cb5000540733549288878a6c0ada554e6 Mon Sep 17 00:00:00 2001
+From: Laurent Carlier <lordheavym at gmail.com>
+Date: Fri, 22 Nov 2019 17:51:06 +0100
+Subject: [PATCH] Fix building with libglvnd 1.2.0
+
+Signed-off-by: Laurent Carlier <lordheavym at gmail.com>
+---
+ configure.ac | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 213399f8..988fda67 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1212,7 +1212,7 @@ AS_IF([test "x$NEED_EGL" = "xyes" && test "x$EGL_CHECKED" != "xyes"],
+               [],
+               [AC_MSG_ERROR([Unable to locate required EGL headers])])
+             AC_CHECK_HEADERS(
+-              [EGL/eglext.h],
++              [EGL/eglext.h EGL/eglmesaext.h],
+               [],
+               [AC_MSG_ERROR([Unable to locate required EGL headers])],
+               [#include <EGL/egl.h>])
+@@ -1226,7 +1226,8 @@ AS_IF([test "x$NEED_EGL" = "xyes" && test "x$EGL_CHECKED" != "xyes"],
+           )
+ 
+         COGL_EGL_INCLUDES="#include <EGL/egl.h>
+-#include <EGL/eglext.h>"
++#include <EGL/eglext.h>
++#include <EGL/eglmesaext.h>"
+         AC_SUBST([COGL_EGL_INCLUDES])
+       ])
+ 
+-- 
+2.24.0
+

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2019-12-24 17:01:45 UTC (rev 539982)
+++ PKGBUILD	2019-12-24 17:02:02 UTC (rev 539983)
@@ -1,43 +0,0 @@
-# Maintainer: Felix Yan <felixonmars at archlinux.org>
-
-pkgname=deepin-cogl
-pkgver=1.22.5
-pkgrel=2
-pkgdesc="An object oriented GL/GLES Abstraction/Utility Layer for Deepin"
-arch=('x86_64')
-url="https://github.com/linuxdeepin/deepin-cogl"
-license=('GPL2')
-depends=('mesa' 'libdrm' 'libxext' 'libxdamage' 'libxcomposite' 'gdk-pixbuf2' 'pango' 'libxrandr')
-makedepends=('gobject-introspection' 'git' 'gtk-doc')
-provides=("cogl=$pkgver")
-conflicts=("cogl")
-options=(!emptydirs)
-source=("git+https://github.com/linuxdeepin/deepin-cogl.git#tag=$pkgver")
-sha512sums=('SKIP')
-
-prepare() {
-  cd $pkgname
-
-  sed -e 's|1.15|1.16 1.15|' -i autogen.sh # Support automake 1.16
-  NOCONFIGURE=1 ./autogen.sh
-}
-
-build() {
-  cd $pkgname
-  ./configure --prefix=/usr \
-    --enable-gles{1,2} \
-    --enable-{kms,wayland}-egl-platform \
-    --enable-wayland-egl-server
-
-  # https://bugzilla.gnome.org/show_bug.cgi?id=655517
-  sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
-  make -j1
-}
-
-package() {
-  cd $pkgname
-  make DESTDIR="$pkgdir" install
-}
-
-# vim:set ts=2 sw=2 et:

Copied: deepin-cogl/repos/community-x86_64/PKGBUILD (from rev 539982, deepin-cogl/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2019-12-24 17:02:02 UTC (rev 539983)
@@ -0,0 +1,46 @@
+# Maintainer: Felix Yan <felixonmars at archlinux.org>
+
+pkgname=deepin-cogl
+pkgver=1.22.5
+pkgrel=3
+pkgdesc="An object oriented GL/GLES Abstraction/Utility Layer for Deepin"
+arch=('x86_64')
+url="https://github.com/linuxdeepin/deepin-cogl"
+license=('GPL2')
+depends=('mesa' 'libdrm' 'libxext' 'libxdamage' 'libxcomposite' 'gdk-pixbuf2' 'pango' 'libxrandr')
+makedepends=('gobject-introspection' 'gtk-doc')
+provides=("cogl=$pkgver")
+conflicts=("cogl")
+options=(!emptydirs)
+source=("https://github.com/linuxdeepin/deepin-cogl/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+        0001-Fix-building-with-libglvnd-1.2.0.patch)
+sha512sums=('41e4d788dfb255802debb547e10e8b501fd087ee17b2270acaf2c30bcc3fa2cf4b1a55740efd10479b512c6fe1eb1bde8f0227dc8ef67645b86efd344cce3c74'
+            '26f1cb91152c8279162eb43d27964815ebf87c14ecaa486a14b53bd85c4c58f90f1b4fad4c9d72a7ac3feb283d95f19be1fb2a371eee2f93a04b1871aae4343d')
+
+prepare() {
+  cd $pkgname-$pkgver
+  patch -p1 -i ../0001-Fix-building-with-libglvnd-1.2.0.patch
+
+  sed -e 's|1.15|1.16 1.15|' -i autogen.sh # Support automake 1.16
+  NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+  cd $pkgname-$pkgver
+  ./configure --prefix=/usr \
+    --enable-gles2 \
+    --enable-{kms,wayland}-egl-platform \
+    --enable-wayland-egl-server
+
+  # https://bugzilla.gnome.org/show_bug.cgi?id=655517
+  sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+  make -j1
+}
+
+package() {
+  cd $pkgname-$pkgver
+  make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:


More information about the arch-commits mailing list