[arch-commits] Commit in keybase/repos/community-x86_64 (6 files)

Eli Schwartz eschwartz at archlinux.org
Tue Jan 22 03:27:08 UTC 2019


    Date: Tuesday, January 22, 2019 @ 03:27:07
  Author: eschwartz
Revision: 426779

archrelease: copy trunk to community-x86_64

Added:
  keybase/repos/community-x86_64/0001-Don-t-use-electron-to-build.patch
    (from rev 426778, keybase/trunk/0001-Don-t-use-electron-to-build.patch)
  keybase/repos/community-x86_64/PKGBUILD
    (from rev 426778, keybase/trunk/PKGBUILD)
  keybase/repos/community-x86_64/keybase-gui
    (from rev 426778, keybase/trunk/keybase-gui)
Deleted:
  keybase/repos/community-x86_64/0001-Don-t-use-electron-to-build.patch
  keybase/repos/community-x86_64/PKGBUILD
  keybase/repos/community-x86_64/keybase-gui

----------------------------------------+
 0001-Don-t-use-electron-to-build.patch |  136 +++++++++----------
 PKGBUILD                               |  212 ++++++++++++++++---------------
 keybase-gui                            |   14 +-
 3 files changed, 193 insertions(+), 169 deletions(-)

Deleted: 0001-Don-t-use-electron-to-build.patch
===================================================================
--- 0001-Don-t-use-electron-to-build.patch	2019-01-22 03:26:44 UTC (rev 426778)
+++ 0001-Don-t-use-electron-to-build.patch	2019-01-22 03:27:07 UTC (rev 426779)
@@ -1,68 +0,0 @@
-From b53e21bbff9bc10f5d83059746b8ec1338a68bc0 Mon Sep 17 00:00:00 2001
-From: Eli Schwartz <eschwartz93 at gmail.com>
-Date: Thu, 21 Jun 2018 05:00:37 -0400
-Subject: [PATCH] Don't use electron to build
-
----
- shared/desktop/package.desktop.js   | 4 ++--
- shared/desktop/yarn-helper/index.js | 2 --
- shared/package.json                 | 1 -
- 3 files changed, 2 insertions(+), 5 deletions(-)
-
-diff --git a/shared/desktop/package.desktop.js b/shared/desktop/package.desktop.js
-index 1ceb5e1ac4..3c6dc3961b 100644
---- a/shared/desktop/package.desktop.js
-+++ b/shared/desktop/package.desktop.js
-@@ -86,7 +86,7 @@ function main() {
-   // use the same version as the currently-installed electron
-   console.log('Finding electron version')
-   try {
--    packagerOpts.electronVersion = require('../package.json').devDependencies.electron
-+    packagerOpts.electronVersion = 'unused string'
-     console.log('Found electron version:', packagerOpts.electronVersion)
-   } catch (err) {
-     console.log("Couldn't parse yarn list to find electron:", err)
-@@ -136,7 +136,7 @@ function startPack() {
-                 .catch(postPackError)
-             })
-           })
--        } else {
-+        } else if (false) {
-           pack(platform, arch)
-             .then(postPack(platform, arch))
-             .catch(postPackError)
-diff --git a/shared/desktop/yarn-helper/index.js b/shared/desktop/yarn-helper/index.js
-index a0a28b3fda..7ed3c84e2f 100644
---- a/shared/desktop/yarn-helper/index.js
-+++ b/shared/desktop/yarn-helper/index.js
-@@ -1,7 +1,6 @@
- // @flow
- // Helper for cross platform yarn run script commands
- import buildCommands from './build'
--import electronComands from './electron'
- import fontCommands from './font'
- import prettierCommands from './prettier'
- import {execSync} from 'child_process'
-@@ -11,7 +10,6 @@ const [, , command, ...rest] = process.argv
- const commands = {
-   ...buildCommands,
-   ...fontCommands,
--  ...electronComands,
-   ...prettierCommands,
-   help: {
-     code: () => {
-diff --git a/shared/package.json b/shared/package.json
-index 5426fee0e5..3c1182ee0e 100644
---- a/shared/package.json
-+++ b/shared/package.json
-@@ -203,7 +203,6 @@
-     "cross-env": "5.2.0",
-     "css-loader": "1.0.1",
-     "del": "3.0.0",
--    "electron": "3.0.10",
-     "electron-packager": "12.2.0",
-     "eslint": "5.9.0",
-     "eslint-config-standard": "12.0.0",
--- 
-2.19.2
-

Copied: keybase/repos/community-x86_64/0001-Don-t-use-electron-to-build.patch (from rev 426778, keybase/trunk/0001-Don-t-use-electron-to-build.patch)
===================================================================
--- 0001-Don-t-use-electron-to-build.patch	                        (rev 0)
+++ 0001-Don-t-use-electron-to-build.patch	2019-01-22 03:27:07 UTC (rev 426779)
@@ -0,0 +1,68 @@
+From 8149b6244c6b9043b5e8fa391a453c2484582ba7 Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz93 at gmail.com>
+Date: Thu, 21 Jun 2018 05:00:37 -0400
+Subject: [PATCH] Don't use electron to build
+
+---
+ shared/desktop/package.desktop.js   | 4 ++--
+ shared/desktop/yarn-helper/index.js | 2 --
+ shared/package.json                 | 1 -
+ 3 files changed, 2 insertions(+), 5 deletions(-)
+
+diff --git a/shared/desktop/package.desktop.js b/shared/desktop/package.desktop.js
+index 1ceb5e1ac4..3c6dc3961b 100644
+--- a/shared/desktop/package.desktop.js
++++ b/shared/desktop/package.desktop.js
+@@ -86,7 +86,7 @@ function main() {
+   // use the same version as the currently-installed electron
+   console.log('Finding electron version')
+   try {
+-    packagerOpts.electronVersion = require('../package.json').devDependencies.electron
++    packagerOpts.electronVersion = 'unused string'
+     console.log('Found electron version:', packagerOpts.electronVersion)
+   } catch (err) {
+     console.log("Couldn't parse yarn list to find electron:", err)
+@@ -136,7 +136,7 @@ function startPack() {
+                 .catch(postPackError)
+             })
+           })
+-        } else {
++        } else if (false) {
+           pack(platform, arch)
+             .then(postPack(platform, arch))
+             .catch(postPackError)
+diff --git a/shared/desktop/yarn-helper/index.js b/shared/desktop/yarn-helper/index.js
+index 425346cbb7..29d1ee6b54 100644
+--- a/shared/desktop/yarn-helper/index.js
++++ b/shared/desktop/yarn-helper/index.js
+@@ -1,7 +1,6 @@
+ // @flow
+ // Helper for cross platform yarn run script commands
+ import buildCommands from './build'
+-import electronComands from './electron'
+ import fontCommands from './font'
+ import prettierCommands from './prettier'
+ import {execSync} from 'child_process'
+@@ -13,7 +12,6 @@ const [, , command, ...rest] = process.argv
+ const commands = {
+   ...buildCommands,
+   ...fontCommands,
+-  ...electronComands,
+   ...prettierCommands,
+   help: {
+     code: () => {
+diff --git a/shared/package.json b/shared/package.json
+index 09e8732402..fdcc2f9c9c 100644
+--- a/shared/package.json
++++ b/shared/package.json
+@@ -204,7 +204,6 @@
+     "cross-env": "5.2.0",
+     "css-loader": "2.1.0",
+     "del": "3.0.0",
+-    "electron": "4.0.1",
+     "electron-packager": "13.0.1",
+     "eslint": "5.12.0",
+     "eslint-config-standard": "12.0.0",
+-- 
+2.20.1
+

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2019-01-22 03:26:44 UTC (rev 426778)
+++ PKGBUILD	2019-01-22 03:27:07 UTC (rev 426779)
@@ -1,97 +0,0 @@
-# Maintainer: Felix Yan <felixonmars at archlinux.org>
-# Maintainer: Eli Schwartz <eschwartz at archlinux.org>
-# Contributor: Michael Hansen <zrax0111 gmail com>
-
-pkgbase=keybase
-pkgname=('keybase' 'keybase-gui')
-pkgdesc='CLI tool for GPG with keybase.io'
-pkgver=2.11.0
-pkgrel=1
-arch=('x86_64')
-url='https://keybase.io/'
-license=('BSD')
-# git is needed for yarn...
-makedepends=('git' 'go-pie' 'yarn')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/keybase/client/archive/v${pkgver}.tar.gz"
-        "keybase-gui"
-        "0001-Don-t-use-electron-to-build.patch")
-sha512sums=('b150184e692c81243a8f83b828ec8ef4f6b324a6cbd0b1cb9cf5e89eebbec7a6183a2af3b8d26c663ab677aa38753c328e190b46035c3815af8373d8ff4b26fa'
-            'b3086ea6c60950284eecc331a8a648ea557f89f686f2adecb82b22d0ac65381683fbcc84875a48cf6ba9e3c63d4f06c73b84175621dca5e8f03b2a6a88cdcad4'
-            'e43f9d881bf1b6e29c7158308d3406e0e0f01d435d91bc934d476424041ad07727357206b2e9298cfbe3c7f48a16dfbe30eb6304686ecf556272c6c7790cea10')
-
-prepare() {
-    cd client-${pkgver}
-
-    export GOPATH="${srcdir}/.gopath"
-    mkdir -p "${GOPATH}"/src/github.com/keybase
-    ln -sf "${PWD}" "${GOPATH}"/src/github.com/keybase/client
-
-    # Fix paths to run electron /path/to/app (or our minimal wrapper script)
-    sed -i 's@/opt/keybase/Keybase@/usr/bin/electron /usr/share/keybase-app@' \
-        packaging/linux/systemd/keybase.gui.service
-    sed -i 's/run_keybase/keybase-gui/g' \
-        packaging/linux/keybase.desktop go/install/install_unix.go
-
-    patch -p1 -i ../0001-Don-t-use-electron-to-build.patch
-}
-
-build() {
-    cd client-${pkgver}/go/keybase
-
-    export GOPATH="${srcdir}/.gopath"
-    # go build -a -tags production -gccgoflags "$CFLAGS $LDFLAGS" github.com/keybase/client/go/keybase
-    go build -a -tags production -o ../bin/keybase github.com/keybase/client/go/keybase
-    go build -a -tags production -o ../bin/kbnm github.com/keybase/client/go/kbnm
-
-    cd ../../shared
-    yarn install
-    yarn run package
-}
-
-package_keybase() {
-    depends=('gnupg')
-    optdepends=('kbfs: for the fuse-based fileystem and the encryption subcommand')
-
-    cd client-${pkgver}
-
-    install -Dm755 -t "${pkgdir}"/usr/bin/ go/bin/*
-
-    # native messaging whitelists
-    KBNM_INSTALL_ROOT=1 KBNM_INSTALL_OVERLAY="${pkgdir}" "${pkgdir}/usr/bin/kbnm" install
-    # systemd activation
-    install -Dm644 packaging/linux/systemd/keybase.service "${pkgdir}"/usr/lib/systemd/user/keybase.service
-    install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
-}
-
-package_keybase-gui() {
-    pkgdesc="GUI frontend for GPG with keybase.io"
-    depends=('electron' 'keybase' 'kbfs')
-
-    cd client-${pkgver}/
-
-    install -Dm644 packaging/linux/keybase.desktop \
-        "${pkgdir}"/usr/share/applications/keybase.desktop
-    # more systemd activation
-    install -Dm644 packaging/linux/systemd/keybase.gui.service \
-        "${pkgdir}"/usr/lib/systemd/user/keybase.gui.service
-    # wrapper for electron
-    install -Dm755 "${srcdir}"/keybase-gui "${pkgdir}"/usr/bin/keybase-gui
-
-    install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
-
-    for i in 16 32 128 256 512 ; do
-        install -Dm644 media/icons/Keybase.iconset/icon_${i}x${i}.png \
-            "${pkgdir}"/usr/share/icons/hicolor/${i}x${i}/apps/keybase.png
-    done
-    # ???
-    install -Dm644 media/icons/Keybase.iconset/icon_32x32 at 2x.png \
-        "${pkgdir}"/usr/share/icons/hicolor/64x64/apps/keybase.png
-    install -Dm644 media/icons/Keybase.iconset/icon_512x512 at 2x.png \
-        "${pkgdir}"/usr/share/icons/hicolor/1024x1024/apps/keybase.png
-
-    # the app itself
-    cd shared/desktop/build
-    rm -rf desktop/sourcemaps/
-    mkdir -p "${pkgdir}"/usr/share/keybase-app
-    cp -r * "${pkgdir}"/usr/share/keybase-app/
-}

Copied: keybase/repos/community-x86_64/PKGBUILD (from rev 426778, keybase/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2019-01-22 03:27:07 UTC (rev 426779)
@@ -0,0 +1,115 @@
+# Maintainer: Felix Yan <felixonmars at archlinux.org>
+# Maintainer: Eli Schwartz <eschwartz at archlinux.org>
+# Contributor: Michael Hansen <zrax0111 gmail com>
+
+pkgbase=keybase
+pkgname=('keybase' 'kbfs' 'keybase-gui')
+pkgdesc='CLI tool for GPG with keybase.io'
+pkgver=2.13.1
+pkgrel=1
+arch=('x86_64')
+url='https://keybase.io/'
+license=('BSD')
+# git is needed for yarn...
+makedepends=('git' 'go-pie' 'yarn')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/keybase/client/archive/v${pkgver}.tar.gz"
+        "keybase-gui"
+        "0001-Don-t-use-electron-to-build.patch")
+sha512sums=('c0cad522f14cf39f08c841ff90f96662f3f5d9fe3c8e8156755a8805757c5d206991410a2511315b8c00dcafcc5e23e5449d37d13f399e6692e0c6d4fb1c0b61'
+            '4ab159d8e764de7ef92b3c9b99559e0a499de607914521b7c5f89396d810c6360b87a785c43be90c54d1dee7e93ec1fda31e8377080d9bbbeb6230166d856f39'
+            'b721dc0c40cf23602424d2ca024524a0eef5210a7cdca0209b89eab5c17c3fcb3cc48d91940a4c88d2416d0a19a7fb3deba92e90244251c4338b0fd640befdcd')
+
+prepare() {
+    cd client-${pkgver}
+
+    export GOPATH="${srcdir}/.gopath"
+    mkdir -p "${GOPATH}"/src/github.com/keybase
+    ln -sf "${PWD}" "${GOPATH}"/src/github.com/keybase/client
+
+    # Fix paths to run electron /path/to/app (or our minimal wrapper script).
+    # Also wire up "hideWindow" when running as a service or via XDG autostart.
+    sed -i \
+        -e 's@/opt/keybase/Keybase@/usr/bin/electron /usr/share/keybase-app@' \
+        -e '/EnvironmentFile/a\Environment=KEYBASE_START_UI=hideWindow' \
+        packaging/linux/systemd/keybase.gui.service
+    sed -i 's/KEYBASE_AUTOSTART=1/KEYBASE_START_UI=hideWindow/;s/run_keybase/keybase-gui/g' \
+        packaging/linux/keybase.desktop go/install/install_unix.go
+
+    patch -p1 -i ../0001-Don-t-use-electron-to-build.patch
+}
+
+build() {
+    cd client-${pkgver}/go/keybase
+
+    export GOPATH="${srcdir}/.gopath"
+    # go build -a -tags production -gccgoflags "$CFLAGS $LDFLAGS" github.com/keybase/client/go/keybase
+    go build -a -tags production -o ../bin/keybase github.com/keybase/client/go/keybase
+    go build -a -tags production -o ../bin/kbnm github.com/keybase/client/go/kbnm
+    go build -a -tags production -o ../bin/kbfsfuse github.com/keybase/client/go/kbfs/kbfsfuse
+    go build -a -tags production -o ../bin/git-remote-keybase github.com/keybase/client/go/kbfs/kbfsgit/git-remote-keybase
+
+    cd ../../shared
+    yarn install
+    yarn run package
+}
+
+package_keybase() {
+    depends=('gnupg')
+    optdepends=('kbfs: for the fuse-based fileystem and the encryption subcommand')
+
+    cd client-${pkgver}
+
+    install -Dm755 -t "${pkgdir}"/usr/bin/ go/bin/{keybase,kbnm}
+
+    # native messaging whitelists
+    KBNM_INSTALL_ROOT=1 KBNM_INSTALL_OVERLAY="${pkgdir}" "${pkgdir}/usr/bin/kbnm" install
+    # systemd activation
+    install -Dm644 packaging/linux/systemd/keybase.service "${pkgdir}"/usr/lib/systemd/user/keybase.service
+    install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
+
+package_kbfs() {
+    pkgdesc="The Keybase filesystem"
+    url="https://keybase.io/docs/kbfs"
+    depends=('fuse' 'keybase')
+
+    cd client-${pkgver}
+
+    install -Dm755 -t "${pkgdir}"/usr/bin/ go/bin/{kbfsfuse,git-remote-keybase}
+    install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+    # more systemd activation
+    install -Dm644 go/kbfs/packaging/linux/systemd/kbfs.service "$pkgdir"/usr/lib/systemd/user/kbfs.service
+}
+
+package_keybase-gui() {
+    pkgdesc="GUI frontend for GPG with keybase.io"
+    depends=('electron' 'keybase' 'kbfs')
+
+    cd client-${pkgver}/
+
+    install -Dm644 packaging/linux/keybase.desktop \
+        "${pkgdir}"/usr/share/applications/keybase.desktop
+    # more systemd activation
+    install -Dm644 packaging/linux/systemd/keybase.gui.service \
+        "${pkgdir}"/usr/lib/systemd/user/keybase.gui.service
+    # wrapper for electron
+    install -Dm755 "${srcdir}"/keybase-gui "${pkgdir}"/usr/bin/keybase-gui
+
+    install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+
+    for i in 16 32 128 256 512 ; do
+        install -Dm644 media/icons/Keybase.iconset/icon_${i}x${i}.png \
+            "${pkgdir}"/usr/share/icons/hicolor/${i}x${i}/apps/keybase.png
+    done
+    # ???
+    install -Dm644 media/icons/Keybase.iconset/icon_32x32 at 2x.png \
+        "${pkgdir}"/usr/share/icons/hicolor/64x64/apps/keybase.png
+    install -Dm644 media/icons/Keybase.iconset/icon_512x512 at 2x.png \
+        "${pkgdir}"/usr/share/icons/hicolor/1024x1024/apps/keybase.png
+
+    # the app itself
+    cd shared/desktop/build
+    rm -rf desktop/sourcemaps/
+    mkdir -p "${pkgdir}"/usr/share/keybase-app
+    cp -r * "${pkgdir}"/usr/share/keybase-app/
+}

Deleted: keybase-gui
===================================================================
--- keybase-gui	2019-01-22 03:26:44 UTC (rev 426778)
+++ keybase-gui	2019-01-22 03:27:07 UTC (rev 426779)
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-systemctl start --user keybase.gui.service
-exec electron /usr/share/keybase-app/ "$@"

Copied: keybase/repos/community-x86_64/keybase-gui (from rev 426778, keybase/trunk/keybase-gui)
===================================================================
--- keybase-gui	                        (rev 0)
+++ keybase-gui	2019-01-22 03:27:07 UTC (rev 426779)
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+systemctl start --user keybase.service kbfs.service
+systemctl start --user keybase.gui.service
+
+# executing the application when it is already running will bring it to the
+# foreground
+if [ "$KEYBASE_START_UI" != 'hideWindow' ]; then
+    exec electron /usr/share/keybase-app/ "$@"
+fi


More information about the arch-commits mailing list