[arch-commits] Commit in varnish/trunk (3 files)

Sven-Hendrik Haase svenstaro at archlinux.org
Mon Jul 1 11:23:58 UTC 2019


    Date: Monday, July 1, 2019 @ 11:23:58
  Author: svenstaro
Revision: 357195

upgpkg: varnish 6.2.0-1

Modified:
  varnish/trunk/PKGBUILD
  varnish/trunk/varnish.install
Deleted:
  varnish/trunk/hack-up-vcstools-to-work-with-python-2-and-3.patch

----------------------------------------------------+
 PKGBUILD                                           |   15 +---
 hack-up-vcstools-to-work-with-python-2-and-3.patch |   66 -------------------
 varnish.install                                    |    6 -
 3 files changed, 9 insertions(+), 78 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2019-07-01 08:54:29 UTC (rev 357194)
+++ PKGBUILD	2019-07-01 11:23:58 UTC (rev 357195)
@@ -1,28 +1,27 @@
-# Maintainer: Dave Reisner <dreisner at archlinux.org>
+# Maintainer: Sven-Hendrik Haase <svenstaro at gmail.com>
+# Contributor: Dave Reisner <dreisner at archlinux.org>
 # Contributor: Jaroslav Lichtblau <dragonlord at aur.archlinux.org>
 # Contributor: Douglas Soares de Andrade
 # Contributor: Roberto Alsina <ralsina at kde.org>
 
 pkgname=varnish
-pkgver=5.2.1
-pkgrel=3
+pkgver=6.2.0
+pkgrel=1
 pkgdesc="High-performance HTTP accelerator"
 arch=('x86_64')
 url="https://www.varnish-cache.org/"
 license=('BSD')
 depends=('gcc' 'libedit' 'pcre' 'libnsl')
-makedepends=('python-docutils')
+makedepends=('python-docutils' 'python-sphinx')
 optdepends=('python: needed for vmod development')
 backup=('etc/varnish/default.vcl')
 options=('!buildflags')
 install=$pkgname.install
 source=("https://github.com/varnishcache/varnish-cache/archive/varnish-$pkgver.tar.gz"
-        hack-up-vcstools-to-work-with-python-2-and-3.patch
         varnish-vcl-reload
         varnish.service
         varnish.sysusers)
-sha256sums=('f44decf0f382a2ac76aaaa2478167a6b41909a3f6179eeefce402d19e694aba0'
-            '97a00962474a5bf97fd71e4c0e792861157aa8ac872fc9c5636b763f11445e8c'
+sha256sums=('0024add1a9d9fc3933096f3837e6069c0fc3001b0033e32240e3a193ec3d8528'
             '0369e3e735e4c6150f08677df8b7cdae1a36ea75fd0e03734abe814a94312f80'
             '49b48981ccb97aee77ef59373db3856652d7badc909f2504df01970d834183f2'
             'b58dd6b00eb81c75e4bb30421b85b2be88c049d5b72a8ee553ba690a5414972b')
@@ -30,8 +29,6 @@
 prepare() {
   cd "varnish-cache-varnish-$pkgver"
 
-  patch -Np1 <"$srcdir/hack-up-vcstools-to-work-with-python-2-and-3.patch"
-
   ./autogen.sh
 }
 

Deleted: hack-up-vcstools-to-work-with-python-2-and-3.patch
===================================================================
--- hack-up-vcstools-to-work-with-python-2-and-3.patch	2019-07-01 08:54:29 UTC (rev 357194)
+++ hack-up-vcstools-to-work-with-python-2-and-3.patch	2019-07-01 11:23:58 UTC (rev 357195)
@@ -1,66 +0,0 @@
-From 17c92e43fda114bf5341e51d752e882238b8fe8c Mon Sep 17 00:00:00 2001
-From: Nils Goroll <nils.goroll at uplex.de>
-Date: Thu, 5 Oct 2017 13:39:23 +0200
-Subject: [PATCH] hack up vsctool to work with python 2 and 3
-
-StringIO does not exist any more in python3, yet requiring 2.7 would
-not pave the path forward, so try to be compatible with both.
-
-Works for me on Python 2.7.9 and Python 3.4
-
-I would appreciate if someone more fluent in serpentinous programming
-language reviewed and/or rewrote this.
----
- lib/libvcc/vsctool.py | 24 ++++++++++++++++++++----
- 1 file changed, 20 insertions(+), 4 deletions(-)
-
-diff --git a/lib/libvcc/vsctool.py b/lib/libvcc/vsctool.py
-index 854968e3b..829c6e518 100644
---- a/lib/libvcc/vsctool.py
-+++ b/lib/libvcc/vsctool.py
-@@ -37,7 +37,10 @@
- import json
- import sys
- import gzip
--import StringIO
-+try:
-+    import StringIO
-+except ImportError:
-+    import io
- import collections
- import struct
- 
-@@ -54,9 +57,22 @@
- 	"format":	[ "integer", FORMATS],
- }
- 
-+# http://python3porting.com/problems.html#bytes-strings-and-unicode
-+if sys.version_info < (3,):
-+    def b(x):
-+        return x
-+else:
-+    import codecs
-+    def b(x):
-+        return codecs.latin_1_encode(x)[0]
-+
- def gzip_str(s):
--	out = StringIO.StringIO()
--	gzip.GzipFile(fileobj=out, mode="w").write(s)
-+	try:
-+		out = StringIO.StringIO()
-+	except NameError:
-+		out = io.BytesIO()
-+
-+	gzip.GzipFile(fileobj=out, mode="w").write(b(s))
- 	out.seek(4)
- 	out.write(struct.pack("<L", 0x12bfd58))
- 	return out.getvalue()
-@@ -285,7 +301,7 @@ class rst_vsc(directive):
- 	def __init__(self, s):
- 		super(rst_vsc, self).__init__(s)
- 
--		for i,v in PARAMS.iteritems():
-+		for i,v in PARAMS.items():
- 			if v is not True:
- 				self.do_default(i, v[0], v[1])
- 

Modified: varnish.install
===================================================================
--- varnish.install	2019-07-01 08:54:29 UTC (rev 357194)
+++ varnish.install	2019-07-01 11:23:58 UTC (rev 357195)
@@ -4,9 +4,9 @@
 }
 
 post_upgrade() {
-  if [[ $(vercmp 5.0.0-1 "$2") -eq 1 ]]; then
-    echo ":: You must update your VCL to be compatible with varnish 5.0.0. See the"
+  if [[ $(vercmp 6.0.0-1 "$2") -eq 1 ]]; then
+    echo ":: You must update your VCL to be compatible with varnish 6. See the"
     echo "   following upgrade guide to port your configuration:"
-    echo "   http://varnish-cache.org/docs/5.0/whats-new/upgrading-5.0.html"
+    echo "   http://varnish-cache.org/docs/6.2/whats-new/upgrading-6.2.html"
   fi
 }


More information about the arch-commits mailing list