[arch-commits] Commit in python-apispec/repos/community-testing-any (2 files)

Felix Yan felixonmars at archlinux.org
Sun Jul 7 02:14:10 UTC 2019


    Date: Sunday, July 7, 2019 @ 02:14:10
  Author: felixonmars
Revision: 487577

archrelease: copy trunk to community-testing-any

Added:
  python-apispec/repos/community-testing-any/PKGBUILD
    (from rev 487576, python-apispec/trunk/PKGBUILD)
Deleted:
  python-apispec/repos/community-testing-any/PKGBUILD

----------+
 PKGBUILD |  106 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 53 insertions(+), 53 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2019-07-07 02:13:56 UTC (rev 487576)
+++ PKGBUILD	2019-07-07 02:14:10 UTC (rev 487577)
@@ -1,53 +0,0 @@
-# Maintainer: Felix Yan <felixonmars at archlinux.org>
-
-pkgbase=python-apispec
-pkgname=(python-apispec python2-apispec)
-pkgver=2.0.1
-pkgrel=1
-pkgdesc="A pluggable API specification generator. Currently supports the OpenAPI Specification."
-url="https://github.com/marshmallow-code/apispec"
-license=('MIT')
-arch=('any')
-makedepends=('python-setuptools' 'python2-setuptools')
-checkdepends=('python-pytest-runner' 'python-tornado' 'python-bottle' 'python-marshmallow'
-              'python-flask' 'python-prance' 'python-yaml' 'python-mock'
-              'python-openapi-spec-validator')
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/marshmallow-code/apispec/archive/$pkgver.tar.gz")
-sha512sums=('afc983dc2148071b411d9a61b4f8e433f9cecaddb0c490eab37229a7593790710e81cdc1f49736a4abca9a20972d517750007a5698bce1790cb889590e04859c')
-
-prepare() {
-  cp -a apispec-$pkgver{,-py2}
-}
-
-build() {
-  cd "$srcdir"/apispec-$pkgver
-  python setup.py build
-
-  cd "$srcdir"/apispec-$pkgver-py2
-  python2 setup.py build
-}
-
-check() {
-  cd apispec-$pkgver
-  python setup.py pytest
-}
-
-package_python-apispec() {
-  depends=('python')
-  optdepends=('python-yaml: for yaml support'
-              'python-prance: for validation'
-              'python-openapi-spec-validator: for validation')
-
-  cd apispec-$pkgver
-  python setup.py install --root="$pkgdir" --optimize=1
-  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}
-
-package_python2-apispec() {
-  depends=('python2')
-  optdepends=('python2-yaml: for yaml support')
-
-  cd apispec-$pkgver-py2
-  python2 setup.py install --root="$pkgdir" --optimize=1
-  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}

Copied: python-apispec/repos/community-testing-any/PKGBUILD (from rev 487576, python-apispec/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2019-07-07 02:14:10 UTC (rev 487577)
@@ -0,0 +1,53 @@
+# Maintainer: Felix Yan <felixonmars at archlinux.org>
+
+pkgbase=python-apispec
+pkgname=(python-apispec python2-apispec)
+pkgver=2.0.2
+pkgrel=1
+pkgdesc="A pluggable API specification generator. Currently supports the OpenAPI Specification."
+url="https://github.com/marshmallow-code/apispec"
+license=('MIT')
+arch=('any')
+makedepends=('python-setuptools' 'python2-setuptools')
+checkdepends=('python-pytest-runner' 'python-tornado' 'python-bottle' 'python-marshmallow'
+              'python-flask' 'python-prance' 'python-yaml' 'python-mock'
+              'python-openapi-spec-validator')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/marshmallow-code/apispec/archive/$pkgver.tar.gz")
+sha512sums=('c2b13ea631109fba224544932a2dd6bbc0552903686d176e693149095c8326e113569c7cfdab661a3a36f7eaf72b9f453714774ffb02a55155bccedfbef23a66')
+
+prepare() {
+  cp -a apispec-$pkgver{,-py2}
+}
+
+build() {
+  cd "$srcdir"/apispec-$pkgver
+  python setup.py build
+
+  cd "$srcdir"/apispec-$pkgver-py2
+  python2 setup.py build
+}
+
+check() {
+  cd apispec-$pkgver
+  python setup.py pytest
+}
+
+package_python-apispec() {
+  depends=('python')
+  optdepends=('python-yaml: for yaml support'
+              'python-prance: for validation'
+              'python-openapi-spec-validator: for validation')
+
+  cd apispec-$pkgver
+  python setup.py install --root="$pkgdir" --optimize=1
+  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python2-apispec() {
+  depends=('python2')
+  optdepends=('python2-yaml: for yaml support')
+
+  cd apispec-$pkgver-py2
+  python2 setup.py install --root="$pkgdir" --optimize=1
+  install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}


More information about the arch-commits mailing list