[arch-commits] Commit in podman/repos/community-x86_64 (PKGBUILD PKGBUILD)

Morten Linderud foxboron at archlinux.org
Mon Jul 8 09:52:46 UTC 2019


    Date: Monday, July 8, 2019 @ 09:52:46
  Author: foxboron
Revision: 487686

archrelease: copy trunk to community-x86_64

Added:
  podman/repos/community-x86_64/PKGBUILD
    (from rev 487685, podman/trunk/PKGBUILD)
Deleted:
  podman/repos/community-x86_64/PKGBUILD

----------+
 PKGBUILD |   96 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 48 insertions(+), 48 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2019-07-08 09:52:38 UTC (rev 487685)
+++ PKGBUILD	2019-07-08 09:52:46 UTC (rev 487686)
@@ -1,48 +0,0 @@
-# Maintainer: Bartłomiej Piotrowski <bpiotrowski at archlinux.org>
-
-pkgbase=podman
-pkgname=(podman podman-docker)
-pkgver=1.4.3
-pkgrel=1
-pkgdesc='Tool and library for running OCI-based containers in pods'
-arch=(x86_64)
-url='https://github.com/containers/libpod'
-license=(Apache)
-depends=(cni-plugins conmon device-mapper iptables libseccomp ostree runc skopeo
-         btrfs-progs slirp4netns)
-makedepends=(go-pie go-md2man git)
-source=(libpod-$pkgver.tar.gz::$url/archive/v${pkgver}.tar.gz)
-sha256sums=('68d25c2e04790044b4a7c87f1ab8a5e892831a3684ba6b9221903a04b177b26e')
-
-prepare() {
-  mkdir -p src/github.com/containers src/github.com/varlink
-  cp -r libpod-$pkgver src/github.com/containers/libpod
-}
-
-build() {
-  export GOPATH="$srcdir"
-  export BUILDTAGS='seccomp ostree varlink containers_image_ostree_stub'
-
-  # buildsystem passes LDFLAGS to GO's -ldflags, which isn't really compatible
-  unset LDFLAGS
-
-  cd src/github.com/containers/libpod
-  make install.tools
-  make
-}
-
-package_podman() {
-  optdepends=('podman-docker: for Docker-compatible CLI')
-
-  cd src/github.com/containers/libpod
-  make install install.completions install.config DESTDIR="$pkgdir" PREFIX=/usr
-}
-
-package_podman-docker() {
-  pkgdesc='Emulate Docker CLI using podman'
-  depends=(podman)
-  conflicts=(docker)
-
-  cd src/github.com/containers/libpod
-  make install.docker DESTDIR="$pkgdir" PREFIX=/usr
-}

Copied: podman/repos/community-x86_64/PKGBUILD (from rev 487685, podman/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2019-07-08 09:52:46 UTC (rev 487686)
@@ -0,0 +1,48 @@
+# Maintainer: Bartłomiej Piotrowski <bpiotrowski at archlinux.org>
+
+pkgbase=podman
+pkgname=(podman podman-docker)
+pkgver=1.4.4
+pkgrel=1
+pkgdesc='Tool and library for running OCI-based containers in pods'
+arch=(x86_64)
+url='https://github.com/containers/libpod'
+license=(Apache)
+depends=(cni-plugins conmon device-mapper iptables libseccomp ostree runc skopeo
+         btrfs-progs slirp4netns)
+makedepends=(go-pie go-md2man git)
+source=(libpod-$pkgver.tar.gz::$url/archive/v${pkgver}.tar.gz)
+sha256sums=('2e027c1b935f3a03f27ef7f17823ccf334607a17d033d4ce53a90b98294e7f68')
+
+prepare() {
+  mkdir -p src/github.com/containers src/github.com/varlink
+  cp -r libpod-$pkgver src/github.com/containers/libpod
+}
+
+build() {
+  export GOPATH="$srcdir"
+  export BUILDTAGS='seccomp ostree varlink containers_image_ostree_stub'
+
+  # buildsystem passes LDFLAGS to GO's -ldflags, which isn't really compatible
+  unset LDFLAGS
+
+  cd src/github.com/containers/libpod
+  make install.tools
+  make
+}
+
+package_podman() {
+  optdepends=('podman-docker: for Docker-compatible CLI')
+
+  cd src/github.com/containers/libpod
+  make install install.completions install.config DESTDIR="$pkgdir" PREFIX=/usr
+}
+
+package_podman-docker() {
+  pkgdesc='Emulate Docker CLI using podman'
+  depends=(podman)
+  conflicts=(docker)
+
+  cd src/github.com/containers/libpod
+  make install.docker DESTDIR="$pkgdir" PREFIX=/usr
+}


More information about the arch-commits mailing list