[arch-commits] Commit in gimp/repos (3 files)

Christian Hesse eworm at archlinux.org
Thu Jun 13 05:50:04 UTC 2019


    Date: Thursday, June 13, 2019 @ 05:50:04
  Author: eworm
Revision: 355994

archrelease: copy trunk to testing-x86_64

Added:
  gimp/repos/testing-x86_64/
  gimp/repos/testing-x86_64/PKGBUILD
    (from rev 355993, gimp/trunk/PKGBUILD)
  gimp/repos/testing-x86_64/linux.gpl
    (from rev 355993, gimp/trunk/linux.gpl)

-----------+
 PKGBUILD  |   63 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 linux.gpl |   19 ++++++++++++++++++
 2 files changed, 82 insertions(+)

Copied: gimp/repos/testing-x86_64/PKGBUILD (from rev 355993, gimp/trunk/PKGBUILD)
===================================================================
--- testing-x86_64/PKGBUILD	                        (rev 0)
+++ testing-x86_64/PKGBUILD	2019-06-13 05:50:04 UTC (rev 355994)
@@ -0,0 +1,63 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Daniel Isenmann <daniel at archlinux.org>
+
+pkgname=gimp
+pkgver=2.10.12
+pkgrel=1
+pkgdesc='GNU Image Manipulation Program'
+url='https://www.gimp.org/'
+arch=('x86_64')
+license=('GPL' 'LGPL')
+depends=('babl' 'dbus-glib' 'desktop-file-utils' 'gegl' 'glib-networking' 'hicolor-icon-theme'
+         'jasper' 'lcms2' 'libheif' 'libexif' 'libgudev' 'libmng' 'libmypaint' 'librsvg' 'libwebp'
+         'libwmf' 'libxmu' 'libxpm' 'mypaint-brushes' 'openexr' 'poppler-data' 'pygtk')
+makedepends=('alsa-lib' 'curl' 'ghostscript' 'gtk-doc' 'intltool' 'iso-codes' 'poppler-glib')
+optdepends=('gutenprint: for sophisticated printing only as gimp has built-in cups print support'
+            'poppler-glib: for pdf support'
+            'alsa-lib: for MIDI event controller module'
+            'curl: for URI support'
+            'ghostscript: for postscript support')
+conflicts=('gimp-plugin-wavelet-decompose')
+replaces=('gimp-plugin-wavelet-decompose')
+source=(https://download.gimp.org/pub/gimp/v${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
+        linux.gpl)
+sha256sums=('7d80b58e0784120d57d327294f6a1fda281ff51a61935c2cd764da281acaac71'
+            '1003bbf5fc292d0d63be44562f46506f7b2ca5729770da9d38d3bb2e8a2f36b3')
+
+prepare() {
+  cd ${pkgname}-${pkgver}
+  _mypaintver=$(echo /usr/lib/libmypaint-*.so | grep -o -E '\-[0-9]+(\.[0-9]+)*' | head -1)
+  sed -i "s|\\(libmypaint\\)\\( >= libmypaint_required_version\\)|\\1${_mypaintver}\\2|g" configure.ac
+  autoreconf -vi
+}
+
+build() {
+pkg-config --exists --print-errors "OpenEXR >= 1.6.1"
+  cd ${pkgname}-${pkgver}
+  PYTHON=/usr/bin/python2 ./configure \
+    --prefix=/usr \
+    --sysconfdir=/etc \
+    --libexecdir=/usr/bin \
+    --enable-mp \
+    --enable-gimp-console \
+    --enable-python \
+    --enable-gtk-doc \
+    --with-bug-report-url='https://bugs.archlinux.org/?string=gimp' \
+    --with-openexr \
+    --without-aa
+  sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+  make
+}
+
+package() {
+  cd ${pkgname}-${pkgver}
+  make DESTDIR="${pkgdir}" install
+  install -D -m644 "${srcdir}/linux.gpl" "${pkgdir}/usr/share/gimp/2.0/palettes/Linux.gpl"
+
+  rm "${pkgdir}/usr/share/man/man1/gimp-console.1"
+  ln -s gimp-console-${pkgver%.*}.1.gz "${pkgdir}/usr/share/man/man1/gimp-console.1.gz"
+  ln -s gimptool-2.0 "${pkgdir}/usr/bin/gimptool"
+  ln -sf gimptool-2.0.1.gz "${pkgdir}/usr/share/man/man1/gimptool.1.gz"
+}
+
+# vim: ts=2 sw=2 et:

Copied: gimp/repos/testing-x86_64/linux.gpl (from rev 355993, gimp/trunk/linux.gpl)
===================================================================
--- testing-x86_64/linux.gpl	                        (rev 0)
+++ testing-x86_64/linux.gpl	2019-06-13 05:50:04 UTC (rev 355994)
@@ -0,0 +1,19 @@
+GIMP Palette
+Name: linux
+#
+  0   0   0
+  0   0 170
+  0 170   0
+  0 170 170
+170   0   0
+170   0 170
+170  85   0
+170 170 170
+ 85  85  85
+ 85  85 255
+ 85 255  85
+ 85 255 255
+255  85  85
+255  85 255
+255 255  85
+255 255 255


More information about the arch-commits mailing list