[arch-commits] Commit in tensorboard/repos/community-x86_64 (PKGBUILD PKGBUILD)

Sven-Hendrik Haase svenstaro at archlinux.org
Mon Jun 17 23:03:05 UTC 2019


    Date: Monday, June 17, 2019 @ 23:03:04
  Author: svenstaro
Revision: 482048

archrelease: copy trunk to community-x86_64

Added:
  tensorboard/repos/community-x86_64/PKGBUILD
    (from rev 482047, tensorboard/trunk/PKGBUILD)
Deleted:
  tensorboard/repos/community-x86_64/PKGBUILD

----------+
 PKGBUILD |  106 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 53 insertions(+), 53 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2019-06-17 23:02:59 UTC (rev 482047)
+++ PKGBUILD	2019-06-17 23:03:04 UTC (rev 482048)
@@ -1,53 +0,0 @@
-# Maintainer: Sven-Hendrik Haase <sh at lutzhaase.com>
-
-pkgname=tensorboard
-pkgver=1.13.1
-pkgrel=1
-pkgdesc="TensorFlow's Visualization Toolkit"
-url='https://github.com/tensorflow/tensorboard'
-arch=('x86_64')
-license=('APACHE')
-depends=('python' 'python-werkzeug' 'python-numpy' 'python-bleach' 'python-wheel' 'python-markdown' 'python-tensorflow-serving-api'
-         'python-html5lib' 'python-protobuf' 'python-setuptools' 'python-tensorflow' 'python-grpcio')
-makedepends=('bazel' 'tree')
-source=("https://github.com/tensorflow/tensorboard/archive/${pkgver}.tar.gz")
-sha512sums=('13995728f9007b305d989180aba4da50ff70a1382e8f6121427db7cbdbb6139a971a1f4d96bc0bc9ce6795d432a528b1b08158a1b1ec2822939bb5d4f08e8e74')
-
-build() {
-  cd "$pkgname-$pkgver"
-
-  bazel build tensorboard:tensorboard
-  bazel build //tensorboard/pip_package:build_pip_package
-
-  mkdir pypackage
-  cp -R bazel-bin/tensorboard/pip_package/build_pip_package.runfiles/org_tensorflow_tensorboard/external pypackage
-  cp -R bazel-bin/tensorboard/pip_package/build_pip_package.runfiles/org_tensorflow_tensorboard/tensorboard pypackage
-  cp tensorboard/pip_package/{README.rst,MANIFEST.in} pypackage
-  cp README.md pypackage
-  cp tensorboard/pip_package/setup.py pypackage
-  cd pypackage
-  python setup.py build
-}
-
-package() {
-  cd "$pkgname-$pkgver"
-
-  install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
-  cd pypackage
-  python setup.py install --root="$pkgdir" --optimize=1
-
-  rm -r "$pkgdir"/usr/lib/python3.7/site-packages/external/
-
-  _requires="$pkgdir"/usr/lib/python3.7/site-packages/tensorboard-${pkgver}-py3.7.egg-info/requires.txt
-  # This is ugly: We need to patch it to use current bleach and html5lib
-  # because old ones are not even compatible with Python 3.6 and we don't have
-  # those in Arch of course.
-  sed -i 's/bleach==.*/bleach/' ${_requires}
-  sed -i 's/html5lib==.*/html5lib/' ${_requires}
-  # Other ugly hack: workaround for issues 650
-  # https://github.com/tensorflow/tensorboard/issues/650
-  sed -i '/^futures/d' ${_requires}
-}
-
-# vim:set ts=2 sw=2 et:

Copied: tensorboard/repos/community-x86_64/PKGBUILD (from rev 482047, tensorboard/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2019-06-17 23:03:04 UTC (rev 482048)
@@ -0,0 +1,53 @@
+# Maintainer: Sven-Hendrik Haase <sh at lutzhaase.com>
+
+pkgname=tensorboard
+pkgver=1.14.0
+pkgrel=1
+pkgdesc="TensorFlow's Visualization Toolkit"
+url='https://github.com/tensorflow/tensorboard'
+arch=('x86_64')
+license=('APACHE')
+depends=('python' 'python-werkzeug' 'python-numpy' 'python-bleach' 'python-wheel' 'python-markdown' 'python-tensorflow-serving-api'
+         'python-html5lib' 'python-protobuf' 'python-setuptools' 'python-tensorflow' 'python-grpcio')
+makedepends=('bazel' 'tree')
+source=("https://github.com/tensorflow/tensorboard/archive/${pkgver}.tar.gz")
+sha512sums=('fa42928371a37468d005c3736d21e6a9453dc509c58da405168d1b72e10cc93e857aaf852539721d51c8ab83cf9991250ea165a8798c8acc5c66d022ef8e2c16')
+
+build() {
+  cd "$pkgname-$pkgver"
+
+  bazel build tensorboard:tensorboard
+  bazel build //tensorboard/pip_package:build_pip_package
+
+  mkdir pypackage
+  cp -R bazel-bin/tensorboard/pip_package/build_pip_package.runfiles/org_tensorflow_tensorboard/external pypackage
+  cp -R bazel-bin/tensorboard/pip_package/build_pip_package.runfiles/org_tensorflow_tensorboard/tensorboard pypackage
+  cp tensorboard/pip_package/{README.rst,MANIFEST.in} pypackage
+  cp README.md pypackage
+  cp tensorboard/pip_package/setup.py pypackage
+  cd pypackage
+  python setup.py build
+}
+
+package() {
+  cd "$pkgname-$pkgver"
+
+  install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+  cd pypackage
+  python setup.py install --root="$pkgdir" --optimize=1
+
+  rm -r "$pkgdir"/usr/lib/python3.7/site-packages/external/
+
+  _requires="$pkgdir"/usr/lib/python3.7/site-packages/tensorboard-${pkgver}-py3.7.egg-info/requires.txt
+  # This is ugly: We need to patch it to use current bleach and html5lib
+  # because old ones are not even compatible with Python 3.6 and we don't have
+  # those in Arch of course.
+  sed -i 's/bleach==.*/bleach/' ${_requires}
+  sed -i 's/html5lib==.*/html5lib/' ${_requires}
+  # Other ugly hack: workaround for issues 650
+  # https://github.com/tensorflow/tensorboard/issues/650
+  sed -i '/^futures/d' ${_requires}
+}
+
+# vim:set ts=2 sw=2 et:


More information about the arch-commits mailing list