[arch-commits] Commit in anki/repos (4 files)

Johannes Löthberg demize at archlinux.org
Sun Mar 31 13:31:53 UTC 2019


    Date: Sunday, March 31, 2019 @ 13:31:52
  Author: demize
Revision: 446688

db-move: moved anki from [community-testing] to [community] (any)

Added:
  anki/repos/community-any/PKGBUILD
    (from rev 446687, anki/repos/community-testing-any/PKGBUILD)
Deleted:
  anki/repos/community-any/PKGBUILD
  anki/repos/community-any/anki-pyqtwebengine.patch
  anki/repos/community-testing-any/

----------------------------------------+
 /PKGBUILD                              |   31 +++++++++++++++++++++++++
 community-any/PKGBUILD                 |   38 -------------------------------
 community-any/anki-pyqtwebengine.patch |   11 --------
 3 files changed, 31 insertions(+), 49 deletions(-)

Deleted: community-any/PKGBUILD
===================================================================
--- community-any/PKGBUILD	2019-03-31 13:18:49 UTC (rev 446687)
+++ community-any/PKGBUILD	2019-03-31 13:31:52 UTC (rev 446688)
@@ -1,38 +0,0 @@
-# Maintainer: Johannes Löthberg <johannes at kyriasis.com>
-# Contributor: Sergej Pupykin <pupykin.s+arch at gmail.com>
-# Contributor: Timm Preetz <timm at preetz.us>
-# Contributor: Michael 'manveru' Fellinger <m.fellinger at gmail.com>
-# Contributor: Dave Pretty <david dot pretty at gmail dot com>
-
-pkgname=anki
-pkgver=2.1.8
-pkgrel=3
-
-pkgdesc="Helps you remember facts (like words/phrases in a foreign language) efficiently"
-url="https://ankisrs.net/"
-arch=('any')
-license=('AGPL3')
-
-depends=('qt5-webengine' 'python-beautifulsoup4' 'python-pyaudio'
-         'python-pyqt5' 'python-pyqtwebengine' 'python-requests' 'python-send2trash'
-         'python-decorator' 'python-markdown'
-         'desktop-file-utils')
-optdepends=('lame: record sound'
-            'mpv: play sound (prefered over mplayer)'
-            'mplayer: play sound')
-
-source=(https://apps.ankiweb.net/downloads/current/anki-$pkgver-source.tgz
-        anki-pyqtwebengine.patch)
-sha256sums=('57c466884ba43ef704c438bb0129e7ed793c468d36ea03cd3007af7a394c8b23'
-            '56cf512a5f023d61fa2b18348a5586b4489d48ac89a8c60612ef61dbe1809c4a')
-
-prepare() {
-  cd anki-$pkgver
-  patch -p1 -i ../anki-pyqtwebengine.patch # Compatibility with split pyqtwebengine
-}
-
-package() {
-  cd anki-$pkgver
-
-  make DESTDIR="$pkgdir" PREFIX=/usr install
-}

Copied: anki/repos/community-any/PKGBUILD (from rev 446687, anki/repos/community-testing-any/PKGBUILD)
===================================================================
--- community-any/PKGBUILD	                        (rev 0)
+++ community-any/PKGBUILD	2019-03-31 13:31:52 UTC (rev 446688)
@@ -0,0 +1,31 @@
+# Maintainer: Johannes Löthberg <johannes at kyriasis.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch at gmail.com>
+# Contributor: Timm Preetz <timm at preetz.us>
+# Contributor: Michael 'manveru' Fellinger <m.fellinger at gmail.com>
+# Contributor: Dave Pretty <david dot pretty at gmail dot com>
+
+pkgname=anki
+pkgver=2.1.11
+pkgrel=1
+
+pkgdesc="Helps you remember facts (like words/phrases in a foreign language) efficiently"
+url="https://ankisrs.net/"
+arch=('any')
+license=('AGPL3')
+
+depends=('qt5-webengine' 'python-beautifulsoup4' 'python-pyaudio'
+         'python-pyqt5' 'python-pyqtwebengine' 'python-requests' 'python-send2trash'
+         'python-decorator' 'python-markdown'
+         'desktop-file-utils')
+optdepends=('lame: record sound'
+            'mpv: play sound. prefered over mplayer'
+            'mplayer: play sound')
+
+source=(https://apps.ankiweb.net/downloads/current/anki-$pkgver-source.tgz)
+sha256sums=('787ce3d7333cc3f33f9bd18ec11d4da56b9ac060edaad21d78fe04e04e559265')
+
+package() {
+  cd anki-$pkgver
+
+  make DESTDIR="$pkgdir" PREFIX=/usr install
+}

Deleted: community-any/anki-pyqtwebengine.patch
===================================================================
--- community-any/anki-pyqtwebengine.patch	2019-03-31 13:18:49 UTC (rev 446687)
+++ community-any/anki-pyqtwebengine.patch	2019-03-31 13:31:52 UTC (rev 446688)
@@ -1,11 +0,0 @@
---- anki-2.1.8/aqt/qt.py.orig	2019-02-12 21:32:36.515462520 +0000
-+++ anki-2.1.8/aqt/qt.py	2019-02-12 21:32:45.032117131 +0000
-@@ -13,7 +13,7 @@
- from PyQt5.Qt import *
- # trigger explicit message in case of missing libraries
- # instead of silently failing to import
--from PyQt5.QtWebEngineWidgets import QWebEnginePage
-+from PyQt5.QtWebEngineWidgets import *
- try:
-     from PyQt5 import sip
- except ImportError:


More information about the arch-commits mailing list