[arch-commits] Commit in gcin/repos/community-x86_64 (4 files)

Antonio Rojas arojas at archlinux.org
Wed May 1 09:26:19 UTC 2019


    Date: Wednesday, May 1, 2019 @ 09:26:18
  Author: arojas
Revision: 457396

archrelease: copy trunk to community-x86_64

Added:
  gcin/repos/community-x86_64/PKGBUILD
    (from rev 457395, gcin/trunk/PKGBUILD)
  gcin/repos/community-x86_64/fix-gtk-immodules-path.patch
    (from rev 457395, gcin/trunk/fix-gtk-immodules-path.patch)
Deleted:
  gcin/repos/community-x86_64/PKGBUILD
  gcin/repos/community-x86_64/fix-gtk-immodules-path.patch

------------------------------+
 PKGBUILD                     |   97 ++++++++++++++++++++---------------------
 fix-gtk-immodules-path.patch |   48 ++++++++++----------
 2 files changed, 72 insertions(+), 73 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2019-05-01 09:25:53 UTC (rev 457395)
+++ PKGBUILD	2019-05-01 09:26:18 UTC (rev 457396)
@@ -1,49 +0,0 @@
-# Maintainer: Chih-Hsuan Yen <yan12125 at archlinux.org>
-# Contributor: Felix Yan <felixonmars at archlinux.org>
-# Contributor: Gaetan Bisson <bisson at archlinux.org>
-# Contributor: Andreas Radke <andyrtr at archlinux.org>
-# Contributor: damir <damir at archlinux.org>
-
-pkgname=gcin
-pkgver=2.8.9
-pkgrel=1
-pkgdesc='Input method server supporting various input methods'
-url='https://hyperrate.com/dir.php?eid=67'
-license=('LGPL')
-arch=('x86_64')
-depends=('gtk3' 'libxtst')
-makedepends=('qt5-base' 'qt4' 'gtk2' 'anthy')
-optdepends=('qt5-base: support for qt5 input method'
-            'qt4: support for qt4 input method'
-            'gtk2: support for gtk2 input method'
-            'anthy: support for anthy input method'
-            'curl: for downloading and uploading vocabulary databases via ts-edit')
-source=("https://hyperrate.com/gcin-source/${pkgname}-${pkgver}.tar.xz"
-        fix-gtk-immodules-path.patch)
-sha512sums=('36813c124bb0ad37a5d3e5fde2ce6aecab9d6702e294b0196da1a830690145371d051909244477dcaca66afce7bba96a8c8f0931b97ad81c61fae8eacef29e17'
-            '54e90b04de45acf9f8821c92234b9708281907cbdf24ebb29f9820945615669d82a8443e49fd49d6c08be4a7b9f2857c8e763f170ef879c8fab1f232bb67e85d')
-
-prepare() {
-    cd "${srcdir}/${pkgname}-${pkgver}"
-    sed 's/lib64/lib/g' -i configure
-    sed '/include suffixes-rule/a \
-        CFLAGS+='"${CFLAGS}"' \
-        LDFLAGS+='"${LDFLAGS}"' \
-        OPTFLAGS=' \
-        -i Makefile
-    sed \
-        -e 's:QT=qt5:QT=qt:' \
-        -i qt5-im/Makefile59
-    patch -Np1 -i ../fix-gtk-immodules-path.patch
-}
-
-build() {
-    cd "${srcdir}/${pkgname}-${pkgver}"
-    ./configure --prefix=/usr --use_i18n=Y
-    make
-}
-
-package() {
-    cd "${srcdir}/${pkgname}-${pkgver}"
-    make DESTDIR="${pkgdir}" install
-}

Copied: gcin/repos/community-x86_64/PKGBUILD (from rev 457395, gcin/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2019-05-01 09:26:18 UTC (rev 457396)
@@ -0,0 +1,48 @@
+# Maintainer: Chih-Hsuan Yen <yan12125 at archlinux.org>
+# Contributor: Felix Yan <felixonmars at archlinux.org>
+# Contributor: Gaetan Bisson <bisson at archlinux.org>
+# Contributor: Andreas Radke <andyrtr at archlinux.org>
+# Contributor: damir <damir at archlinux.org>
+
+pkgname=gcin
+pkgver=2.8.9
+pkgrel=2
+pkgdesc='Input method server supporting various input methods'
+url='https://hyperrate.com/dir.php?eid=67'
+license=('LGPL')
+arch=('x86_64')
+depends=('gtk3' 'libxtst')
+makedepends=('qt5-base' 'gtk2' 'anthy')
+optdepends=('qt5-base: support for qt5 input method'
+            'gtk2: support for gtk2 input method'
+            'anthy: support for anthy input method'
+            'curl: for downloading and uploading vocabulary databases via ts-edit')
+source=("https://hyperrate.com/gcin-source/${pkgname}-${pkgver}.tar.xz"
+        fix-gtk-immodules-path.patch)
+sha512sums=('36813c124bb0ad37a5d3e5fde2ce6aecab9d6702e294b0196da1a830690145371d051909244477dcaca66afce7bba96a8c8f0931b97ad81c61fae8eacef29e17'
+            '54e90b04de45acf9f8821c92234b9708281907cbdf24ebb29f9820945615669d82a8443e49fd49d6c08be4a7b9f2857c8e763f170ef879c8fab1f232bb67e85d')
+
+prepare() {
+    cd "${srcdir}/${pkgname}-${pkgver}"
+    sed 's/lib64/lib/g' -i configure
+    sed '/include suffixes-rule/a \
+        CFLAGS+='"${CFLAGS}"' \
+        LDFLAGS+='"${LDFLAGS}"' \
+        OPTFLAGS=' \
+        -i Makefile
+    sed \
+        -e 's:QT=qt5:QT=qt:' \
+        -i qt5-im/Makefile59
+    patch -Np1 -i ../fix-gtk-immodules-path.patch
+}
+
+build() {
+    cd "${srcdir}/${pkgname}-${pkgver}"
+    ./configure --prefix=/usr --use_i18n=Y
+    make -j1
+}
+
+package() {
+    cd "${srcdir}/${pkgname}-${pkgver}"
+    make DESTDIR="${pkgdir}" install
+}

Deleted: fix-gtk-immodules-path.patch
===================================================================
--- fix-gtk-immodules-path.patch	2019-05-01 09:25:53 UTC (rev 457395)
+++ fix-gtk-immodules-path.patch	2019-05-01 09:26:18 UTC (rev 457396)
@@ -1,24 +0,0 @@
-diff -ur gcin-2.8.9.orig/gtk-im/Makefile gcin-2.8.9/gtk-im/Makefile
---- gcin-2.8.9.orig/gtk-im/Makefile	2019-03-14 21:31:09.553500793 +0800
-+++ gcin-2.8.9/gtk-im/Makefile	2019-03-14 22:07:00.917828776 +0800
-@@ -1,7 +1,7 @@
- include ../config.mak
- 
- OBJS = imgcin.o gtkimcontextgcin.o
--GTK2IM=gtk-2.0/immodules
-+GTK2IM=gtk-2.0/`pkg-config --variable=gtk_binary_version gtk+-2.0`/immodules
- GTKINC=`pkg-config --cflags gtk+-2.0`
- LDFLAGS=`pkg-config --libs gtk+-2.0`
- IMMODULES=$(libdir)/$(GTK2IM)
-diff -ur gcin-2.8.9.orig/gtk3-im/Makefile gcin-2.8.9/gtk3-im/Makefile
---- gcin-2.8.9.orig/gtk3-im/Makefile	2019-03-14 21:31:09.553500793 +0800
-+++ gcin-2.8.9/gtk3-im/Makefile	2019-03-14 22:06:40.175065314 +0800
-@@ -1,7 +1,7 @@
- include ../config.mak
- 
- OBJS = imgcin.o gtkimcontextgcin.o
--GTK3IM=gtk-3.0/immodules
-+GTK3IM=gtk-3.0/`pkg-config --variable=gtk_binary_version gtk+-3.0`/immodules
- GTKINC=`pkg-config --cflags gtk+-3.0`
- LDFLAGS=`pkg-config --libs gtk+-3.0`
- LDFLAGS+='-Wl,--as-needed'

Copied: gcin/repos/community-x86_64/fix-gtk-immodules-path.patch (from rev 457395, gcin/trunk/fix-gtk-immodules-path.patch)
===================================================================
--- fix-gtk-immodules-path.patch	                        (rev 0)
+++ fix-gtk-immodules-path.patch	2019-05-01 09:26:18 UTC (rev 457396)
@@ -0,0 +1,24 @@
+diff -ur gcin-2.8.9.orig/gtk-im/Makefile gcin-2.8.9/gtk-im/Makefile
+--- gcin-2.8.9.orig/gtk-im/Makefile	2019-03-14 21:31:09.553500793 +0800
++++ gcin-2.8.9/gtk-im/Makefile	2019-03-14 22:07:00.917828776 +0800
+@@ -1,7 +1,7 @@
+ include ../config.mak
+ 
+ OBJS = imgcin.o gtkimcontextgcin.o
+-GTK2IM=gtk-2.0/immodules
++GTK2IM=gtk-2.0/`pkg-config --variable=gtk_binary_version gtk+-2.0`/immodules
+ GTKINC=`pkg-config --cflags gtk+-2.0`
+ LDFLAGS=`pkg-config --libs gtk+-2.0`
+ IMMODULES=$(libdir)/$(GTK2IM)
+diff -ur gcin-2.8.9.orig/gtk3-im/Makefile gcin-2.8.9/gtk3-im/Makefile
+--- gcin-2.8.9.orig/gtk3-im/Makefile	2019-03-14 21:31:09.553500793 +0800
++++ gcin-2.8.9/gtk3-im/Makefile	2019-03-14 22:06:40.175065314 +0800
+@@ -1,7 +1,7 @@
+ include ../config.mak
+ 
+ OBJS = imgcin.o gtkimcontextgcin.o
+-GTK3IM=gtk-3.0/immodules
++GTK3IM=gtk-3.0/`pkg-config --variable=gtk_binary_version gtk+-3.0`/immodules
+ GTKINC=`pkg-config --cflags gtk+-3.0`
+ LDFLAGS=`pkg-config --libs gtk+-3.0`
+ LDFLAGS+='-Wl,--as-needed'


More information about the arch-commits mailing list