[arch-commits] Commit in borg/trunk (2 files)

Evangelos Foutras foutrelis at archlinux.org
Sat May 25 16:59:53 UTC 2019


    Date: Saturday, May 25, 2019 @ 16:59:52
  Author: foutrelis
Revision: 470685

upgpkg: borg 1.1.10-1

New upstream release; bundles msgpack (fixing FS#61346).

Modified:
  borg/trunk/PKGBUILD
Deleted:
  borg/trunk/0001-Fix-msgpack-version-constraints-using-proper-setupto.patch

-----------------------------------------------------------------+
 0001-Fix-msgpack-version-constraints-using-proper-setupto.patch |   31 ----------
 PKGBUILD                                                        |   25 +-------
 2 files changed, 5 insertions(+), 51 deletions(-)

Deleted: 0001-Fix-msgpack-version-constraints-using-proper-setupto.patch
===================================================================
--- 0001-Fix-msgpack-version-constraints-using-proper-setupto.patch	2019-05-25 16:59:38 UTC (rev 470684)
+++ 0001-Fix-msgpack-version-constraints-using-proper-setupto.patch	2019-05-25 16:59:52 UTC (rev 470685)
@@ -1,31 +0,0 @@
-From 53671fd85a33d73699b80564da345ffc9b73c3e5 Mon Sep 17 00:00:00 2001
-From: Eli Schwartz <eschwartz at archlinux.org>
-Date: Mon, 11 Jun 2018 18:56:50 -0400
-Subject: [PATCH] Fix msgpack version constraints using proper setuptools
- metadata.
-
-Embrace environment markers (a.k.a. PEP 508 compliance)! They let you do
-sane handling of different requirements for different versions of
-python. There's no need to bend over backwards to try to ensure usage of
-python34-compatible dependencies on python36.
----
- setup.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 253a050a..22aabbbe 100644
---- a/setup.py
-+++ b/setup.py
-@@ -39,7 +39,8 @@
-     # we are rather picky about msgpack versions, because a good working msgpack is
-     # very important for borg, see https://github.com/borgbackup/borg/issues/3753
-     # best versions seem to be 0.4.6, 0.4.7, 0.4.8 and 0.5.6:
--    'msgpack-python >=0.4.6, <=0.5.6, !=0.5.0, !=0.5.1, !=0.5.2, !=0.5.3, !=0.5.4, !=0.5.5',
-+    'msgpack-python >=0.4.6, <0.5;python_version=="3.4"',
-+    'msgpack >=0.5.6;python_version >="3.5"',
-     # if you can't satisfy the above requirement, these are versions that might
-     # also work ok, IF you make sure to use the COMPILED version of msgpack-python,
-     # NOT the PURE PYTHON fallback implementation: ==0.5.1, ==0.5.4
--- 
-2.19.0
-

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2019-05-25 16:59:38 UTC (rev 470684)
+++ PKGBUILD	2019-05-25 16:59:52 UTC (rev 470685)
@@ -3,13 +3,13 @@
 
 pkgname=borg
 _pkgname=borgbackup
-pkgver=1.1.8
+pkgver=1.1.10
 pkgrel=1
 pkgdesc='Deduplicating backup program with compression and authenticated encryption'
 url='https://borgbackup.github.io/'
 license=('BSD')
 arch=('x86_64')
-depends=('acl' 'lz4' 'openssl' 'python-msgpack' 'python-setuptools' 'xz' 'zstd')
+depends=('acl' 'lz4' 'openssl' 'python-setuptools' 'xz' 'zstd')
 optdepends=('openssh: repositories on remote hosts'
             'python-llfuse: mounting backups as a FUSE file system')
 makedepends=('cython' 'python-sphinx' 'python-guzzle-sphinx-theme')
@@ -16,26 +16,11 @@
 checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-benchmark' 'python-mock')
 provides=('borgbackup')
 replaces=('borgbackup')
-source=("https://github.com/$_pkgname/$pkgname/releases/download/$pkgver/$_pkgname-$pkgver.tar.gz"{,.asc}
-        "0001-Fix-msgpack-version-constraints-using-proper-setupto.patch")
-sha256sums=('0b4370480ca0114cb0bb534286241af8a35c6ffb71404dfa409ed06099661b63'
-            'SKIP'
-            '0392d573928aa8282ddb3082289a42ade7503aa285d575ce06d6296327518744')
+source=("https://github.com/$_pkgname/$pkgname/releases/download/$pkgver/$_pkgname-$pkgver.tar.gz"{,.asc})
+sha256sums=('efb41416d24ff1d13c7952c7f4eaf41ef6fc5e1000354217db55cd62c905e7de'
+            'SKIP')
 validpgpkeys=('6D5BEF9ADD2075805747B70F9F88FB52FAF7B393') # Thomas Waldmann <tw at waldmann-edv.de>
 
-prepare() {
-  cd "$srcdir/$_pkgname-$pkgver"
-
-  # msgpack versions are constantly broken: https://bugs.archlinux.org/task/58974
-  # patch submitted upstream as https://github.com/borgbackup/borg/pull/3891
-  # but upstream refuses to merge it, claiming that it *breaks* compatibility
-  # rather than adds it??? We're specifically using a patch since otherwise,
-  # this keeps on breaking with every single release, and we need to check
-  # every single time that it isn't broken again. New versions *cannot* simply
-  # be trusted to be sane.
-  patch -p1 -i ../0001-Fix-msgpack-version-constraints-using-proper-setupto.patch
-}
-
 build() {
   cd "$srcdir/$_pkgname-$pkgver"
   python setup.py build


More information about the arch-commits mailing list