[arch-commits] Commit in dart/repos/community-x86_64 (PKGBUILD PKGBUILD)

Felix Yan felixonmars at archlinux.org
Fri May 31 17:33:23 UTC 2019


    Date: Friday, May 31, 2019 @ 17:33:23
  Author: felixonmars
Revision: 476072

archrelease: copy trunk to community-x86_64

Added:
  dart/repos/community-x86_64/PKGBUILD
    (from rev 476071, dart/trunk/PKGBUILD)
Deleted:
  dart/repos/community-x86_64/PKGBUILD

----------+
 PKGBUILD |  122 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 61 insertions(+), 61 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2019-05-31 17:33:17 UTC (rev 476071)
+++ PKGBUILD	2019-05-31 17:33:23 UTC (rev 476072)
@@ -1,61 +0,0 @@
-# Maintainer: Alexander Rødseth <rodseth at gmail.com>
-# Maintainer: Felix Yan <felixonmars at archlinux.org>
-# Contributor: T. Jameson Little <t.jameson.little at gmail dot com>
-# Contributor: Usagi Ito <usagi at WonderRabbitProject.net>
-# Contributor: siasia <http://pastebin.com/qsBEmNCw>
-# Contributor: Julien Nicoulaud <julien.nicoulaud at gmail.com>
-
-pkgname=dart
-pkgver=2.3.1
-pkgrel=1
-pkgdesc='The dart programming language SDK'
-arch=('x86_64')
-url='http://www.dartlang.org/'
-license=('BSD')
-makedepends=('setconf')
-options=('!strip')
-source_x86_64+=("$pkgname-$pkgver-64.zip::http://storage.googleapis.com/dart-archive/channels/stable/release/latest/sdk/dartsdk-linux-x64-release.zip")
-sha512sums_x86_64=('9115883a89e015e43eb2a3fd24b547a3667f79aee62c8c649107818aa7241a0eb26b9f87c0b07dd7528238f68ba5bd6063719e0780d847e45d5ca67e1600fe5c')
-
-prepare() {
-  # Fix permissions
-  find "$pkgname-sdk" -type d -exec chmod 0755 '{}' + \
-    -or -type f -exec chmod 0644 '{}' +
-  chmod +x "$pkgname-sdk/bin/"*
-
-  cd "$pkgname-sdk/bin"
-
-  # Configure paths
-  for _f in dart2js dartanalyzer pub dartfmt dartdevc dartdoc; do
-    setconf $_f BIN_DIR "/opt/$pkgname-sdk/bin"
-    setconf $_f PROG_NAME "/opt/$pkgname-sdk/bin/$_f"
-    setconf $_f SDK_DIR "/opt/$pkgname-sdk/"
-  done
-
-  # Extract license (AUTHORS and LICENSE files are missing)
-  head -n5 "../include/dart_api.h" > ../../LICENSE
-}
-
-package() {
-  # Create directories
-  install -d "$pkgdir"{"/opt/$pkgname-sdk",/usr/{bin,"share/doc/$pkgname-sdk"}}
-
-  # Package the files
-  cp -a "$pkgname-sdk/"* "$pkgdir/opt/$pkgname-sdk/"
-
-  # Set up symbolic links for the executables
-  for f in dart dart2js dartanalyzer pub dartfmt dartdevc dartdoc; do
-    ln -s "/opt/$pkgname-sdk/bin/$f" "$pkgdir/usr/bin/$f"
-  done
-
-  # Package samples and documentation
-  for f in samples about.html about_files; do
-    echo mv "$pkgdir/opt/$pkgname-sdk/$f" "$pkgdir/usr/share/doc/$pkgname/"
-  done
-
-  # BSD License
-  install -Dm644 LICENSE \
-    "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
-
-# vim:set ts=2 sw=2 et:

Copied: dart/repos/community-x86_64/PKGBUILD (from rev 476071, dart/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2019-05-31 17:33:23 UTC (rev 476072)
@@ -0,0 +1,61 @@
+# Maintainer: Alexander Rødseth <rodseth at gmail.com>
+# Maintainer: Felix Yan <felixonmars at archlinux.org>
+# Contributor: T. Jameson Little <t.jameson.little at gmail dot com>
+# Contributor: Usagi Ito <usagi at WonderRabbitProject.net>
+# Contributor: siasia <http://pastebin.com/qsBEmNCw>
+# Contributor: Julien Nicoulaud <julien.nicoulaud at gmail.com>
+
+pkgname=dart
+pkgver=2.3.1
+pkgrel=2
+pkgdesc='The dart programming language SDK'
+arch=('x86_64')
+url='https://www.dartlang.org/'
+depends=('bash')
+license=('BSD')
+makedepends=('setconf')
+options=('!strip')
+source=("$pkgname-$pkgver-64.zip::https://storage.googleapis.com/dart-archive/channels/stable/release/latest/sdk/dartsdk-linux-x64-release.zip")
+sha512sums=('9115883a89e015e43eb2a3fd24b547a3667f79aee62c8c649107818aa7241a0eb26b9f87c0b07dd7528238f68ba5bd6063719e0780d847e45d5ca67e1600fe5c')
+
+prepare() {
+  # Fix permissions
+  find "$pkgname-sdk" -type d -exec chmod a+rx '{}' + \
+    -or -type f -exec chmod a+r '{}' +
+
+  cd "$pkgname-sdk/bin"
+
+  # Configure paths
+  for _f in dart2js dartanalyzer pub dartfmt dartdevc dartdoc; do
+    setconf $_f BIN_DIR "/opt/$pkgname-sdk/bin"
+    setconf $_f PROG_NAME "/opt/$pkgname-sdk/bin/$_f"
+    setconf $_f SDK_DIR "/opt/$pkgname-sdk/"
+  done
+
+  # Extract license (AUTHORS and LICENSE files are missing)
+  head -n5 "../include/dart_api.h" > ../../LICENSE
+}
+
+package() {
+  # Create directories
+  install -d "$pkgdir"{"/opt/$pkgname-sdk",/usr/{bin,"share/doc/$pkgname-sdk"}}
+
+  # Package the files
+  cp -a "$pkgname-sdk/"* "$pkgdir/opt/$pkgname-sdk/"
+
+  # Set up symbolic links for the executables
+  for f in dart dart2js dartanalyzer pub dartfmt dartdevc dartdoc dart2aot dartaotruntime; do
+    ln -s "/opt/$pkgname-sdk/bin/$f" "$pkgdir/usr/bin/$f"
+  done
+
+  # Package samples and documentation
+  for f in samples about.html about_files; do
+    echo mv "$pkgdir/opt/$pkgname-sdk/$f" "$pkgdir/usr/share/doc/$pkgname/"
+  done
+
+  # BSD License
+  install -Dm644 LICENSE \
+    "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:


More information about the arch-commits mailing list