[arch-commits] Commit in tensorboard/repos/community-testing-x86_64 (6 files)

Konstantin Gizdov kgizdov at archlinux.org
Fri Apr 10 15:33:18 UTC 2020


    Date: Friday, April 10, 2020 @ 15:33:17
  Author: kgizdov
Revision: 613120

archrelease: copy trunk to community-testing-x86_64

Added:
  tensorboard/repos/community-testing-x86_64/PKGBUILD
    (from rev 613119, tensorboard/trunk/PKGBUILD)
  tensorboard/repos/community-testing-x86_64/bump-tensorflow.patch
    (from rev 613119, tensorboard/trunk/bump-tensorflow.patch)
  tensorboard/repos/community-testing-x86_64/fix-grpc-deps.patch
    (from rev 613119, tensorboard/trunk/fix-grpc-deps.patch)
Deleted:
  tensorboard/repos/community-testing-x86_64/PKGBUILD
  tensorboard/repos/community-testing-x86_64/bump-tensorflow.patch
  tensorboard/repos/community-testing-x86_64/fix-grpc-deps.patch

-----------------------+
 PKGBUILD              |  127 ++++++++++++++++++++++++------------------------
 bump-tensorflow.patch |   36 ++++++-------
 fix-grpc-deps.patch   |   94 +++++++++++++++++------------------
 3 files changed, 129 insertions(+), 128 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2020-04-10 15:33:09 UTC (rev 613119)
+++ PKGBUILD	2020-04-10 15:33:17 UTC (rev 613120)
@@ -1,63 +0,0 @@
-# Maintainer: Sven-Hendrik Haase <sh at lutzhaase.com>
-
-pkgname=tensorboard
-pkgver=2.2.0
-pkgrel=2
-pkgdesc="TensorFlow's Visualization Toolkit"
-url='https://github.com/tensorflow/tensorboard'
-arch=('x86_64')
-license=('APACHE')
-depends=('python' 'python-werkzeug' 'python-numpy' 'python-bleach' 'python-wheel' 'python-markdown' 'python-tensorflow-serving-api'
-         'python-html5lib' 'python-protobuf' 'python-setuptools' 'python-tensorflow' 'python-grpcio' 'python-google-auth-oauthlib')
-makedepends=('bazel' 'tree')
-source=("${pkgname}-${pkgver}::https://github.com/tensorflow/tensorboard/archive/${pkgver}.tar.gz"
-        'bump-tensorflow.patch'
-        'fix-grpc-deps.patch')
-sha512sums=('05da0d879c20c86a3f307aa712e779cab442292c5628086175af141398029d65f119b81a21e08d866ab2e89e9159d036b59a1b22e39a668a7a72a95c79a7af2f'
-            '088a9310d2a62603fda2ca05eae16fab3fb82b3250533beb06ec5551b671ff71c11ddb6a338234b0790c5db61790dcddc08969cca5d07a84ed668bddff2b8542'
-            'e3b339285ea1ee46e0cc560f9ef509d2307d15090bc740ae9cc322daafd1ccccdb118045ffff8b565a234043049c5208679bb982360b7b364df7d97ffe671669')
-
-prepare() {
-  cd "$pkgname-$pkgver"
-
-  patch -Np1 -i "${srcdir}/bump-tensorflow.patch"
-  patch -Np1 -i "${srcdir}/fix-grpc-deps.patch"
-}
-
-build() {
-  cd "$pkgname-$pkgver"
-
-  bazel build --experimental_repo_remote_exec tensorboard:tensorboard
-  bazel build --experimental_repo_remote_exec //tensorboard/pip_package:build_pip_package
-
-  mkdir pypackage
-  cp -R bazel-bin/tensorboard/pip_package/build_pip_package.runfiles/org_tensorflow_tensorboard/external pypackage
-  cp -R bazel-bin/tensorboard/pip_package/build_pip_package.runfiles/org_tensorflow_tensorboard/tensorboard pypackage
-  cp tensorboard/pip_package/{README.rst,MANIFEST.in,setup.py,requirements.txt} pypackage
-  cp README.md pypackage
-  cd pypackage
-  python setup.py build
-}
-
-package() {
-  cd "$pkgname-$pkgver"
-
-  install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
-  cd pypackage
-  python setup.py install --root="$pkgdir" --optimize=1
-
-  rm -r "$pkgdir"/usr/lib/python3.8/site-packages/external/
-
-  _requires="$pkgdir"/usr/lib/python3.8/site-packages/tensorboard-${pkgver}-py3.8.egg-info/requires.txt
-  # This is ugly: We need to patch it to use current bleach and html5lib
-  # because old ones are not even compatible with Python 3.6 and we don't have
-  # those in Arch of course.
-  sed -i 's/bleach==.*/bleach/' ${_requires}
-  sed -i 's/html5lib==.*/html5lib/' ${_requires}
-  # Other ugly hack: workaround for issues 650
-  # https://github.com/tensorflow/tensorboard/issues/650
-  sed -i '/^futures/d' ${_requires}
-}
-
-# vim:set ts=2 sw=2 et:

Copied: tensorboard/repos/community-testing-x86_64/PKGBUILD (from rev 613119, tensorboard/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2020-04-10 15:33:17 UTC (rev 613120)
@@ -0,0 +1,64 @@
+# Maintainer: Sven-Hendrik Haase <sh at lutzhaase.com>
+
+pkgname=tensorboard
+pkgver=2.2.0
+pkgrel=3
+pkgdesc="TensorFlow's Visualization Toolkit"
+url='https://github.com/tensorflow/tensorboard'
+arch=('x86_64')
+license=('APACHE')
+depends=('python' 'python-werkzeug' 'python-numpy' 'python-bleach' 'python-wheel' 'python-markdown' 'python-tensorflow-serving-api'
+         'python-html5lib' 'python-protobuf' 'python-setuptools' 'python-tensorflow' 'python-grpcio' 'python-google-auth-oauthlib'
+         'python-tensorboard_plugin_wit')
+makedepends=('bazel' 'tree')
+source=("${pkgname}-${pkgver}::https://github.com/tensorflow/tensorboard/archive/${pkgver}.tar.gz"
+        'bump-tensorflow.patch'
+        'fix-grpc-deps.patch')
+sha512sums=('05da0d879c20c86a3f307aa712e779cab442292c5628086175af141398029d65f119b81a21e08d866ab2e89e9159d036b59a1b22e39a668a7a72a95c79a7af2f'
+            '088a9310d2a62603fda2ca05eae16fab3fb82b3250533beb06ec5551b671ff71c11ddb6a338234b0790c5db61790dcddc08969cca5d07a84ed668bddff2b8542'
+            'e3b339285ea1ee46e0cc560f9ef509d2307d15090bc740ae9cc322daafd1ccccdb118045ffff8b565a234043049c5208679bb982360b7b364df7d97ffe671669')
+
+prepare() {
+  cd "$pkgname-$pkgver"
+
+  patch -Np1 -i "${srcdir}/bump-tensorflow.patch"
+  patch -Np1 -i "${srcdir}/fix-grpc-deps.patch"
+}
+
+build() {
+  cd "$pkgname-$pkgver"
+
+  bazel build --experimental_repo_remote_exec tensorboard:tensorboard
+  bazel build --experimental_repo_remote_exec //tensorboard/pip_package:build_pip_package
+
+  mkdir pypackage
+  cp -R bazel-bin/tensorboard/pip_package/build_pip_package.runfiles/org_tensorflow_tensorboard/external pypackage
+  cp -R bazel-bin/tensorboard/pip_package/build_pip_package.runfiles/org_tensorflow_tensorboard/tensorboard pypackage
+  cp tensorboard/pip_package/{README.rst,MANIFEST.in,setup.py,requirements.txt} pypackage
+  cp README.md pypackage
+  cd pypackage
+  python setup.py build
+}
+
+package() {
+  cd "$pkgname-$pkgver"
+
+  install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+  cd pypackage
+  python setup.py install --root="$pkgdir" --optimize=1
+
+  rm -r "$pkgdir"/usr/lib/python3.8/site-packages/external/
+
+  _requires="$pkgdir"/usr/lib/python3.8/site-packages/tensorboard-${pkgver}-py3.8.egg-info/requires.txt
+  # This is ugly: We need to patch it to use current bleach and html5lib
+  # because old ones are not even compatible with Python 3.6 and we don't have
+  # those in Arch of course.
+  sed -i 's/bleach==.*/bleach/' ${_requires}
+  sed -i 's/html5lib==.*/html5lib/' ${_requires}
+  # Other ugly hack: workaround for issues 650
+  # https://github.com/tensorflow/tensorboard/issues/650
+  sed -i '/^futures/d' ${_requires}
+}
+
+# vim:set ts=2 sw=2 et:

Deleted: bump-tensorflow.patch
===================================================================
--- bump-tensorflow.patch	2020-04-10 15:33:09 UTC (rev 613119)
+++ bump-tensorflow.patch	2020-04-10 15:33:17 UTC (rev 613120)
@@ -1,18 +0,0 @@
-diff -aur tensorboard-2.2.0-old/WORKSPACE tensorboard-2.2.0-new/WORKSPACE
---- tensorboard-2.2.0-old/WORKSPACE	2020-03-24 15:41:29.000000000 +0200
-+++ tensorboard-2.2.0-new/WORKSPACE	2020-03-26 12:40:24.515353787 +0200
-@@ -103,11 +103,10 @@
-     name = "org_tensorflow",
-     # NOTE: when updating this, MAKE SURE to also update the protobuf_js runtime version
-     # in third_party/workspace.bzl to >= the protobuf/protoc version provided by TF.
--    sha256 = "638e541a4981f52c69da4a311815f1e7989bf1d67a41d204511966e1daed14f7",
--    strip_prefix = "tensorflow-2.1.0",
-+    sha256 = "3e0cffc98ad3767dd16a09b7f25a99961e21d65cfcad67ed3a9b1a01318c7e94",
-+    strip_prefix = "tensorflow-2.2.0-rc2",
-     urls = [
--        "http://mirror.tensorflow.org/github.com/tensorflow/tensorflow/archive/v2.1.0.tar.gz",  # 2020-01-06
--        "https://github.com/tensorflow/tensorflow/archive/v2.1.0.tar.gz",
-+        "https://github.com/tensorflow/tensorflow/archive/v2.2.0-rc2.tar.gz",
-     ],
- )
- 

Copied: tensorboard/repos/community-testing-x86_64/bump-tensorflow.patch (from rev 613119, tensorboard/trunk/bump-tensorflow.patch)
===================================================================
--- bump-tensorflow.patch	                        (rev 0)
+++ bump-tensorflow.patch	2020-04-10 15:33:17 UTC (rev 613120)
@@ -0,0 +1,18 @@
+diff -aur tensorboard-2.2.0-old/WORKSPACE tensorboard-2.2.0-new/WORKSPACE
+--- tensorboard-2.2.0-old/WORKSPACE	2020-03-24 15:41:29.000000000 +0200
++++ tensorboard-2.2.0-new/WORKSPACE	2020-03-26 12:40:24.515353787 +0200
+@@ -103,11 +103,10 @@
+     name = "org_tensorflow",
+     # NOTE: when updating this, MAKE SURE to also update the protobuf_js runtime version
+     # in third_party/workspace.bzl to >= the protobuf/protoc version provided by TF.
+-    sha256 = "638e541a4981f52c69da4a311815f1e7989bf1d67a41d204511966e1daed14f7",
+-    strip_prefix = "tensorflow-2.1.0",
++    sha256 = "3e0cffc98ad3767dd16a09b7f25a99961e21d65cfcad67ed3a9b1a01318c7e94",
++    strip_prefix = "tensorflow-2.2.0-rc2",
+     urls = [
+-        "http://mirror.tensorflow.org/github.com/tensorflow/tensorflow/archive/v2.1.0.tar.gz",  # 2020-01-06
+-        "https://github.com/tensorflow/tensorflow/archive/v2.1.0.tar.gz",
++        "https://github.com/tensorflow/tensorflow/archive/v2.2.0-rc2.tar.gz",
+     ],
+ )
+ 

Deleted: fix-grpc-deps.patch
===================================================================
--- fix-grpc-deps.patch	2020-04-10 15:33:09 UTC (rev 613119)
+++ fix-grpc-deps.patch	2020-04-10 15:33:17 UTC (rev 613120)
@@ -1,47 +0,0 @@
-diff -aur tensorboard-2.2.0-old/third_party/workspace.bzl tensorboard-2.2.0-new/third_party/workspace.bzl
---- tensorboard-2.2.0-old/third_party/workspace.bzl	2020-03-24 15:41:29.000000000 +0200
-+++ tensorboard-2.2.0-new/third_party/workspace.bzl	2020-04-07 18:09:49.309586469 +0300
-@@ -55,6 +55,18 @@
-       actual = "@org_pythonhosted_six",
-   )
- 
-+  # gRPC's BUILD file depends on //external:protobuf_clib.
-+  native.bind(
-+      name = "protobuf_clib",
-+      actual = "@com_google_protobuf//:protoc_lib",
-+  )
-+
-+  # gRPC's BUILD file depends on //external:protobuf_headers.
-+  native.bind(
-+      name = "protobuf_headers",
-+      actual = "@com_google_protobuf//:protobuf_headers",
-+  )
-+
-   platform_http_file(
-       name = "org_chromium_chromium",
-       licenses = ["notice"],  # BSD 3-clause (maybe more?)
-diff -aur tensorboard-2.2.0-old/WORKSPACE tensorboard-2.2.0-new/WORKSPACE
---- tensorboard-2.2.0-old/WORKSPACE	2020-04-07 18:11:04.789583868 +0300
-+++ tensorboard-2.2.0-new/WORKSPACE	2020-04-07 18:11:15.819583488 +0300
-@@ -113,6 +113,21 @@
- load("@org_tensorflow//tensorflow:workspace.bzl", "tf_workspace")
- tf_workspace()
- 
-+# add upb dep
-+http_archive(
-+    name = "upb",
-+    urls = [
-+        "https://github.com/protocolbuffers/upb/archive/ef25ea52814b48f1d945e25b5b1b19b04eea3ad8.tar.gz"
-+    ],
-+    strip_prefix = "upb-ef25ea52814b48f1d945e25b5b1b19b04eea3ad8",
-+    sha256 = "03dd5e19e1b653a3b2d7f50a3cc3ed913a72a0ecaf0d667c5f4df3ab3c8587c2",
-+)
-+# load("@upb//bazel:workspace_deps.bzl", "upb_deps")
-+# load("@upb//bazel:upb_proto_library.bzl", "upb_deps")
-+# upb_deps()
-+# load("@upb//bazel:grpc_deps.bzl", "grpc_my_deps")
-+# grpc_my_deps()
-+
- # Please add all new dependencies in workspace.bzl.
- load("//third_party:workspace.bzl", "tensorboard_workspace")
- tensorboard_workspace()

Copied: tensorboard/repos/community-testing-x86_64/fix-grpc-deps.patch (from rev 613119, tensorboard/trunk/fix-grpc-deps.patch)
===================================================================
--- fix-grpc-deps.patch	                        (rev 0)
+++ fix-grpc-deps.patch	2020-04-10 15:33:17 UTC (rev 613120)
@@ -0,0 +1,47 @@
+diff -aur tensorboard-2.2.0-old/third_party/workspace.bzl tensorboard-2.2.0-new/third_party/workspace.bzl
+--- tensorboard-2.2.0-old/third_party/workspace.bzl	2020-03-24 15:41:29.000000000 +0200
++++ tensorboard-2.2.0-new/third_party/workspace.bzl	2020-04-07 18:09:49.309586469 +0300
+@@ -55,6 +55,18 @@
+       actual = "@org_pythonhosted_six",
+   )
+ 
++  # gRPC's BUILD file depends on //external:protobuf_clib.
++  native.bind(
++      name = "protobuf_clib",
++      actual = "@com_google_protobuf//:protoc_lib",
++  )
++
++  # gRPC's BUILD file depends on //external:protobuf_headers.
++  native.bind(
++      name = "protobuf_headers",
++      actual = "@com_google_protobuf//:protobuf_headers",
++  )
++
+   platform_http_file(
+       name = "org_chromium_chromium",
+       licenses = ["notice"],  # BSD 3-clause (maybe more?)
+diff -aur tensorboard-2.2.0-old/WORKSPACE tensorboard-2.2.0-new/WORKSPACE
+--- tensorboard-2.2.0-old/WORKSPACE	2020-04-07 18:11:04.789583868 +0300
++++ tensorboard-2.2.0-new/WORKSPACE	2020-04-07 18:11:15.819583488 +0300
+@@ -113,6 +113,21 @@
+ load("@org_tensorflow//tensorflow:workspace.bzl", "tf_workspace")
+ tf_workspace()
+ 
++# add upb dep
++http_archive(
++    name = "upb",
++    urls = [
++        "https://github.com/protocolbuffers/upb/archive/ef25ea52814b48f1d945e25b5b1b19b04eea3ad8.tar.gz"
++    ],
++    strip_prefix = "upb-ef25ea52814b48f1d945e25b5b1b19b04eea3ad8",
++    sha256 = "03dd5e19e1b653a3b2d7f50a3cc3ed913a72a0ecaf0d667c5f4df3ab3c8587c2",
++)
++# load("@upb//bazel:workspace_deps.bzl", "upb_deps")
++# load("@upb//bazel:upb_proto_library.bzl", "upb_deps")
++# upb_deps()
++# load("@upb//bazel:grpc_deps.bzl", "grpc_my_deps")
++# grpc_my_deps()
++
+ # Please add all new dependencies in workspace.bzl.
+ load("//third_party:workspace.bzl", "tensorboard_workspace")
+ tensorboard_workspace()


More information about the arch-commits mailing list