[arch-commits] Commit in pyqt5/repos/testing-x86_64 (PKGBUILD PKGBUILD)

Antonio Rojas arojas at archlinux.org
Wed Jun 3 16:30:41 UTC 2020


    Date: Wednesday, June 3, 2020 @ 16:30:39
  Author: arojas
Revision: 388165

archrelease: copy trunk to testing-x86_64

Added:
  pyqt5/repos/testing-x86_64/PKGBUILD
    (from rev 388164, pyqt5/trunk/PKGBUILD)
Deleted:
  pyqt5/repos/testing-x86_64/PKGBUILD

----------+
 PKGBUILD |  224 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 112 insertions(+), 112 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2020-06-03 16:30:05 UTC (rev 388164)
+++ PKGBUILD	2020-06-03 16:30:39 UTC (rev 388165)
@@ -1,112 +0,0 @@
-# Maintainer: Antonio Rojas <arojas at archlinux.org>
-# Maintainer: Felix Yan <felixonmars at archlinux.org>
-# Contributor: Andrea Scarpino <andrea at archlinux.org>
-# Contributor: Yichao Yu <yyc1992 at gmail.com>
-# Contributor: Douglas Soares de Andrade <douglas at archlinux.org>
-# Contributor: riai <riai at bigfoot.com> Ben <ben at benmazer.net>
-
-pkgbase=pyqt5
-pkgname=('python-pyqt5' 'python2-pyqt5')
-pkgver=5.15.0
-pkgrel=1
-arch=('x86_64')
-url="https://riverbankcomputing.com/software/pyqt/intro"
-license=('GPL')
-makedepends=('sip5' 'pyqt-builder' 'python2-sip-pyqt5' 'sip' 'python-opengl' 'python2-opengl' 'python2-enum34'
-             'python2-dbus' 'python-dbus' 'qt5-connectivity' 'qt5-multimedia' 'qt5-tools' 'qt5-serialport' 'qt5-svg'
-             'qt5-webkit' 'qt5-websockets' 'qt5-x11extras' 'qt5-networkauth' 'qt5-xmlpatterns' 'qt5-remoteobjects' 'qt5-quick3d')
-conflicts=('pyqt5-common')
-source=("https://pypi.python.org/packages/source/P/PyQt5/PyQt5-$pkgver.tar.gz")
-sha256sums=('c6f75488ffd5365a65893bc64ea82a6957db126fbfe33654bcd43ae1c30c52f9')
-
-prepare() {
-  cp -a PyQt5-$pkgver{,-py2}
-
-  sed -e 's|4.19.23|4.19.22|' -i PyQt5-$pkgver-py2/configure.py # Fix unexistant SIP min version
-}
-
-build() {
-  cd "$srcdir"/PyQt5-$pkgver
-  sip-build \
-    --confirm-license \
-    --no-make \
-    --api-dir /usr/share/qt/qsci/api/python
-  cd build
-  make
-
-  cd "$srcdir"/PyQt5-$pkgver-py2
-  python2 configure.py \
-    --confirm-license \
-    --sip='/usr/bin/sip'
-  make
-}
-
-package_python-pyqt5(){
-  pkgdesc="A set of Python bindings for the Qt5 toolkit"
-  groups=(pyqt5)
-  depends=('python-pyqt5-sip' 'qt5-base')
-  optdepends=('python-opengl: enable OpenGL 3D graphics in PyQt applications'
-              'python-dbus: for python-dbus mainloop support'
-              'qt5-multimedia: QtMultimedia, QtMultimediaWidgets'
-              'qt5-tools: QtHelp, QtDesigner'
-              'qt5-svg: QtSvg'
-              'qt5-webkit: QtWebKit, QtWebKitWidgets'
-              'qt5-xmlpatterns: QtXmlPatterns'
-              'qt5-declarative: QtQml, qmlplugin'
-              'qt5-serialport: QtSerialPort'
-              'qt5-websockets: QtWebSockets'
-              'qt5-connectivity: QtNfc, QtBluetooth'
-              'qt5-x11extras: QtX11Extras'
-              'qt5-networkauth: QtNetworkAuth'
-              'qt5-remoteobjects: QtRemoteObjects'
-              'qt5-quick3d: QtQuick3D')
-
-  cd PyQt5-$pkgver/build
-  make INSTALL_ROOT="$pkgdir" install -j1
-
-  # Remove unused py2 version of uic modules:
-  rm -r "$pkgdir"/usr/lib/python*/site-packages/PyQt5/uic/port_v2
-
-  # compile Python bytecode
-  python -m compileall -d / "$pkgdir"/usr/lib
-  python -O -m compileall -d / "$pkgdir"/usr/lib
-}
-
-package_python2-pyqt5(){
-  pkgdesc="A set of Python 2 bindings for the Qt5 toolkit"
-  depends=('python2-sip-pyqt5' 'qt5-base' 'python2-enum34')
-  optdepends=('python2-opengl: enable OpenGL 3D graphics in PyQt applications'
-              'python-dbus: for python-dbus mainloop support'
-              'qt5-multimedia: QtMultimedia, QtMultimediaWidgets'
-              'qt5-tools: QtHelp, QtDesigner'
-              'qt5-svg: QtSvg'
-              'qt5-webkit: QtWebKit, QtWebKitWidgets'
-              'qt5-xmlpatterns: QtXmlPatterns'
-              'qt5-declarative: QtQml, qmlplugin'
-              'qt5-serialport: QtSerialPort'
-              'qt5-websockets: QtWebSockets'
-              'qt5-connectivity: QtNfc, QtBluetooth'
-              'qt5-x11extras: QtX11Extras'
-              'qt5-networkauth: QtNetworkAuth'
-              'qt5-remoteobjects: QtRemoteObjects'
-              'qt5-quick3d: QtQuick3D')
-
-  cd PyQt5-$pkgver-py2
-  # INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
-  make DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install -j1
-
-  # Remove unused py3 version of uic modules:
-  rm -r "$pkgdir"/usr/lib/python*/site-packages/PyQt5/uic/port_v3
-
-  # compile Python bytecode
-  python2 -m compileall -d / "$pkgdir"/usr/lib
-  python2 -O -m compileall -d / "$pkgdir"/usr/lib
-
-  # Fix conflicts with python-pyqt5
-  mv "$pkgdir"/usr/bin/{,python2-}pyuic5
-  mv "$pkgdir"/usr/bin/{,python2-}pylupdate5
-  mv "$pkgdir"/usr/bin/{,python2-}pyrcc5
-
-  rm "$pkgdir"/usr/lib/qt/plugins/designer/libpyqt5.so
-  rm "$pkgdir"/usr/lib/qt/plugins/PyQt5/libpyqt5qmlplugin.so
-}

Copied: pyqt5/repos/testing-x86_64/PKGBUILD (from rev 388164, pyqt5/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2020-06-03 16:30:39 UTC (rev 388165)
@@ -0,0 +1,112 @@
+# Maintainer: Antonio Rojas <arojas at archlinux.org>
+# Maintainer: Felix Yan <felixonmars at archlinux.org>
+# Contributor: Andrea Scarpino <andrea at archlinux.org>
+# Contributor: Yichao Yu <yyc1992 at gmail.com>
+# Contributor: Douglas Soares de Andrade <douglas at archlinux.org>
+# Contributor: riai <riai at bigfoot.com> Ben <ben at benmazer.net>
+
+pkgbase=pyqt5
+pkgname=('python-pyqt5' 'python2-pyqt5')
+pkgver=5.15.0
+pkgrel=2
+arch=('x86_64')
+url="https://riverbankcomputing.com/software/pyqt/intro"
+license=('GPL')
+makedepends=('sip5' 'pyqt-builder' 'python2-sip-pyqt5' 'sip' 'python-opengl' 'python2-opengl' 'python2-enum34'
+             'python2-dbus' 'python-dbus' 'qt5-connectivity' 'qt5-multimedia' 'qt5-tools' 'qt5-serialport' 'qt5-svg'
+             'qt5-webkit' 'qt5-websockets' 'qt5-x11extras' 'qt5-networkauth' 'qt5-xmlpatterns' 'qt5-remoteobjects' 'qt5-quick3d')
+conflicts=('pyqt5-common')
+source=("https://pypi.python.org/packages/source/P/PyQt5/PyQt5-$pkgver.tar.gz")
+sha256sums=('c6f75488ffd5365a65893bc64ea82a6957db126fbfe33654bcd43ae1c30c52f9')
+
+prepare() {
+  cp -a PyQt5-$pkgver{,-py2}
+
+  sed -e 's|4.19.23|4.19.22|' -i PyQt5-$pkgver-py2/configure.py # Fix unexistant SIP min version
+}
+
+build() {
+  cd "$srcdir"/PyQt5-$pkgver
+  sip-build \
+    --confirm-license \
+    --no-make \
+    --api-dir /usr/share/qt/qsci/api/python
+  cd build
+  make
+
+  cd "$srcdir"/PyQt5-$pkgver-py2
+  python2 configure.py \
+    --confirm-license \
+    --sip='/usr/bin/sip'
+  make
+}
+
+package_python-pyqt5(){
+  pkgdesc="A set of Python bindings for the Qt5 toolkit"
+  groups=(pyqt5)
+  depends=('python-pyqt5-sip' 'qt5-base')
+  optdepends=('python-opengl: enable OpenGL 3D graphics in PyQt applications'
+              'python-dbus: for python-dbus mainloop support'
+              'qt5-multimedia: QtMultimedia, QtMultimediaWidgets'
+              'qt5-tools: QtHelp, QtDesigner'
+              'qt5-svg: QtSvg'
+              'qt5-webkit: QtWebKit, QtWebKitWidgets'
+              'qt5-xmlpatterns: QtXmlPatterns'
+              'qt5-declarative: QtQml, qmlplugin'
+              'qt5-serialport: QtSerialPort'
+              'qt5-websockets: QtWebSockets'
+              'qt5-connectivity: QtNfc, QtBluetooth'
+              'qt5-x11extras: QtX11Extras'
+              'qt5-networkauth: QtNetworkAuth'
+              'qt5-remoteobjects: QtRemoteObjects'
+              'qt5-quick3d: QtQuick3D')
+
+  cd PyQt5-$pkgver/build
+  make INSTALL_ROOT="$pkgdir" install -j1
+
+  # Remove unused py2 version of uic modules:
+  rm -r "$pkgdir"/usr/lib/python*/site-packages/PyQt5/uic/port_v2
+
+  # compile Python bytecode
+  python -m compileall -d / "$pkgdir"/usr/lib
+  python -O -m compileall -d / "$pkgdir"/usr/lib
+}
+
+package_python2-pyqt5(){
+  pkgdesc="A set of Python 2 bindings for the Qt5 toolkit"
+  depends=('python2-sip-pyqt5' 'qt5-base' 'python2-enum34')
+  optdepends=('python2-opengl: enable OpenGL 3D graphics in PyQt applications'
+              'python-dbus: for python-dbus mainloop support'
+              'qt5-multimedia: QtMultimedia, QtMultimediaWidgets'
+              'qt5-tools: QtHelp, QtDesigner'
+              'qt5-svg: QtSvg'
+              'qt5-webkit: QtWebKit, QtWebKitWidgets'
+              'qt5-xmlpatterns: QtXmlPatterns'
+              'qt5-declarative: QtQml, qmlplugin'
+              'qt5-serialport: QtSerialPort'
+              'qt5-websockets: QtWebSockets'
+              'qt5-connectivity: QtNfc, QtBluetooth'
+              'qt5-x11extras: QtX11Extras'
+              'qt5-networkauth: QtNetworkAuth'
+              'qt5-remoteobjects: QtRemoteObjects'
+              'qt5-quick3d: QtQuick3D')
+
+  cd PyQt5-$pkgver-py2
+  # INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
+  make DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install -j1
+
+  # Remove unused py3 version of uic modules:
+  rm -r "$pkgdir"/usr/lib/python*/site-packages/PyQt5/uic/port_v3
+
+  # compile Python bytecode
+  python2 -m compileall -d / "$pkgdir"/usr/lib
+  python2 -O -m compileall -d / "$pkgdir"/usr/lib
+
+  # Fix conflicts with python-pyqt5
+  mv "$pkgdir"/usr/bin/{,python2-}pyuic5
+  mv "$pkgdir"/usr/bin/{,python2-}pylupdate5
+  mv "$pkgdir"/usr/bin/{,python2-}pyrcc5
+
+  rm "$pkgdir"/usr/lib/qt/plugins/designer/libpyqt5.so
+  rm "$pkgdir"/usr/lib/qt/plugins/PyQt5/libpyqt5qmlplugin.so
+}


More information about the arch-commits mailing list