[arch-commits] Commit in pidgin/repos (5 files)

Evangelos Foutras foutrelis at archlinux.org
Sat May 16 13:38:28 UTC 2020


    Date: Saturday, May 16, 2020 @ 13:38:27
  Author: foutrelis
Revision: 384637

archrelease: copy trunk to staging-x86_64

Added:
  pidgin/repos/staging-x86_64/
  pidgin/repos/staging-x86_64/PKGBUILD
    (from rev 384636, pidgin/trunk/PKGBUILD)
  pidgin/repos/staging-x86_64/pidgin-nm-1.0.patch
    (from rev 384636, pidgin/trunk/pidgin-nm-1.0.patch)
  pidgin/repos/staging-x86_64/pidgin-python-3.8.patch
    (from rev 384636, pidgin/trunk/pidgin-python-3.8.patch)
  pidgin/repos/staging-x86_64/purple-remote-python3.patch
    (from rev 384636, pidgin/trunk/purple-remote-python3.patch)

-----------------------------+
 PKGBUILD                    |  108 ++++++++++++++++++++++++++++++++++++++++++
 pidgin-nm-1.0.patch         |   52 ++++++++++++++++++++
 pidgin-python-3.8.patch     |   13 +++++
 purple-remote-python3.patch |   34 +++++++++++++
 4 files changed, 207 insertions(+)

Copied: pidgin/repos/staging-x86_64/PKGBUILD (from rev 384636, pidgin/trunk/PKGBUILD)
===================================================================
--- staging-x86_64/PKGBUILD	                        (rev 0)
+++ staging-x86_64/PKGBUILD	2020-05-16 13:38:27 UTC (rev 384637)
@@ -0,0 +1,108 @@
+# Maintainer: Evangelos Foutras <evangelos at foutrelis.com>
+# Contributor: Ionut Biru <ibiru at archlinux.org>
+# Contributor: Andrea Scarpino <andrea at archlinux.org>
+# Contributor: Alexander Fehr <pizzapunk gmail com>
+# Contributor: Lucien Immink <l.immink at student.fnt.hvu.nl>
+
+pkgname=('pidgin' 'libpurple' 'finch')
+pkgver=2.13.0
+pkgrel=10
+arch=('x86_64')
+url="https://pidgin.im/"
+license=('GPL')
+makedepends=('startup-notification' 'gtkspell' 'libxss' 'nss' 'libsasl' 'libsm'
+             'libidn' 'libgadu' 'python' 'hicolor-icon-theme' 'farstream' 'tk'
+             'libnsl' 'avahi' 'ca-certificates' 'intltool' 'libnm' 'dbus-glib')
+source=(https://bitbucket.org/pidgin/main/downloads/$pkgname-$pkgver.tar.bz2{,.asc}
+        purple-remote-python3.patch pidgin-python-3.8.patch pidgin-nm-1.0.patch)
+sha256sums=('2747150c6f711146bddd333c496870bfd55058bab22ffb7e4eb784018ec46d8f'
+            'SKIP'
+            '4eb6be9310e4d5d1b906b1d579c395000ee0af6d6f5056307233512151d1f4b1'
+            'afc824771b7409859f06b18f88ed9db97e90e3a5b10e5bab60f880c19f058c4f'
+            'ca00ab0f502690f7a1551020dfc9a0119edf1eabaae9127658313d6635acda33')
+validpgpkeys=('364E2EB38EA6A8D61FB963AD75FE259AA8AC8032') # Gary Kramlich (grim) <grim at reaperworld.com>
+
+prepare() {
+  cd $pkgbase-$pkgver
+
+  # https://developer.pidgin.im/ticket/17065
+  patch -Np1 -i ../purple-remote-python3.patch
+  # Fix networkmanager 1.0 detection (Fedora)
+  patch -p1 -i ../pidgin-nm-1.0.patch
+  # Fix build with python 3.8
+  patch -p1 -i ../pidgin-python-3.8.patch
+
+  autoreconf -vif
+}
+
+build() {
+  cd $pkgbase-$pkgver
+
+  ./configure \
+    --prefix=/usr \
+    --sysconfdir=/etc \
+    --disable-schemas-install \
+    --disable-meanwhile \
+    --disable-gnutls \
+    --enable-cyrus-sasl \
+    --disable-doxygen \
+    --enable-nm \
+    --with-system-ssl-certs=/etc/ssl/certs
+    make
+}
+
+package_pidgin(){
+  pkgdesc="Multi-protocol instant messaging client"
+  depends=('libpurple' 'startup-notification' 'gtkspell' 'libxss' 'libsm'
+           'gst-plugins-base' 'gst-plugins-good' 'hicolor-icon-theme')
+  optdepends=('aspell: for spelling correction')
+
+  cd $pkgbase-$pkgver
+
+  # For linking
+  make -C libpurple DESTDIR="$pkgdir" install-libLTLIBRARIES
+
+  make -C pidgin DESTDIR="$pkgdir" install
+  make -C doc DESTDIR="$pkgdir" install
+
+  # Remove files that are packaged in libpurle
+  make -C libpurple DESTDIR="$pkgdir" uninstall-libLTLIBRARIES
+
+  rm "$pkgdir/usr/share/man/man1/finch.1"
+}
+
+package_libpurple(){
+  pkgdesc="IM library extracted from Pidgin"
+  depends=('farstream' 'libsasl' 'libidn' 'libnsl' 'libgadu' 'dbus-glib' 'nss'
+           'libnm')
+  optdepends=('avahi: Bonjour protocol support'
+              'ca-certificates: SSL CA certificates'
+              'python-dbus: for purple-remote and purple-url-handler'
+              'tk: Tcl/Tk scripting support')
+
+  cd $pkgbase-$pkgver
+
+  for _dir in libpurple share/sounds share/ca-certs m4macros po; do
+    make -C "$_dir" DESTDIR="$pkgdir" install
+  done
+}
+
+package_finch(){
+  pkgdesc="A ncurses-based messaging client"
+  depends=('libpurple' 'libx11' 'python')
+
+  cd $pkgbase-$pkgver
+
+  # For linking
+  make -C libpurple DESTDIR="$pkgdir" install-libLTLIBRARIES
+
+  make -C finch DESTDIR="$pkgdir" install
+  make -C doc DESTDIR="$pkgdir" install
+
+  # Remove files that are packaged in libpurle
+  make -C libpurple DESTDIR="$pkgdir" uninstall-libLTLIBRARIES
+
+  rm "$pkgdir"/usr/share/man/man1/pidgin.1
+}
+
+# vim:set ts=2 sw=2 et:

Copied: pidgin/repos/staging-x86_64/pidgin-nm-1.0.patch (from rev 384636, pidgin/trunk/pidgin-nm-1.0.patch)
===================================================================
--- staging-x86_64/pidgin-nm-1.0.patch	                        (rev 0)
+++ staging-x86_64/pidgin-nm-1.0.patch	2020-05-16 13:38:27 UTC (rev 384637)
@@ -0,0 +1,52 @@
+diff --git a/configure.ac b/configure.ac
+index 04836fa..0a2d451 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1423,18 +1423,24 @@ fi
+ dnl Check for NetworkManager.h; if we don't have it, oh well
+ if test "x$enable_dbus" = "xyes" ; then
+ 	if test "x$enable_nm" = "xyes" ; then
+-		PKG_CHECK_MODULES(NETWORKMANAGER, [NetworkManager >= 0.5.0], [
++		PKG_CHECK_MODULES(NETWORKMANAGER, [libnm], [
+ 			AC_SUBST(NETWORKMANAGER_CFLAGS)
+ 			AC_SUBST(NETWORKMANAGER_LIBS)
+ 			AC_DEFINE(HAVE_NETWORKMANAGER, 1, [Define if we have NetworkManager.])
+ 		], [
+-			enable_nm=no
+-			if test "x$force_deps" = "xyes" ; then
+-				AC_MSG_ERROR([
++			PKG_CHECK_MODULES(NETWORKMANAGER, [NetworkManager >= 0.5.0], [
++				AC_SUBST(NETWORKMANAGER_CFLAGS)
++				AC_SUBST(NETWORKMANAGER_LIBS)
++				AC_DEFINE(HAVE_NETWORKMANAGER, 1, [Define if we have NetworkManager.])
++			], [
++				enable_nm=no
++				if test "x$force_deps" = "xyes" ; then
++					AC_MSG_ERROR([
+ NetworkManager development headers not found.
+ Use --disable-nm if you do not need NetworkManager support.
+ ])
+-			fi])
++				fi])
++		])
+ 	fi
+ else
+ 	enable_nm=no
+diff --git a/libpurple/network.c b/libpurple/network.c
+index c43e3c7..b17e439 100644
+--- a/libpurple/network.c
++++ b/libpurple/network.c
+@@ -939,8 +939,13 @@ nm_update_state(NMState state)
+ #if NM_CHECK_VERSION(0,8,992)
+ 		case NM_STATE_DISCONNECTING:
+ #endif
++#if NM_CHECK_VERSION(1,0,0)
++			if (prev != NM_STATE_CONNECTED_GLOBAL && prev != NM_STATE_UNKNOWN)
++				break;
++#else
+ 			if (prev != NM_STATE_CONNECTED && prev != NM_STATE_UNKNOWN)
+ 				break;
++#endif
+ 			if (ui_ops != NULL && ui_ops->network_disconnected != NULL)
+ 				ui_ops->network_disconnected();
+ 			break;

Copied: pidgin/repos/staging-x86_64/pidgin-python-3.8.patch (from rev 384636, pidgin/trunk/pidgin-python-3.8.patch)
===================================================================
--- staging-x86_64/pidgin-python-3.8.patch	                        (rev 0)
+++ staging-x86_64/pidgin-python-3.8.patch	2020-05-16 13:38:27 UTC (rev 384637)
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index d916891..d8c39a0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1565,7 +1565,7 @@ if test "x$enable_consoleui" = "xyes" -a ! -z "$PYTHON" -a x"$PYTHON" != x"no" ;
+ 	AC_MSG_CHECKING(for Python compile flags)
+ 	if test -f ${PYTHON}-config; then
+ 		PY_CFLAGS=`${PYTHON}-config --includes`
+-		PY_LIBS=`${PYTHON}-config --libs`
++		PY_LIBS=`${PYTHON}-config --libs --embed` || PY_LIBS=`${PYTHON}-config --libs`
+ 		AC_DEFINE(USE_PYTHON, [1], [Define if python headers are available.])
+ 		AC_MSG_RESULT(ok)
+ 	else

Copied: pidgin/repos/staging-x86_64/purple-remote-python3.patch (from rev 384636, pidgin/trunk/purple-remote-python3.patch)
===================================================================
--- staging-x86_64/purple-remote-python3.patch	                        (rev 0)
+++ staging-x86_64/purple-remote-python3.patch	2020-05-16 13:38:27 UTC (rev 384637)
@@ -0,0 +1,34 @@
+# HG changeset patch
+# User Evangelos Foutras <evangelos at foutrelis.com>
+# Date 1520583640 -7200
+#      Fri Mar 09 10:20:40 2018 +0200
+# Branch release-2.x.y
+# Node ID ac2e05444162f1dc0fd60e4d5c8b4cbe2969b695
+# Parent  02df346d26d00cb9a1420c11a59fccb35d92f04e
+Adjust purple-remote to work with Python 3
+
+Fixes the following error:
+
+    Traceback (most recent call last):
+      File "./libpurple/purple-remote", line 241, in <module>
+        print("No existing libpurple instance detected.")
+      File "/usr/lib/python3.6/codecs.py", line 377, in write
+        self.stream.write(data)
+    TypeError: write() argument must be str, not bytes
+
+diff -r 02df346d26d0 -r ac2e05444162 libpurple/purple-remote
+--- a/libpurple/purple-remote	Thu Mar 08 22:51:37 2018 -0600
++++ b/libpurple/purple-remote	Fri Mar 09 10:20:40 2018 +0200
+@@ -13,8 +13,10 @@
+ 
+ import xml.dom.minidom 
+ 
+-sys.stdin = codecs.getwriter('utf-8')(sys.stdin);
+-sys.stdout = codecs.getwriter('utf-8')(sys.stdout);
++if hasattr(sys.stdout, 'buffer'):
++    sys.stdout = codecs.getwriter('utf-8')(sys.stdout.buffer)
++else:
++    sys.stdout = codecs.getwriter('utf-8')(sys.stdout)
+ 
+ xml.dom.minidom.Element.all   = xml.dom.minidom.Element.getElementsByTagName
+ 


More information about the arch-commits mailing list