[arch-commits] Commit in qgis/repos/community-x86_64 (4 files)

Balló György bgyorgy at archlinux.org
Wed May 27 19:16:30 UTC 2020


    Date: Wednesday, May 27, 2020 @ 19:16:29
  Author: bgyorgy
Revision: 636004

archrelease: copy trunk to community-x86_64

Added:
  qgis/repos/community-x86_64/PKGBUILD
    (from rev 636003, qgis/trunk/PKGBUILD)
  qgis/repos/community-x86_64/qgis-pyqt5-sip5.patch
    (from rev 636003, qgis/trunk/qgis-pyqt5-sip5.patch)
Deleted:
  qgis/repos/community-x86_64/PKGBUILD
  qgis/repos/community-x86_64/qgis-pyqt5-sip5.patch

-----------------------+
 PKGBUILD              |  120 ++++++++++++++++++++++++------------------------
 qgis-pyqt5-sip5.patch |   44 ++++++++---------
 2 files changed, 82 insertions(+), 82 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2020-05-27 19:16:25 UTC (rev 636003)
+++ PKGBUILD	2020-05-27 19:16:29 UTC (rev 636004)
@@ -1,60 +0,0 @@
-# Maintainer: Balló György <ballogyor+arch at gmail dot com>
-# Contributor: Doug Newgard <scimmia at archlinux dot org>
-# Contributor: XavierCLL <xavier.corredor.llano (a) gmail.com>
-# Contributor: SaultDon <sault.don gmail>
-# Contributor: Lantald < lantald at gmx.com >
-# Contributor: Thomas Dziedzic < gostrc at gmail >
-# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
-# Contributor: Gerardo Exequiel Pozzi <vmlinuz386 at yahoo.com.ar>
-# Contributor: Eric Forgeot < http://esclinux.tk >
-
-pkgname=qgis
-pkgver=3.12.1
-pkgrel=1
-pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats'
-url='https://qgis.org/'
-license=(GPL)
-arch=(x86_64)
-depends=(desktop-file-utils exiv2 gdal hicolor-icon-theme libzip python-qscintilla-qt5 qca qt5-3d
-         qt5-serialport qt5-webkit qtkeychain qwtpolar spatialindex python-sip)
-makedepends=(cmake fcgi gsl python-six qt5-tools txt2tags sip python-setuptools)
-optdepends=('fcgi: Map server'
-            'gpsbabel: GPS Tools plugin'
-            'gsl: Georeferencer plugin'
-            'python-gdal: DB Manager plugin; Processing plugin'
-            'python-jinja: MetaSearch plugin'
-            'python-owslib: MetaSearch plugin'
-            'python-psycopg2: DB Manager plugin; Processing plugin'
-            'python-pygments: MetaSearch plugin'
-            'python-numpy: Processing plugin'
-            'python-yaml: Processing plugin')
-source=("https://qgis.org/downloads/$pkgname-$pkgver.tar.bz2"
-         qgis-pyqt5-sip5.patch)
-sha256sums=('a7dc7af768b8960c08ce72a06c1f4ca4664f4197ce29c7fe238429e48b2881a8'
-            '47fdab75c94ecf5b61a41b334e23714226e895cef507c35a3bc4b46c7d307981')
-
-prepare() {
-  [[ -d build ]] || mkdir build
-
-  cd $pkgname-$pkgver
-  patch -p1 -i ../qgis-pyqt5-sip5.patch # Use new pyqt sip file location
-}
-
-build() {
-  cd build
-  cmake -G "Unix Makefiles" ../$pkgname-$pkgver/ \
-    -DCMAKE_INSTALL_PREFIX=/usr \
-    -DWITH_3D=TRUE \
-    -DWITH_SERVER=TRUE \
-    -DWITH_CUSTOM_WIDGETS=TRUE \
-    -DBINDINGS_GLOBAL_INSTALL=TRUE \
-    -DQGIS_MANUAL_SUBDIR=share/man \
-    -DWITH_QWTPOLAR=TRUE \
-    -DWITH_INTERNAL_QWTPOLAR=FALSE
-  make
-}
-
-package() {
-  cd build
-  make DESTDIR="$pkgdir" install
-}

Copied: qgis/repos/community-x86_64/PKGBUILD (from rev 636003, qgis/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2020-05-27 19:16:29 UTC (rev 636004)
@@ -0,0 +1,60 @@
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Doug Newgard <scimmia at archlinux dot org>
+# Contributor: XavierCLL <xavier.corredor.llano (a) gmail.com>
+# Contributor: SaultDon <sault.don gmail>
+# Contributor: Lantald < lantald at gmx.com >
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
+# Contributor: Gerardo Exequiel Pozzi <vmlinuz386 at yahoo.com.ar>
+# Contributor: Eric Forgeot < http://esclinux.tk >
+
+pkgname=qgis
+pkgver=3.12.3
+pkgrel=1
+pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats'
+url='https://qgis.org/'
+license=(GPL)
+arch=(x86_64)
+depends=(exiv2 gdal hicolor-icon-theme libzip python-qscintilla-qt5 qca qt5-3d
+         qt5-serialport qt5-webkit qtkeychain qwtpolar spatialindex python-sip)
+makedepends=(cmake fcgi gsl python-six qt5-tools txt2tags sip python-setuptools)
+optdepends=('fcgi: Map server'
+            'gpsbabel: GPS Tools plugin'
+            'gsl: Georeferencer plugin'
+            'python-gdal: DB Manager plugin; Processing plugin'
+            'python-jinja: MetaSearch plugin'
+            'python-owslib: MetaSearch plugin'
+            'python-psycopg2: DB Manager plugin; Processing plugin'
+            'python-pygments: MetaSearch plugin'
+            'python-numpy: Processing plugin'
+            'python-yaml: Processing plugin')
+source=("https://qgis.org/downloads/$pkgname-$pkgver.tar.bz2"
+         qgis-pyqt5-sip5.patch)
+sha256sums=('c2b53815f9b994e1662995d1f25f90628156b996758f5471bffb74ab29a95220'
+            '47fdab75c94ecf5b61a41b334e23714226e895cef507c35a3bc4b46c7d307981')
+
+prepare() {
+  [[ -d build ]] || mkdir build
+
+  cd $pkgname-$pkgver
+  patch -p1 -i ../qgis-pyqt5-sip5.patch # Use new pyqt sip file location
+}
+
+build() {
+  cd build
+  cmake -G "Unix Makefiles" ../$pkgname-$pkgver/ \
+    -DCMAKE_INSTALL_PREFIX=/usr \
+    -DWITH_3D=TRUE \
+    -DWITH_SERVER=TRUE \
+    -DWITH_CUSTOM_WIDGETS=TRUE \
+    -DBINDINGS_GLOBAL_INSTALL=TRUE \
+    -DQGIS_MANUAL_SUBDIR=share/man \
+    -DWITH_QWTPOLAR=TRUE \
+    -DWITH_INTERNAL_QWTPOLAR=FALSE
+  make
+}
+
+package() {
+  cd build
+  make DESTDIR="$pkgdir" install
+}

Deleted: qgis-pyqt5-sip5.patch
===================================================================
--- qgis-pyqt5-sip5.patch	2020-05-27 19:16:25 UTC (rev 636003)
+++ qgis-pyqt5-sip5.patch	2020-05-27 19:16:29 UTC (rev 636004)
@@ -1,22 +0,0 @@
-diff --git a/cmake/FindPyQt5.py b/cmake/FindPyQt5.py
-index 6a55a0f801..ba46441059 100644
---- a/cmake/FindPyQt5.py
-+++ b/cmake/FindPyQt5.py
-@@ -37,7 +37,7 @@ except ImportError:
-     import PyQt5.QtCore
-     import sipconfig # won't work for SIP v5
-     import os.path
--    import sys
-+    import sys, site
-     cfg = sipconfig.Configuration()
-     sip_dir = cfg.default_sip_dir
-     if sys.platform.startswith('freebsd'):
-@@ -54,7 +54,7 @@ except ImportError:
-         'pyqt_version_str': PyQt5.QtCore.PYQT_VERSION_STR,
-         'pyqt_sip_flags': PyQt5.QtCore.PYQT_CONFIGURATION['sip_flags'],
-         'pyqt_mod_dir': os.path.join(cfg.default_mod_dir, "PyQt5"),
--        'pyqt_sip_dir': sip_dir,
-+        'pyqt_sip_dir': os.path.join(site.getsitepackages()[0], "PyQt5", "bindings"),
-         'pyqt_bin_dir': cfg.default_bin_dir,
-     }
-     pyqtcfg = sipconfig.Configuration([cfg])

Copied: qgis/repos/community-x86_64/qgis-pyqt5-sip5.patch (from rev 636003, qgis/trunk/qgis-pyqt5-sip5.patch)
===================================================================
--- qgis-pyqt5-sip5.patch	                        (rev 0)
+++ qgis-pyqt5-sip5.patch	2020-05-27 19:16:29 UTC (rev 636004)
@@ -0,0 +1,22 @@
+diff --git a/cmake/FindPyQt5.py b/cmake/FindPyQt5.py
+index 6a55a0f801..ba46441059 100644
+--- a/cmake/FindPyQt5.py
++++ b/cmake/FindPyQt5.py
+@@ -37,7 +37,7 @@ except ImportError:
+     import PyQt5.QtCore
+     import sipconfig # won't work for SIP v5
+     import os.path
+-    import sys
++    import sys, site
+     cfg = sipconfig.Configuration()
+     sip_dir = cfg.default_sip_dir
+     if sys.platform.startswith('freebsd'):
+@@ -54,7 +54,7 @@ except ImportError:
+         'pyqt_version_str': PyQt5.QtCore.PYQT_VERSION_STR,
+         'pyqt_sip_flags': PyQt5.QtCore.PYQT_CONFIGURATION['sip_flags'],
+         'pyqt_mod_dir': os.path.join(cfg.default_mod_dir, "PyQt5"),
+-        'pyqt_sip_dir': sip_dir,
++        'pyqt_sip_dir': os.path.join(site.getsitepackages()[0], "PyQt5", "bindings"),
+         'pyqt_bin_dir': cfg.default_bin_dir,
+     }
+     pyqtcfg = sipconfig.Configuration([cfg])


More information about the arch-commits mailing list