[arch-commits] Commit in powerline/repos (3 files)

Evangelos Foutras foutrelis at archlinux.org
Thu Nov 12 19:39:17 UTC 2020


    Date: Thursday, November 12, 2020 @ 19:39:17
  Author: foutrelis
Revision: 753562

archrelease: copy trunk to community-staging-x86_64

Added:
  powerline/repos/community-staging-x86_64/
  powerline/repos/community-staging-x86_64/PKGBUILD
    (from rev 753561, powerline/trunk/PKGBUILD)
  powerline/repos/community-staging-x86_64/fail-on-binary-error.patch
    (from rev 753561, powerline/trunk/fail-on-binary-error.patch)

----------------------------+
 PKGBUILD                   |  150 +++++++++++++++++++++++++++++++++++++++++++
 fail-on-binary-error.patch |   15 ++++
 2 files changed, 165 insertions(+)

Copied: powerline/repos/community-staging-x86_64/PKGBUILD (from rev 753561, powerline/trunk/PKGBUILD)
===================================================================
--- community-staging-x86_64/PKGBUILD	                        (rev 0)
+++ community-staging-x86_64/PKGBUILD	2020-11-12 19:39:17 UTC (rev 753562)
@@ -0,0 +1,150 @@
+# Maintainer: Jiachen Yang <farseerfc at gmail.com>
+# AUR Maintainer: Swift Geek
+# AUR Maintainer: Timothée Ravier <tim at siosm.fr>
+# AUR Maintainer: Stefan Tatschner <rumpelsepp at sevenbyte.org>
+# Contributor: Swift Geek
+# Contributor: Pablo Olmos de Aguilera C. pablo+aur at odac dot co
+
+_pkgname="powerline"
+pkgbase="powerline"
+pkgname=("powerline" "python-powerline" "powerline-common" "powerline-vim" "powerline-fonts")
+pkgdesc='Statusline plugin for vim, and provides statuslines and prompts for several other applications, including zsh, bash, tmux, IPython, Awesome, i3 and Qtile'
+pkgver=2.8.1
+pkgrel=2
+url="https://github.com/${_pkgname}/${_pkgname}"
+license=('MIT')
+arch=('x86_64')
+makedepends=(
+    'python-setuptools'
+    'python-sphinx'
+    'git'
+    )
+checkdepends=(
+    'python-pexpect'
+    'python-tox'
+)
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/${_pkgname}/${_pkgname}/archive/${pkgver}.tar.gz"
+        "fail-on-binary-error.patch")
+sha512sums=('74642215ee204d1c05f34af31a95c2a96fe391d73360a30dc0d80c2d43f1d3d769c377cdb35fccfd486a204503d602ae2f5134b36060db6f6b7384598639aaca'
+            'd8f77a55d6056353e05556b283840e65bc0411890b5906deaf7f041843a17b08b6975ec399810e10d333384d840e66c1125f6851559e4806a850502c685a6621')
+
+
+
+prepare() {
+    # fix https://bugs.archlinux.org/task/48358
+    cd "${srcdir}/${_pkgname}-${pkgver}"
+    find scripts -type f -iname "powerline-*" -print0 | xargs -0 sed -i "1s/env //"
+    find "${_pkgname}"/bindings -type f -iname "*.py" -print0 | xargs -0 sed -i "1s/env //"
+
+    # explicitly fail if building binary usr/bin/powerline has any error
+    patch -N <../fail-on-binary-error.patch
+}
+
+build(){
+    # build main pages
+    cd "${srcdir}/${_pkgname}-${pkgver}/docs"
+    make man
+
+    # build C client
+    cd "${srcdir}/${_pkgname}-${pkgver}"
+    LC_ALL=C python setup.py build
+}
+
+
+# FIXME Currently test will fail with dividers and other errors
+check(){
+    cd "${srcdir}/${_pkgname}-${pkgver}"
+    LC_ALL=C python setup.py test
+}
+
+package_powerline(){
+    depends=('python-powerline')
+    conflicts=('powerline2' 'python-powerline<=2.3-1')
+    replaces=('python-powerline<=2.3-1')
+
+    cd "${srcdir}/${_pkgname}-${pkgver}/scripts"
+    install -Dm755 powerline "${pkgdir}/usr/bin/powerline"
+    install -Dm755 powerline-config "${pkgdir}/usr/bin/powerline-config"
+    install -Dm755 powerline-daemon "${pkgdir}/usr/bin/powerline-daemon"
+    install -Dm755 powerline-lint "${pkgdir}/usr/bin/powerline-lint"
+    install -Dm755 powerline-render "${pkgdir}/usr/bin/powerline-render"
+    
+    install -dm755 "${pkgdir}/usr/share/powerline/"
+    ln -s "$(python3 -c 'import site; print(site.getsitepackages()[0])')/powerline/bindings" "${pkgdir}/usr/share/powerline/bindings"
+
+    # install systemd user service
+    # see https://github.com/powerline/powerline/issues/1447
+    # and https://bugs.archlinux.org/task/65781
+    cd "${srcdir}/${_pkgname}-${pkgver}/powerline/dist/systemd"
+    install -Dm644 powerline-daemon.service  "${pkgdir}/usr/lib/systemd/user/powerline-daemon.service"
+    # license is installed by powerline-common
+}
+
+package_python-powerline() {
+    pkgdesc='python library for powerline'
+    depends=('python>=3.2' 'powerline-common')
+    optdepends=('python-psutil: improved system information'
+                'python-pygit2: improved git support'
+                'powerline-vim: vim plugin'
+                'powerline-fonts: patched fonts for powerline'
+                'which: fish bindings'
+                )
+
+    # install by redirect scripts and binaries
+    cd "${srcdir}/${_pkgname}-${pkgver}"
+    python setup.py install --skip-build --root="${pkgdir}" --install-data=tmp --install-scripts=tmp --optimize=1
+    # remove redirected scripts and binaries
+    rm -rf "${pkgdir}/tmp" 
+
+    install -dm755 "${pkgdir}/usr/share/licenses/"
+    ln -s "/usr/share/licenses/${_pkgname}" "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+
+package_powerline-common(){
+    pkgdesc='common files for python-powerline and python2-powerline'
+    
+    cd "${srcdir}/${_pkgname}-${pkgver}"
+
+    # license
+    install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+
+    install -dm755 "${pkgdir}/usr/share/licenses/"
+    ln -s "/usr/share/licenses/${_pkgname}" "${pkgdir}/usr/share/licenses/${pkgname}"
+
+    # manpages
+    install -dm755 "${pkgdir}/usr/share/man/man1/"
+    install -Dm644 "${srcdir}/${_pkgname}-${pkgver}/docs/_build/man/"* \
+                   "${pkgdir}/usr/share/man/man1/"
+}
+
+package_powerline-fonts() {
+    pkgdesc='patched fonts for powerline'
+    provides=('otf-powerline-symbols')
+    depends=('powerline-common')
+
+    cd "${srcdir}/${_pkgname}-${pkgver}"
+
+    install -dm755 "${pkgdir}/etc/fonts/conf.d"
+    install -Dm644 "font/PowerlineSymbols.otf" "${pkgdir}/usr/share/fonts/OTF/PowerlineSymbols.otf"
+    install -Dm644 "font/10-powerline-symbols.conf" "${pkgdir}/etc/fonts/conf.avail/10-powerline-symbols.conf"
+    ln -s "../conf.avail/10-powerline-symbols.conf" "${pkgdir}/etc/fonts/conf.d/10-powerline-symbols.conf"
+
+    install -dm755 "${pkgdir}/usr/share/licenses/"
+    ln -s "/usr/share/licenses/${_pkgname}" "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+
+package_powerline-vim() {
+    pkgdesc='vim plugin for powerline'
+    depends=('powerline' 'powerline-common' 'vim-runtime')
+    conflicts=('python2-powerline-vim')
+    provides=('python2-powerline-vim')
+
+    cd "${srcdir}/${_pkgname}-${pkgver}"
+    install -Dm644 "powerline/bindings/vim/plugin/powerline.vim" \
+                   "${pkgdir}/usr/share/vim/vimfiles/plugin/powerline.vim"
+
+    install -dm755 "${pkgdir}/usr/share/licenses/"
+    ln -s "/usr/share/licenses/${_pkgname}" "${pkgdir}/usr/share/licenses/${pkgname}"
+}

Copied: powerline/repos/community-staging-x86_64/fail-on-binary-error.patch (from rev 753561, powerline/trunk/fail-on-binary-error.patch)
===================================================================
--- community-staging-x86_64/fail-on-binary-error.patch	                        (rev 0)
+++ community-staging-x86_64/fail-on-binary-error.patch	2020-11-12 19:39:17 UTC (rev 753562)
@@ -0,0 +1,15 @@
+diff --git a/a/setup.py b/b/setup.py
+index 30bcddb..6b37d3b 100644
+--- a/a/setup.py
++++ b/b/setup.py
+@@ -118,8 +118,8 @@ setup(
+ 		'scripts/powerline-daemon',
+ 		'scripts/powerline-render',
+ 		'scripts/powerline-config',
+-	] + (['scripts/powerline'] if can_use_scripts else []),
+-	data_files=(None if can_use_scripts else (('bin', ['scripts/powerline']),)),
++	],
++	data_files=(('bin', ['scripts/powerline']),),
+ 	keywords='',
+ 	packages=find_packages(exclude=('tests', 'tests.*')),
+ 	include_package_data=True,


More information about the arch-commits mailing list