[arch-commits] Commit in kea/trunk (3 files)

Antonio Rojas arojas at archlinux.org
Sun Oct 11 18:10:52 UTC 2020


    Date: Sunday, October 11, 2020 @ 18:10:51
  Author: arojas
Revision: 723532

Rebuild 1.5 for botan 2.16

Modified:
  kea/trunk/PKGBUILD
  kea/trunk/fix-scripts-include-path.patch
  kea/trunk/tmpfiles-kea.conf

--------------------------------+
 PKGBUILD                       |   36 ---
 fix-scripts-include-path.patch |  408 ++++++---------------------------------
 tmpfiles-kea.conf              |    1 
 3 files changed, 80 insertions(+), 365 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD	2020-10-11 17:56:49 UTC (rev 723531)
+++ PKGBUILD	2020-10-11 18:10:51 UTC (rev 723532)
@@ -1,15 +1,14 @@
-# Maintainer: Konstantin Gizdov <arch at kge dot pw>
 # Maintainer: Baptiste Jonglez <baptiste--aur at jonglez dot org>
 # Contributor: nfnty
 pkgname='kea'
-pkgver=1.8.0
-_upstreamver=1.8.0
-pkgrel=2
+pkgver=1.5.0
+_upstreamver=1.5.0
+pkgrel=15
 pkgdesc='High-performance, extensible DHCP server engine from ISC, supporting both DHCPv4 and DHCPv6'
 arch=('x86_64')
 url='https://kea.isc.org'
 license=('MPL2')
-depends=('botan' 'boost-libs' 'log4cplus' 'mariadb-libs' 'openssl' 'postgresql-libs')
+depends=('botan' 'boost-libs' 'log4cplus' 'mariadb-libs' 'postgresql-libs')
 makedepends=('boost'
              'postgresql' # Needed for some headers
              'python') # kea-shell
@@ -19,16 +18,7 @@
             'kea-devel-docs: developer documentation')
 # Checks are disabled for now
 #checkdepends=('gtest' 'postgresql' 'mariadb' 'python' 'procps-ng') # procps-ng needed for 'pgrep'
-backup=(
-  # New config files as of Kea 1.3
-  'etc/kea/kea-dhcp4.conf'
-  'etc/kea/kea-dhcp6.conf'
-  'etc/kea/kea-dhcp-ddns.conf'
-  'etc/kea/kea-ctrl-agent.conf'
-  'etc/kea/kea-netconf.conf'
-  'etc/kea/keactrl.conf'
-)
-install=kea.install
+backup=('etc/kea/kea-dhcp4.conf' 'etc/kea/kea-dhcp6.conf' 'etc/kea/kea-dhcp-ddns.conf' 'etc/kea/kea-ctrl-agent.conf' 'etc/kea/keactrl.conf') # New config files as of Kea 1.3
 
 source=(https://ftp.isc.org/isc/kea/${_upstreamver}/kea-${_upstreamver}.tar.gz{,.asc}
         fix-scripts-include-path.patch
@@ -36,17 +26,15 @@
         kea-dhcp4.service
         kea-dhcp6.service
         kea-dhcp-ddns.service
-        kea-ctrl-agent.service
-        kea.install)
-sha512sums=('a8896ebdb6948851cddca015d696db4ec205af1472ccc25e7fd6d2f9070599cb7f80998f1dc94e763723723e8e0edd8a53274b96630d27db8c40995489d3a883'
+        kea-ctrl-agent.service)
+sha512sums=('6d6b7407831311ebe37abce382ce77c664015ddbe3e73ec78153a00b301f98af5be52e26ad4febf5ca1e478d2c1844db4c988b241d2700d758e90b077f176ad8'
             'SKIP'
-            'aec7df9fccd55b82b7f63b8738c335d8ebb57f8b7a1f2838398191b2aa7a4278c8460a7f196506260e29a70e80f5184432f051fc64454bb91c785924c4b2497f'
-            'b83479f0b90caf4022b1c858f99d8310848a90b0cc45aaa222cb2bf08b2a97312816b8f64c8c0232b612795bc7a0bbe5b05dbc508b2f1214c1ea88dc84200a2d'
+            '337c1e8689ce569bb8b085261e946743bc88d62ffdd264f4e8f271a6ca92c5bcda2329376aec4ffacd96187c7dba30450b8d5a9e2929f0a559ef8ecba7c0bafc'
+            '702a5dc19d1ed8fbe21aa9a4c09297eff9c9a3f6f1b178af8101a655b18b70c9e1dafd0cccc32063e31b2592d276e80c9bd4d2d51d8e1f74f67931fd290be6c0'
             '1b62dace9f9a955b21c5dd5b5466fb3a4f1d8057ad2a30ea89e222a769dc721ad2fe4913c41ec407e018b1b38ddde757e9b7b8fc12d4763ddde077a0abb0c971'
             '8f0e8d059338c415ae322e971e243b259d9b2ef7d37b6be57b409bf5f0f3392e519c9bb94c5b548021d000b944a5da82096608cd9ff3ee58061059ad519b0068'
             '9ab05b580f3b206d127514e158a445146a765ba4bf760daa93bcf29ec9d816dbdd08a497b5a4bba67645f4cc79b210fed8d1defa9daefc48175a654738927d31'
-            'db329fd83e458e4a77f6df8569074088bed152ffc1a188059d868d7178a6d3530efe368ce870a2e0be894f87fa0e5ba43562bdc3ad6372ddfcfedae37c90f491'
-            '758371f20a977f8e42e9d43d2d065c6aa294866070e54868dc329c0875b2eeafa05dcdf93590d5b429e262e2350a42c7616a3bc2e6f3994f53886870f4910251')
+            'db329fd83e458e4a77f6df8569074088bed152ffc1a188059d868d7178a6d3530efe368ce870a2e0be894f87fa0e5ba43562bdc3ad6372ddfcfedae37c90f491')
 validpgpkeys=('BE0E9748B718253A28BB89FFF1B11BF05CF02E57'  # Internet Systems Consortium, Inc. (Signing key, 2017-2018) <codesign at isc.org>
               'AE3FAC796711EC59FC007AA474BB6B9A4CBB3D38') # Internet Systems Consortium, Inc. (Signing key, 2019-2020) <codesign at isc.org>
 prepare() {
@@ -66,12 +54,8 @@
       --libexecdir='/usr/bin' \
       --sysconfdir='/etc' \
       --localstatedir='/var' \
-      --with-openssl \
       --with-dhcp-mysql \
       --with-dhcp-pgsql \
-      --enable-perfdhcp \
-      --enable-generate-messages \
-      --enable-generate-parser \
       --enable-shell
   make
 }

Modified: fix-scripts-include-path.patch
===================================================================
--- fix-scripts-include-path.patch	2020-10-11 17:56:49 UTC (rev 723531)
+++ fix-scripts-include-path.patch	2020-10-11 18:10:51 UTC (rev 723532)
@@ -1,10 +1,10 @@
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_1.0_to_2.0.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_1.0_to_2.0.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_1.0_to_2.0.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_1.0_to_2.0.sh.in	2020-10-02 11:02:02.400414722 +0300
-@@ -1,13 +1,7 @@
+diff --git a/src/share/database/scripts/mysql/upgrade_1.0_to_2.0.sh.in b/src/share/database/scripts/mysql/upgrade_1.0_to_2.0.sh.in
+index 6914f6de1..d13bd1f95 100644
+--- a/src/share/database/scripts/mysql/upgrade_1.0_to_2.0.sh.in
++++ b/src/share/database/scripts/mysql/upgrade_1.0_to_2.0.sh.in
+@@ -1,12 +1,7 @@
  #!/bin/sh
  
--prefix=@prefix@
 -# Include utilities. Use installed version if available and
 -# use build version if it isn't.
 -if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
@@ -17,13 +17,13 @@
  
  VERSION=`mysql_version "$@"`
  
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_2.0_to_3.0.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_2.0_to_3.0.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_2.0_to_3.0.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_2.0_to_3.0.sh.in	2020-10-02 11:02:31.870972519 +0300
-@@ -1,13 +1,7 @@
+diff --git a/src/share/database/scripts/mysql/upgrade_2.0_to_3.0.sh.in b/src/share/database/scripts/mysql/upgrade_2.0_to_3.0.sh.in
+index 0c28330ff..4383a5abf 100644
+--- a/src/share/database/scripts/mysql/upgrade_2.0_to_3.0.sh.in
++++ b/src/share/database/scripts/mysql/upgrade_2.0_to_3.0.sh.in
+@@ -1,12 +1,7 @@
  #!/bin/sh
  
--prefix=@prefix@
 -# Include utilities. Use installed version if available and
 -# use build version if it isn't.
 -if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
@@ -36,13 +36,13 @@
  
  VERSION=`mysql_version "$@"`
  
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_3.0_to_4.0.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_3.0_to_4.0.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_3.0_to_4.0.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_3.0_to_4.0.sh.in	2020-10-02 11:02:47.074593828 +0300
-@@ -1,13 +1,7 @@
+diff --git a/src/share/database/scripts/mysql/upgrade_3.0_to_4.0.sh.in b/src/share/database/scripts/mysql/upgrade_3.0_to_4.0.sh.in
+index 400bbaa07..9570d184b 100644
+--- a/src/share/database/scripts/mysql/upgrade_3.0_to_4.0.sh.in
++++ b/src/share/database/scripts/mysql/upgrade_3.0_to_4.0.sh.in
+@@ -1,12 +1,7 @@
  #!/bin/sh
  
--prefix=@prefix@
 -# Include utilities. Use installed version if available and
 -# use build version if it isn't.
 -if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
@@ -55,13 +55,13 @@
  
  VERSION=`mysql_version "$@"`
  
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_4.0_to_4.1.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_4.0_to_4.1.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_4.0_to_4.1.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_4.0_to_4.1.sh.in	2020-10-02 11:02:53.631384734 +0300
-@@ -1,13 +1,7 @@
+diff --git a/src/share/database/scripts/mysql/upgrade_4.0_to_4.1.sh.in b/src/share/database/scripts/mysql/upgrade_4.0_to_4.1.sh.in
+index 88d2677f6..5b552b10a 100644
+--- a/src/share/database/scripts/mysql/upgrade_4.0_to_4.1.sh.in
++++ b/src/share/database/scripts/mysql/upgrade_4.0_to_4.1.sh.in
+@@ -1,12 +1,7 @@
  #!/bin/sh
  
--prefix=@prefix@
 -# Include utilities. Use installed version if available and
 -# use build version if it isn't.
 -if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
@@ -74,13 +74,13 @@
  
  VERSION=`mysql_version "$@"`
  
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_4.1_to_5.0.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_4.1_to_5.0.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_4.1_to_5.0.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_4.1_to_5.0.sh.in	2020-10-02 11:02:59.278158416 +0300
-@@ -1,13 +1,7 @@
+diff --git a/src/share/database/scripts/mysql/upgrade_4.1_to_5.0.sh.in b/src/share/database/scripts/mysql/upgrade_4.1_to_5.0.sh.in
+index f63179bb3..daea9d134 100644
+--- a/src/share/database/scripts/mysql/upgrade_4.1_to_5.0.sh.in
++++ b/src/share/database/scripts/mysql/upgrade_4.1_to_5.0.sh.in
+@@ -1,12 +1,7 @@
  #!/bin/sh
  
--prefix=@prefix@
 -# Include utilities. Use installed version if available and
 -# use build version if it isn't.
 -if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
@@ -93,13 +93,13 @@
  
  VERSION=`mysql_version "$@"`
  
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_5.0_to_5.1.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_5.0_to_5.1.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_5.0_to_5.1.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_5.0_to_5.1.sh.in	2020-10-02 11:03:06.771633795 +0300
-@@ -1,13 +1,7 @@
+diff --git a/src/share/database/scripts/mysql/upgrade_5.0_to_5.1.sh.in b/src/share/database/scripts/mysql/upgrade_5.0_to_5.1.sh.in
+index 14d0ef013..3f7798ec9 100644
+--- a/src/share/database/scripts/mysql/upgrade_5.0_to_5.1.sh.in
++++ b/src/share/database/scripts/mysql/upgrade_5.0_to_5.1.sh.in
+@@ -1,12 +1,7 @@
  #!/bin/sh
  
--prefix=@prefix@
 -# Include utilities. Use installed version if available and
 -# use build version if it isn't.
 -if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
@@ -112,13 +112,13 @@
  
  VERSION=`mysql_version "$@"`
  
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_5.1_to_5.2.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_5.1_to_5.2.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_5.1_to_5.2.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_5.1_to_5.2.sh.in	2020-10-02 11:03:11.888397474 +0300
-@@ -1,13 +1,7 @@
+diff --git a/src/share/database/scripts/mysql/upgrade_5.1_to_5.2.sh.in b/src/share/database/scripts/mysql/upgrade_5.1_to_5.2.sh.in
+index b692f6912..dee79e7e5 100644
+--- a/src/share/database/scripts/mysql/upgrade_5.1_to_5.2.sh.in
++++ b/src/share/database/scripts/mysql/upgrade_5.1_to_5.2.sh.in
+@@ -1,12 +1,7 @@
  #!/bin/sh
  
--prefix=@prefix@
 -# Include utilities. Use installed version if available and
 -# use build version if it isn't.
 -if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
@@ -131,13 +131,13 @@
  
  VERSION=`mysql_version "$@"`
  
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_5.2_to_6.0.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_5.2_to_6.0.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_5.2_to_6.0.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_5.2_to_6.0.sh.in	2020-10-02 11:03:17.211831753 +0300
-@@ -1,13 +1,7 @@
+diff --git a/src/share/database/scripts/mysql/upgrade_5.2_to_6.0.sh.in b/src/share/database/scripts/mysql/upgrade_5.2_to_6.0.sh.in
+index 3bf129cce..66dfaaf7f 100644
+--- a/src/share/database/scripts/mysql/upgrade_5.2_to_6.0.sh.in
++++ b/src/share/database/scripts/mysql/upgrade_5.2_to_6.0.sh.in
+@@ -1,12 +1,7 @@
  #!/bin/sh
  
--prefix=@prefix@
 -# Include utilities. Use installed version if available and
 -# use build version if it isn't.
 -if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
@@ -150,13 +150,13 @@
  
  VERSION=`mysql_version "$@"`
  
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_6.0_to_7.0.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_6.0_to_7.0.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_6.0_to_7.0.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_6.0_to_7.0.sh.in	2020-10-02 11:03:22.781937394 +0300
-@@ -1,13 +1,7 @@
+diff --git a/src/share/database/scripts/pgsql/upgrade_1.0_to_2.0.sh.in b/src/share/database/scripts/pgsql/upgrade_1.0_to_2.0.sh.in
+index 22d6af4d8..cd0b048bb 100644
+--- a/src/share/database/scripts/pgsql/upgrade_1.0_to_2.0.sh.in
++++ b/src/share/database/scripts/pgsql/upgrade_1.0_to_2.0.sh.in
+@@ -1,12 +1,7 @@
  #!/bin/sh
  
--prefix=@prefix@
 -# Include utilities. Use installed version if available and
 -# use build version if it isn't.
 -if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
@@ -167,187 +167,15 @@
 +# Include utilities.
 +. /usr/share/kea/scripts/admin-utils.sh
  
- VERSION=`mysql_version "$@"`
- 
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_7.0_to_8.0.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_7.0_to_8.0.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_7.0_to_8.0.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_7.0_to_8.0.sh.in	2020-10-02 11:03:27.845366775 +0300
-@@ -1,13 +1,7 @@
- #!/bin/sh
- 
--prefix=@prefix@
--# Include utilities. Use installed version if available and
--# use build version if it isn't.
--if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
--    . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
--else
--    . @abs_top_builddir@/src/bin/admin/admin-utils.sh
--fi
-+# Include utilities.
-+. /usr/share/kea/scripts/admin-utils.sh
- 
- VERSION=`mysql_version "$@"`
- 
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_8.0_to_8.1.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_8.0_to_8.1.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_8.0_to_8.1.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_8.0_to_8.1.sh.in	2020-10-02 11:03:41.438958033 +0300
-@@ -1,13 +1,7 @@
- #!/bin/sh
- 
--prefix=@prefix@
--# Include utilities. Use installed version if available and
--# use build version if it isn't.
--if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
--    . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
--else
--    . @abs_top_builddir@/src/bin/admin/admin-utils.sh
--fi
-+# Include utilities.
-+. /usr/share/kea/scripts/admin-utils.sh
- 
- VERSION=`mysql_version "$@"`
- 
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_8.1_to_8.2.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_8.1_to_8.2.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_8.1_to_8.2.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_8.1_to_8.2.sh.in	2020-10-02 11:03:50.945805145 +0300
-@@ -1,13 +1,7 @@
- #!/bin/sh
- 
--prefix=@prefix@
--# Include utilities. Use installed version if available and
--# use build version if it isn't.
--if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
--    . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
--else
--    . @abs_top_builddir@/src/bin/admin/admin-utils.sh
--fi
-+# Include utilities.
-+. /usr/share/kea/scripts/admin-utils.sh
- 
- VERSION=`mysql_version "$@"`
- 
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_8.2_to_9.0.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_8.2_to_9.0.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_8.2_to_9.0.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_8.2_to_9.0.sh.in	2020-10-02 11:04:02.296020643 +0300
-@@ -1,13 +1,7 @@
- #!/bin/sh
- 
--prefix=@prefix@
--# Include utilities. Use installed version if available and
--# use build version if it isn't.
--if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
--    . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
--else
--    . @abs_top_builddir@/src/bin/admin/admin-utils.sh
--fi
-+# Include utilities.
-+. /usr/share/kea/scripts/admin-utils.sh
- 
- VERSION=`mysql_version "$@"`
- 
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_9.0_to_9.1.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_9.0_to_9.1.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_9.0_to_9.1.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_9.0_to_9.1.sh.in	2020-10-02 11:04:08.132798154 +0300
-@@ -1,13 +1,7 @@
- #!/bin/sh
- 
--prefix=@prefix@
--# Include utilities. Use installed version if available and
--# use build version if it isn't.
--if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
--    . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
--else
--    . @abs_top_builddir@/src/bin/admin/admin-utils.sh
--fi
-+# Include utilities.
-+. /usr/share/kea/scripts/admin-utils.sh
- 
- VERSION=`mysql_version "$@"`
- 
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_9.1_to_9.2.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_9.1_to_9.2.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_9.1_to_9.2.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_9.1_to_9.2.sh.in	2020-10-02 11:04:13.879573974 +0300
-@@ -1,13 +1,7 @@
- #!/bin/sh
- 
--prefix=@prefix@
--# Include utilities. Use installed version if available and
--# use build version if it isn't.
--if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
--    . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
--else
--    . @abs_top_builddir@/src/bin/admin/admin-utils.sh
--fi
-+# Include utilities.
-+. /usr/share/kea/scripts/admin-utils.sh
- 
- VERSION=`mysql_version "$@"`
- 
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_9.2_to_9.3.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_9.2_to_9.3.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/upgrade_9.2_to_9.3.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/upgrade_9.2_to_9.3.sh.in	2020-10-02 11:04:25.629797209 +0300
-@@ -1,13 +1,7 @@
- #!/bin/sh
- 
--prefix=@prefix@
--# Include utilities. Use installed version if available and
--# use build version if it isn't.
--if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
--    . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
--else
--    . @abs_top_builddir@/src/bin/admin/admin-utils.sh
--fi
-+# Include utilities.
-+. /usr/share/kea/scripts/admin-utils.sh
- 
- VERSION=`mysql_version "$@"`
- 
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/mysql/wipe_data.sh.in kea-1.8.0-new/src/share/database/scripts/mysql/wipe_data.sh.in
---- kea-1.8.0-old/src/share/database/scripts/mysql/wipe_data.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/mysql/wipe_data.sh.in	2020-10-02 11:05:55.311503213 +0300
-@@ -12,14 +12,8 @@
- # including leases, reservations, etc... Use at your own peril.
- # Reference tables will be left in-tact.
- 
--prefix=@prefix@
--# Include utilities. Use installed version if available and
--# use build version if it isn't.
--if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
--    . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
--else
--    . @abs_top_builddir@/src/bin/admin/admin-utils.sh
--fi
-+# Include utilities.
-+. /usr/share/kea/scripts/admin-utils.sh
- 
- # First argument is must be the expected schema version <major>.<minor>
- exp_version="$1"
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_1.0_to_2.0.sh.in kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_1.0_to_2.0.sh.in
---- kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_1.0_to_2.0.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_1.0_to_2.0.sh.in	2020-10-02 11:04:39.893401621 +0300
-@@ -1,13 +1,7 @@
- #!/bin/sh
- 
--prefix=@prefix@
--# Include utilities. Use installed version if available and
--# use build version if it isn't.
--if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
--    . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
--else
--    . @abs_top_builddir@/src/bin/admin/admin-utils.sh
--fi
-+# Include utilities.
-+. /usr/share/kea/scripts/admin-utils.sh
- 
  VERSION=`pgsql_version "$@"`
  
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_2.0_to_3.0.sh.in kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_2.0_to_3.0.sh.in
---- kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_2.0_to_3.0.sh.in	2020-10-02 11:00:03.148163954 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_2.0_to_3.0.sh.in	2020-10-02 11:04:45.243503326 +0300
-@@ -1,13 +1,7 @@
+diff --git a/src/share/database/scripts/pgsql/upgrade_2.0_to_3.0.sh.in b/src/share/database/scripts/pgsql/upgrade_2.0_to_3.0.sh.in
+index ac283c3c0..29c78ddbc 100644
+--- a/src/share/database/scripts/pgsql/upgrade_2.0_to_3.0.sh.in
++++ b/src/share/database/scripts/pgsql/upgrade_2.0_to_3.0.sh.in
+@@ -1,12 +1,7 @@
  #!/bin/sh
  
--prefix=@prefix@
 -# Include utilities. Use installed version if available and
 -# use build version if it isn't.
 -if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
@@ -360,13 +188,13 @@
  
  VERSION=`pgsql_version "$@"`
  
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_3.0_to_3.1.sh.in kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_3.0_to_3.1.sh.in
---- kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_3.0_to_3.1.sh.in	2020-10-02 11:00:03.148163954 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_3.0_to_3.1.sh.in	2020-10-02 11:04:50.880277161 +0300
-@@ -1,13 +1,7 @@
+diff --git a/src/share/database/scripts/pgsql/upgrade_3.0_to_3.1.sh.in b/src/share/database/scripts/pgsql/upgrade_3.0_to_3.1.sh.in
+index 531f250b8..e687b4bfc 100644
+--- a/src/share/database/scripts/pgsql/upgrade_3.0_to_3.1.sh.in
++++ b/src/share/database/scripts/pgsql/upgrade_3.0_to_3.1.sh.in
+@@ -1,12 +1,7 @@
  #!/bin/sh
  
--prefix=@prefix@
 -# Include utilities. Use installed version if available and
 -# use build version if it isn't.
 -if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
@@ -379,13 +207,13 @@
  
  VERSION=`pgsql_version "$@"`
  
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_3.1_to_3.2.sh.in kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_3.1_to_3.2.sh.in
---- kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_3.1_to_3.2.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_3.1_to_3.2.sh.in	2020-10-02 11:04:55.337028573 +0300
-@@ -1,13 +1,7 @@
+diff --git a/src/share/database/scripts/pgsql/upgrade_3.1_to_3.2.sh.in b/src/share/database/scripts/pgsql/upgrade_3.1_to_3.2.sh.in
+index 3581ead64..60d1d3e49 100644
+--- a/src/share/database/scripts/pgsql/upgrade_3.1_to_3.2.sh.in
++++ b/src/share/database/scripts/pgsql/upgrade_3.1_to_3.2.sh.in
+@@ -1,12 +1,7 @@
  #!/bin/sh
  
--prefix=@prefix@
 -# Include utilities. Use installed version if available and
 -# use build version if it isn't.
 -if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
@@ -398,13 +226,13 @@
  
  VERSION=`pgsql_version "$@"`
  
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_3.2_to_3.3.sh.in kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_3.2_to_3.3.sh.in
---- kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_3.2_to_3.3.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_3.2_to_3.3.sh.in	2020-10-02 11:05:00.917134693 +0300
-@@ -1,13 +1,7 @@
+diff --git a/src/share/database/scripts/pgsql/upgrade_3.2_to_3.3.sh.in b/src/share/database/scripts/pgsql/upgrade_3.2_to_3.3.sh.in
+index 76f4683ea..f7d292439 100644
+--- a/src/share/database/scripts/pgsql/upgrade_3.2_to_3.3.sh.in
++++ b/src/share/database/scripts/pgsql/upgrade_3.2_to_3.3.sh.in
+@@ -1,12 +1,7 @@
  #!/bin/sh
  
--prefix=@prefix@
 -# Include utilities. Use installed version if available and
 -# use build version if it isn't.
 -if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
@@ -417,13 +245,13 @@
  
  VERSION=`pgsql_version "$@"`
  
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_3.3_to_4.0.sh.in kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_3.3_to_4.0.sh.in
---- kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_3.3_to_4.0.sh.in	2020-10-02 11:00:03.151497350 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_3.3_to_4.0.sh.in	2020-10-02 11:05:09.357295228 +0300
-@@ -1,13 +1,7 @@
+diff --git a/src/share/database/scripts/pgsql/upgrade_3.3_to_4.0.sh.in b/src/share/database/scripts/pgsql/upgrade_3.3_to_4.0.sh.in
+index b9513629c..d65cafc22 100644
+--- a/src/share/database/scripts/pgsql/upgrade_3.3_to_4.0.sh.in
++++ b/src/share/database/scripts/pgsql/upgrade_3.3_to_4.0.sh.in
+@@ -1,12 +1,7 @@
  #!/bin/sh
  
--prefix=@prefix@
 -# Include utilities. Use installed version if available and
 -# use build version if it isn't.
 -if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
@@ -436,99 +264,3 @@
  
  VERSION=`pgsql_version "$@"`
  
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_4.0_to_5.0.sh.in kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_4.0_to_5.0.sh.in
---- kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_4.0_to_5.0.sh.in	2020-10-02 11:00:03.148163954 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_4.0_to_5.0.sh.in	2020-10-02 11:05:14.294055811 +0300
-@@ -1,13 +1,7 @@
- #!/bin/sh
- 
--prefix=@prefix@
--# Include utilities. Use installed version if available and
--# use build version if it isn't.
--if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
--    . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
--else
--    . @abs_top_builddir@/src/bin/admin/admin-utils.sh
--fi
-+# Include utilities.
-+. /usr/share/kea/scripts/admin-utils.sh
- 
- VERSION=`pgsql_version "$@"`
- 
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_5.0_to_5.1.sh.in kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_5.0_to_5.1.sh.in
---- kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_5.0_to_5.1.sh.in	2020-10-02 11:00:03.148163954 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_5.0_to_5.1.sh.in	2020-10-02 11:05:19.260816976 +0300
-@@ -1,13 +1,7 @@
- #!/bin/sh
- 
--prefix=@prefix@
--# Include utilities. Use installed version if available and
--# use build version if it isn't.
--if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
--    . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
--else
--    . @abs_top_builddir@/src/bin/admin/admin-utils.sh
--fi
-+# Include utilities.
-+. /usr/share/kea/scripts/admin-utils.sh
- 
- VERSION=`pgsql_version "$@"`
- 
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_5.1_to_6.0.sh.in kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_5.1_to_6.0.sh.in
---- kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_5.1_to_6.0.sh.in	2020-10-02 11:00:03.148163954 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_5.1_to_6.0.sh.in	2020-10-02 11:05:23.947572823 +0300
-@@ -1,13 +1,7 @@
- #!/bin/sh
- 
--prefix=@prefix@
--# Include utilities. Use installed version if available and
--# use build version if it isn't.
--if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
--    . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
--else
--    . @abs_top_builddir@/src/bin/admin/admin-utils.sh
--fi
-+# Include utilities.
-+. /usr/share/kea/scripts/admin-utils.sh
- 
- VERSION=`pgsql_version "$@"`
- 
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_6.0_to_6.1.sh.in kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_6.0_to_6.1.sh.in
---- kea-1.8.0-old/src/share/database/scripts/pgsql/upgrade_6.0_to_6.1.sh.in	2020-10-02 11:00:03.148163954 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/pgsql/upgrade_6.0_to_6.1.sh.in	2020-10-02 11:05:29.001002326 +0300
-@@ -1,13 +1,7 @@
- #!/bin/sh
- 
--prefix=@prefix@
--# Include utilities. Use installed version if available and
--# use build version if it isn't.
--if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
--    . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
--else
--    . @abs_top_builddir@/src/bin/admin/admin-utils.sh
--fi
-+# Include utilities.
-+. /usr/share/kea/scripts/admin-utils.sh
- 
- VERSION=`pgsql_version "$@"`
- 
-diff -aur --color kea-1.8.0-old/src/share/database/scripts/pgsql/wipe_data.sh.in kea-1.8.0-new/src/share/database/scripts/pgsql/wipe_data.sh.in
---- kea-1.8.0-old/src/share/database/scripts/pgsql/wipe_data.sh.in	2020-10-02 11:00:03.148163954 +0300
-+++ kea-1.8.0-new/src/share/database/scripts/pgsql/wipe_data.sh.in	2020-10-02 11:05:37.991173444 +0300
-@@ -12,14 +12,8 @@
- # including leases, reservations, etc... Use at your own peril.
- # Reference tables will be left in-tact.
- 
--prefix=@prefix@
--# Include utilities. Use installed version if available and
--# use build version if it isn't.
--if [ -e @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh ]; then
--    . @datarootdir@/@PACKAGE_NAME@/scripts/admin-utils.sh
--else
--    . @abs_top_builddir@/src/bin/admin/admin-utils.sh
--fi
-+# Include utilities.
-+. /usr/share/kea/scripts/admin-utils.sh
- 
- # First argument is must be the expected schema version <major>.<minor>
- exp_version="$1"

Modified: tmpfiles-kea.conf
===================================================================
--- tmpfiles-kea.conf	2020-10-11 17:56:49 UTC (rev 723531)
+++ tmpfiles-kea.conf	2020-10-11 18:10:51 UTC (rev 723532)
@@ -1,2 +1 @@
-d /run/kea 0755 root root -
 d /run/lock/kea 0755 root root -


More information about the arch-commits mailing list