[arch-commits] Commit in ghostscript/repos/extra-x86_64 (PKGBUILD PKGBUILD)

Andreas Radke andyrtr at archlinux.org
Mon Sep 14 18:02:13 UTC 2020


    Date: Monday, September 14, 2020 @ 18:02:13
  Author: andyrtr
Revision: 396138

archrelease: copy trunk to extra-x86_64

Added:
  ghostscript/repos/extra-x86_64/PKGBUILD
    (from rev 396137, ghostscript/trunk/PKGBUILD)
Deleted:
  ghostscript/repos/extra-x86_64/PKGBUILD

----------+
 PKGBUILD |  206 ++++++++++++++++++++++++++++++-------------------------------
 1 file changed, 103 insertions(+), 103 deletions(-)

Deleted: PKGBUILD
===================================================================
--- PKGBUILD	2020-09-14 18:01:50 UTC (rev 396137)
+++ PKGBUILD	2020-09-14 18:02:13 UTC (rev 396138)
@@ -1,103 +0,0 @@
-# Maintainer: AndyRTR <andyrtr at archlinux.org>
-
-pkgbase=ghostscript
-pkgname=(ghostscript ghostxps ghostpcl)
-pkgver=9.53.0
-pkgrel=1
-pkgdesc="An interpreter for the PostScript language"
-url="https://www.ghostscript.com/"
-arch=('x86_64')
-license=('AGPL3' 'custom')
-depends=('libxt' 'libcups' 'fontconfig' 'zlib' 'libpng' 'libjpeg' 'jbig2dec'
-         'libtiff' 'lcms2' 'dbus' 'libpaper' 'ijs' 'openjpeg2' 'libidn')
-makedepends=('gtk3' 'gnutls' 'glu' 'freeglut')
-# https://github.com/ArtifexSoftware/ghostpdl-downloads/releases
-source=(https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${pkgver//./}/ghostpdl-${pkgver}.tar.gz)
-sha512sums=('f1ed6ec04d5eef6761e68c950dc29f5f6d80ac7f2cd478e56e95c5cb4b0099f3216c402ad9ac387caa280b54531dcb6aa6c47c2ae33edd6e232a18fc03e63ea3')
-
-
-### update jbig2dec first! ###
-
-prepare() {
-  cd ghostpdl-${pkgver}
-
-  # force it to use system-libs
-  rm -r cups/libs expat ijs jbig2dec jpeg lcms2mt libpng openjpeg tiff zlib
-  # using tree freetype because of https://bugs.archlinux.org/task/56849
-  # lcms2mt is the new lcms2 fork aimed to replace lcms2 in a thread safe way
-  
-  # http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=40dc5b409c6262b18b4bf5386b5482ead4c511e3
-  # libs link unwanted to libgpdl that isn't installed
-  rm -rf gpdl
-}
-
-build() {
-  cd ghostpdl-${pkgver}
-  ./configure --prefix=/usr \
-              --enable-dynamic \
-              --with-ijs \
-              --with-jbig2dec \
-              --with-x \
-              --with-drivers=ALL \
-              --with-fontpath=/usr/share/fonts/gsfonts \
-              --enable-fontconfig \
-              --enable-freetype \
-              --enable-openjpeg \
-              --without-luratech \
-              --with-system-libtiff \
-              --with-libpaper \
-              --disable-compile-inits #--help # needed for linking with system-zlib
-
-  make so-only
-}
-
-package_ghostscript() {
-  optdepends=('texlive-core:      needed for dvipdf'
-              'gtk3:              needed for gsx')
-
-  cd ghostpdl-${pkgver}
-
-  make DESTDIR="${pkgdir}" \
-       CUPSSERVERROOT="${pkgdir}$(cups-config --serverroot)" \
-       CUPSSERVERBIN="${pkgdir}$(cups-config --serverbin)" \
-       soinstall
-  ln -s gsc "${pkgdir}"/usr/bin/gs
-
-  # remove useless broken doc/ symlink - FS#59507
-  rm -f "${pkgdir}"/usr/share/ghostscript/${pkgver}/doc
-
-  # remove unwanted localized manpages
-  rm -r "${pkgdir}"/usr/share/man/de
-
-  install -Dt "${pkgdir}"/usr/share/licenses/${pkgname} -m644 LICENSE
-}
-
-package_ghostxps() {
-  pkgdesc="${pkgdesc/PostScript/XPS document}"
-  depends=("ghostscript=${pkgver}-${pkgrel}")
-
-  cd ghostpdl-${pkgver}
-
-  install -Dt "${pkgdir}"/usr/bin sobin/gxpsc
-  ln -s gxpsc "${pkgdir}"/usr/bin/gxps
-
-  install -Dt "${pkgdir}"/usr/lib sobin/libgxps.so.${pkgver%.*}
-  ln -s libgxps.so.${pkgver%.*} "${pkgdir}"/usr/lib/libgxps.so.${pkgver%rc*}
-
-  install -Dt "${pkgdir}"/usr/share/licenses/${pkgname} -m644 LICENSE
-}
-
-package_ghostpcl() {
-  pkgdesc="${pkgdesc/PostScript/PCL 6}"
-  depends=("ghostscript=${pkgver}-${pkgrel}")
-
-  cd ghostpdl-${pkgver}
-
-  install -Dt "${pkgdir}"/usr/bin sobin/gpcl6c
-  ln -sf gpcl6c "${pkgdir}"/usr/bin/gpcl6
-
-  install -Dt "${pkgdir}"/usr/lib sobin/libgpcl6.so.${pkgver%.*}
-  ln -s libgpcl6.so.${pkgver%.*} "${pkgdir}"/usr/lib/libgpcl6.so.${pkgver%rc*}
-
-  install -Dt "${pkgdir}"/usr/share/licenses/${pkgname} -m644 LICENSE
-}

Copied: ghostscript/repos/extra-x86_64/PKGBUILD (from rev 396137, ghostscript/trunk/PKGBUILD)
===================================================================
--- PKGBUILD	                        (rev 0)
+++ PKGBUILD	2020-09-14 18:02:13 UTC (rev 396138)
@@ -0,0 +1,103 @@
+# Maintainer: AndyRTR <andyrtr at archlinux.org>
+
+pkgbase=ghostscript
+pkgname=(ghostscript ghostxps ghostpcl)
+pkgver=9.53.1
+pkgrel=1
+pkgdesc="An interpreter for the PostScript language"
+url="https://www.ghostscript.com/"
+arch=('x86_64')
+license=('AGPL3' 'custom')
+depends=('libxt' 'libcups' 'fontconfig' 'zlib' 'libpng' 'libjpeg' 'jbig2dec'
+         'libtiff' 'lcms2' 'dbus' 'libpaper' 'ijs' 'openjpeg2' 'libidn')
+makedepends=('gtk3' 'gnutls' 'glu' 'freeglut')
+# https://github.com/ArtifexSoftware/ghostpdl-downloads/releases
+source=(https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${pkgver//./}/ghostpdl-${pkgver}.tar.gz)
+sha512sums=('4aaeba969239690966bde288c8dc4663e0956361f9c667ca5aae117e950621291aed40d5828f7ac99bc0a812595430fe0e8311a75c4f482c1320c9c294028008')
+
+
+### update jbig2dec first! ###
+
+prepare() {
+  cd ghostpdl-${pkgver}
+
+  # force it to use system-libs
+  rm -r cups/libs expat ijs jbig2dec jpeg lcms2mt libpng openjpeg tiff zlib
+  # using tree freetype because of https://bugs.archlinux.org/task/56849
+  # lcms2mt is the new lcms2 fork aimed to replace lcms2 in a thread safe way
+  
+  # http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=40dc5b409c6262b18b4bf5386b5482ead4c511e3
+  # libs link unwanted to libgpdl that isn't installed
+  rm -rf gpdl
+}
+
+build() {
+  cd ghostpdl-${pkgver}
+  ./configure --prefix=/usr \
+              --enable-dynamic \
+              --with-ijs \
+              --with-jbig2dec \
+              --with-x \
+              --with-drivers=ALL \
+              --with-fontpath=/usr/share/fonts/gsfonts \
+              --enable-fontconfig \
+              --enable-freetype \
+              --enable-openjpeg \
+              --without-luratech \
+              --with-system-libtiff \
+              --with-libpaper \
+              --disable-compile-inits #--help # needed for linking with system-zlib
+
+  make so-only
+}
+
+package_ghostscript() {
+  optdepends=('texlive-core:      needed for dvipdf'
+              'gtk3:              needed for gsx')
+
+  cd ghostpdl-${pkgver}
+
+  make DESTDIR="${pkgdir}" \
+       CUPSSERVERROOT="${pkgdir}$(cups-config --serverroot)" \
+       CUPSSERVERBIN="${pkgdir}$(cups-config --serverbin)" \
+       soinstall
+  ln -s gsc "${pkgdir}"/usr/bin/gs
+
+  # remove useless broken doc/ symlink - FS#59507
+  rm -f "${pkgdir}"/usr/share/ghostscript/${pkgver}/doc
+
+  # remove unwanted localized manpages
+  rm -r "${pkgdir}"/usr/share/man/de
+
+  install -Dt "${pkgdir}"/usr/share/licenses/${pkgname} -m644 LICENSE
+}
+
+package_ghostxps() {
+  pkgdesc="${pkgdesc/PostScript/XPS document}"
+  depends=("ghostscript=${pkgver}-${pkgrel}")
+
+  cd ghostpdl-${pkgver}
+
+  install -Dt "${pkgdir}"/usr/bin sobin/gxpsc
+  ln -s gxpsc "${pkgdir}"/usr/bin/gxps
+
+  install -Dt "${pkgdir}"/usr/lib sobin/libgxps.so.${pkgver%.*}
+  ln -s libgxps.so.${pkgver%.*} "${pkgdir}"/usr/lib/libgxps.so.${pkgver%rc*}
+
+  install -Dt "${pkgdir}"/usr/share/licenses/${pkgname} -m644 LICENSE
+}
+
+package_ghostpcl() {
+  pkgdesc="${pkgdesc/PostScript/PCL 6}"
+  depends=("ghostscript=${pkgver}-${pkgrel}")
+
+  cd ghostpdl-${pkgver}
+
+  install -Dt "${pkgdir}"/usr/bin sobin/gpcl6c
+  ln -sf gpcl6c "${pkgdir}"/usr/bin/gpcl6
+
+  install -Dt "${pkgdir}"/usr/lib sobin/libgpcl6.so.${pkgver%.*}
+  ln -s libgpcl6.so.${pkgver%.*} "${pkgdir}"/usr/lib/libgpcl6.so.${pkgver%rc*}
+
+  install -Dt "${pkgdir}"/usr/share/licenses/${pkgname} -m644 LICENSE
+}


More information about the arch-commits mailing list