[arch-dev-public] Repository rebuilding

Aaron Griffin aaronmgriffin at gmail.com
Fri Aug 10 16:04:21 EDT 2007

On 8/10/07, Jason Chu <jason at archlinux.org> wrote:
> What would you think if x86_64 had a -4 version of a package that you have
> as -3 in i686?  Would you think that i686 should update to -4?  Or would
> you check the PKGBUILDs of the two of them to see if one or the other needs
> an update?

Well, there's a few things here that make this point either moot, or
an edge case:
a) most people don't know the versions that another arch uses. It's
really that simple. If I `pacman -S foo` and get 1.5-4, it doesn't
tell me what version x86_64 has. The front page likewise only shows
i686 packages (sadly...).
b) if people get confused then they don't understand the significance
of the pkgrel, and it's thus our responsibility to make it more clear.

Also, Juergen, thanks for the script - I was gonna do it when I got
home from work as I knew it was that simple. You just beat me 8)

More information about the arch-dev-public mailing list