[arch-dev-public] DB rebuilds

Dan McGee dpmcgee at gmail.com
Sun Jun 17 20:27:50 EDT 2007

I just threw up a pacman release (3.0.5) that fixes the following
issue (http://bugs.archlinux.org/task/7338): conflicts lines from
packages were not correctly added to a sync DB, causing issues when it
comes to replacing stock packages with an -svn version, for example.
Two things this likely affects:

1. If version 3.0.4 of pacman is installed on al.org, we should
probably upgrade to 3.0.5 to get the fixed repo-add script (which is
used by gensync, which may be used by our other scripts?)
2. The community DB should probably be rebuilt completely to ensure
all the conflicts lines are now present, if this is a problem.

Questions on this? Let me know if I wasn't clear about anything here.


More information about the arch-dev-public mailing list