[arch-dev-public] Third list of removal candidates

Eric Belanger belanger at ASTRO.UMontreal.CA
Thu Nov 29 21:54:17 EST 2007

On Thu, 29 Nov 2007, Roman Kyrylych wrote:

> 2007/11/27, Eric Belanger <belanger at astro.umontreal.ca>:
>> Hi,
>> Here is the third sublist. It contains the packages from the second list
>> that for which no decision has been made plus the remaining orphans in the
>> wiki list. There might be a fourth sublist if there are still some stray
>> orphans remaining.
>> If you think a package should be kept or disagree about the comments, say
>> it so. If you think all these packages can be removed, also say it so. If
>> you want to adopt one of these packages, please adopt it through the
>> dashboard and let me know.
>> ======================================

>> libidl  unused lib
>> libsvg  unused lib
> Aren't they just non-specified depends? Names sound like they are/was
> important somewhere.

libidl seems to be a legacy lib which is no longer needed. Packages in the 
repo now uses libidl2.

libsvg is old. It's a devel snapshot dating from 2005.

About non-specified depends: I won't go through the thousands of packages 
in the repo to see if their depends are correct. ;) If a package has one 
of these libs as a non-specified depends, a user will eventually get an error 
and will file a bug report.  The dev with the brocken package will need to 
readd the missing depends in the repo.

>> powernowd       Do we need it? We already have cpudyn and cpufreq. As a decision been made?
> Not needed. We have all needed modules in kernel and cpufrequtils to
> make them usable.
> (see comments in previous thread)

OK, just wanted to  be sure.

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the arch-dev-public mailing list