[arch-dev-public] Database breakage - again!

Thomas Bächler thomas at archlinux.org
Sun Apr 20 07:01:41 EDT 2008

Thomas Bächler schrieb:
> Okay, I am pissed right now. bzip2 (x86_64) had version 1.0.5-1 in the 
> database, while the version in the package and the filename are 1.0.5-2.
> I tried to fix it, and found out what happened in the first place:
> [x86_64][17:21:48][thomas at artin trunk]$ archrelease testing-x86_64
> svnmerge: no integration info available
> ~/arch/repos/svn-packages/bzip2 ~/arch/repos/svn-packages/bzip2/trunk
> Nothing to commit
> ~/arch/repos/svn-packages/bzip2/trunk
> However, the PKGBUILD in testing-x86_64 was the old one. This is clearly 
> a problem in the archrelease script. AND in our db scripts. I fixed it 
> this time, however, people should actually look at the output of the 
> scripts. It's not like we're monkeys.
Here are all others:

Inconsistency: firefox3 3.0b4-1 vs. firefox3-3.0b5-1-x86_64.pkg.tar.gz
Inconsistency: bmpx 0.40.13-1 vs. bmpx-0.40.13-2-i686.pkg.tar.gz
Inconsistency: bzr 1.3-1.1 vs. bzr-1.3-1-x86_64.pkg.tar.gz
Inconsistency: darcs 1.0.9-1 vs. darcs-2.0.0-1-x86_64.pkg.tar.gz
Inconsistency: pidgin 2.4.0-1 vs. pidgin-2.4.1-1-x86_64.pkg.tar.gz

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 260 bytes
Desc: OpenPGP digital signature
URL: <http://archlinux.org/pipermail/arch-dev-public/attachments/20080420/fe9a7310/attachment.pgp>

More information about the arch-dev-public mailing list