[arch-dev-public] kernel/catalyst upgrade path broken

Jan de Groot jan at jgc.homeip.net
Sun Dec 28 07:38:07 EST 2008

On Sat, 2008-12-27 at 21:30 +0100, Andreas Radke wrote:
> after pacman -R xf86-video-ati i can do the update.

This is because xf86-video-ati contains a versioned dependency on libgl,
which catalyst-utils doesn't provide. This is half-correct actually.
xf86-video-ati depends on ati-dri, which needs libdricore.so, which is
in libgl-7.2, not in any other package.
Having both drivers installed on the same system has no use actually, as
you can't use both at the same time.

More information about the arch-dev-public mailing list