[arch-dev-public] current e2fsprogs incompatible with grub

Roman Kyrylych roman.kyrylych at gmail.com
Fri Feb 8 18:37:30 EST 2008

2008/2/9, Jan de Groot <jan at jgc.homeip.net>:
> Creating a boot filesystem with the default settings for mke2fs will
> render grub useless because grub can't read partitions created with it.
> The issue is that the inode size is 256 by default, which is compatible
> with kernel 2.6.10 and higher. Older kernels, and also grub won't work
> with anything else than 128, which is the default according to the
> manpage (but clearly isn't).
> We should fix this before making our new installer CD and we should nag
> upstream about this. During my search for a solution, I found not a
> single solution, but several forum posts coming from several
> distributions, all without solution other than "install lilo, grub is
> broken on my distro".

That sucks. :-(
Where the hell those developers look before doing such stupid
incompatible changes? :-/

Roman Kyrylych (Роман Кирилич)

More information about the arch-dev-public mailing list