[arch-dev-public] Updated perl 5.10.0

Roman Kyrylych roman.kyrylych at gmail.com
Tue Jan 8 07:43:42 EST 2008

2008/1/3, K. Piche <kpiche at rogers.com>:
> Another thing to note is that additional modules were added to the
> default perl library so some official packages are not needed once
> 5.10.0 is installed.  However the packages can be used to "update" parts
> of the perl library.  I'm not sure how we're going to deal with this
> situation yet.  For example perl 5.10.0 now comes with
> IO::Compress::Base version 2.008, perl-io-compress-base is 2.006.  The
> package is not required until 2.009 is released and before the perl
> package gets updated.

I'm confused. If perl-io-compress-base will be at 2.009 and perl
package will still have 2.008 - user cannot install
perl-io-compress-base because pacman will complain about file
Either perl package should be rebuilt to include the newer IO::Compress::Base
or all those base modules can be deps (or cannot because of tech limitations?).
Did I get this right? (I'm not a perl user, never got to writing
anything in it after reading some book long ago :-P)

Roman Kyrylych (Роман Кирилич)

More information about the arch-dev-public mailing list