[arch-dev-public] [draft] QT-4 and QT3 moved to [extra]

Pierre Schmitz pierre at archlinux.de
Sun Jan 20 13:10:11 EST 2008

As announced last year* and after a longer period of testing, QT versions 3 
and 4 have now been moved to [extra].

At least until the final release of KDE4 there are plenty of packages which 
still use version 3 of QT. Therefore a new package called qt3 was introduced.

The dependencies of all packages are updated according to this change. The 
update should be quite smooth. Pacman only notifies about replacing qt by qt3 
and qt4 by qt.

If you don't want to have QT version 4 installed just remove it 
with "pacman -Rc qt" after the update.

If you are using any third party repositories like KDEmod please wait until 
they have updated their packages, too. Do not force any updates!

If there are still any issues, please report them at 

Community packages may not be updated with the new versioning scheme of QT, so 
give your TUs some time to make the required changes.

*) http://archlinux.org/pipermail/arch-dev-public/2007-November/002910.html

More information about the arch-dev-public mailing list