[arch-dev-public] mailman and python

Dusty Phillips buchuki at gmail.com
Mon Nov 3 11:26:28 EST 2008

2008/11/3 Aaron Hussein Griffin <aaronmgriffin at gmail.com>:
> On Mon, Nov 3, 2008 at 6:19 AM, Allan McRae <allan at archlinux.org> wrote:
>> Hi,
>> Can someone have a look at the mailman and python-2.6 incompatibility
>> reported in FS#11970 (http://bugs.archlinux.org/task/11970).  I don't have
>> any more time to look into this before I leave and currently mailman has no
>> maintainer.  If no patch is found, mailman will work with python24 as an
>> interim fix.
> Adopted it. I'm sure this is a simple patch (convert 'sha' to
> 'hashlib'). I hope I can get to this tonight.

Not likely, sha is deprecated in python26, but it still works.
(Converting it to hashlib is easy though.) -- that's just a warning.

The error in that bug report is that the email.message class doesn't
exist... maybe they meant to import email.Message. I don't think
email.message ever existed in the standard email module though -- is
mailman expecting a different email module from the one in python's
standard library?


More information about the arch-dev-public mailing list