[arch-dev-public] How old kernel to "support" - Was: [signoff] coreutils-7.5

Allan McRae allan at archlinux.org
Tue Aug 25 01:32:41 EDT 2009

Thomas Bächler wrote:
> Allan McRae schrieb:
>>> Without that patch, what kernels does coreutils support then? Since 
>>> udev
>>> breaks with pretty much everything below 2.6.24, I don't think it's
>>> useful to patch packages to support anything below 2.6.24.
>> It breaks support for kernels below 2.6.22.  As our glibc supports 
>> 2.6.18 and above and people can have a static dev, so I thought this 
>> was a good patch to include.  Anyway, it is an upstream patch, so the 
>> next release will make this moot...
> Hmmmm,
> http://projects.archlinux.org/?p=initscripts.git;a=commitdiff;h=76bb11cb8b5374ff2bba79afc80c408f61779f0c 
> I think this hasn't worked for years anyway.

Uh...  so we can not have a static dev fs?   Wasn't that the whole 
argument against bumping the kernel version required for glibc too 
high?  Or has the situation changed enough with the new udev to revisit 
that issue?


More information about the arch-dev-public mailing list