[arch-dev-public] [arch-general] [signoff] kernel26 2.6.30-3

Eric Bélanger snowmaniscool at gmail.com
Thu Jun 25 17:54:37 EDT 2009

On Tue, Jun 16, 2009 at 12:54 AM, Eric Bélanger<snowmaniscool at gmail.com> wrote:
> On Mon, Jun 15, 2009 at 10:19 AM, Thomas Bächler<thomas at archlinux.org> wrote:
>> Tobias Powalowski schrieb:
>>> Could it be that the new netcfg scripts are a bit buggy here, my custom
>>> bridge script fails too with the same error.
>>> Digging a bit in netcfg code shows it uses ip link | grep UP which is not
>>> working here it says UNKNOWN, maybe James can enlighten us more.
>> My guess as well, the link detection might be broken. netcfg should really
>> have an option to force enabling the interface even if link detection fails.
>> However, when no link is detected, some ethernet drivers disable TX
>> completely. When it was first introduced for my old dmfe card, it was broken
>> and I could receive packets, but nothing was ever transmitted - after my bug
>> report they reverted the changes and reintroduced a working link detection
>> in the next version. My point is, even if you fix netcfg, Eric's driver
>> might be just as broken so he still has to reconnect the cable to make it
>> work.
> I tested with the netcfg in core and it works without any problems.
> So it seems to be an issue with the netcfg in testing.

Update: I tried  netcfg 2.2.0b3-1 and it works. My previous failiures
were with  2.2.0b2.

More information about the arch-dev-public mailing list