[arch-dev-public] xf86-video-nouveau/nouveau-drm in testing

Xavier shiningxc at gmail.com
Thu Mar 12 06:14:39 EDT 2009

On Wed, Mar 4, 2009 at 11:10 AM, Daniel Isenmann <daniel.isenmann at gmx.de> wrote:
> On Tue, 3 Mar 2009 21:55:31 +0100
> Andreas Radke <a.radke at arcor.de> wrote:
>> I've added xf86-video-nouveau + nouveau-drm to testing. Together with
>> Xorg 7.5 this is a nice replacement for the binary crap when you don't
>> need 3D stuff. 2D works well accelerated. 3D will follow later with
>> gallium 3d. For more read:
>> http://nouveau.freedesktop.org/wiki/
> I have installed nouveau and everything runs fine here on my computer.
> The normal work like surfing, building packages, mails, etc. works as
> always. There are no problems so far. Ok, there is no 3D at the moment
> but who needs 3D. ;) (I don't need 3D)
> The installation process was a little bit stony. This way worked:
> - uninstalling nvidia and nvidia-utils
> - installing xf86-video-nouveau and nouveau-drm
> - reboot (removing the drm module doesn't work here)
> - reinstalling libgl and xorg-server
> That's it. After the steps everything worked as expected. Maybe there
> is an easier way for installing it (normally removing the module
> should work), but it works this way.
> I will test it (and the future versions) further and I'm looking forward
> for the 3D support.

An easier way for installing it is to not have nvidia drivers in the
first place :)
It went smoother for me because it was a fresh install.

If I usually don't need 3D support, I do need xv for video playback.
This didn't work by default.
I was told to run a composite manager (xcompmgr is enough) to make it
work, so I enabled composite extension in xorg, ran xcompmgr, and
everything worked fine.


More information about the arch-dev-public mailing list