[arch-dev-public] [signoff] klibc stuff + mkinitcpio

Eric Bélanger snowmaniscool at gmail.com
Thu Oct 22 04:00:04 EDT 2009

On Thu, Oct 22, 2009 at 3:40 AM, Thomas Bächler <thomas at archlinux.org> wrote:
> Allan McRae schrieb:
>> Just adding that I tried heaps of clocksource= options
>> (acpi_pm,htc,jiffies,rtc) and none of them helped this issue.
>> Allan
> That clocksource message is probably unrelated - I get similar messages
> after successful boot. Eric didn't get those, but got a message about his
> keyboard being detected. It is normal that kernel messages appear here after
> control has been passed to userspace - the problem is that userspace hangs.

FTR, my message was:
 Loading udev... input: AT Translated Set 2 keyboard as ...

It stucked there for a few minutes then proceeded with
"Alarm clock
etc, etc.

Only dm_mod was loaded so it failed mounting the root partition and
dropped me in a recovery shell.  I haven't tried udevadm or modprobe
but udevd was running and lsmod was working.  I sent my broken image
to Thomas and everything was there.  Very strange.

> If you have the time and energy, can you add "echo" calls to
> /lib/initcpio/hooks/udev to find out if the udevd --daemon, udevadm trigger
> or udevadm settle is the place where is hangs. I would guess the latter, but
> I don't know for sure.

More information about the arch-dev-public mailing list