[arch-dev-public] Search binary file bug

Aaron Griffin aaronmgriffin at gmail.com
Sun Sep 13 17:59:26 EDT 2009

On Sun, Sep 13, 2009 at 4:10 PM, Eric Bélanger <snowmaniscool at gmail.com> wrote:
> On Sun, Sep 13, 2009 at 3:52 PM, Dusty Phillips <dusty at linux.ca> wrote:
>> 2009/9/13 Dusty Phillips <dusty at linux.ca>:
>>> 2009/9/13 Eric Bélanger <snowmaniscool at gmail.com>:
>>>> On Sun, Sep 13, 2009 at 2:24 PM, Aaron Griffin <aaronmgriffin at gmail.com> wrote:
>>>>> Forwarding this on because it's reproducible using "myadmin" (I tried).
>>>>> ---------- Forwarded message ----------
>>>>> From: Sammie S. Taunton <diemuzi at gmail.com>
>>>>> Date: Sun, Sep 13, 2009 at 12:29 PM
>>>>> Subject: weird search bug
>>>>> To: aaron at archlinux.org
>>>>> Hello,
>>>>> I can't explain it so maybe you'll have a random guess at it. But I'm
>>>>> using the latest firefox version and I went to search for a package
>>>>> (phpmyadmin) and it returns a downloadable mimetype of
>>>>> application/octet-stream
>>>>> However using IE, it works just fine. So just for giggles I tried
>>>>> searching for myadmin and same thing. Every other package I'm
>>>>> searching for works just fine lol. So I dunno haha
>>>>> ~ Sammie
>>>> I can also reproduce it when searching for other packages. This error
>>>> only appears sometimes. There's a FR:
>>>> http://bugs.archlinux.org/task/16134
>>> 'other packages' doesn't help me. specific search terms do. :-)
>> Except... 'myadmin' works fine for me.
>> Dusty
> auctex, xerces-c-2 (deleted since then)
> The BIN problem come and go.  When firefox tries to download a BIN, if
> you click cancel and do the search again, it will work fine. If you
> try again 5-6 time it will work fine.  I can't replicate that problem
> reliably. wonder also had this problem.

Yeah but searching for "myadmin" on here
http://www.archlinux.org/packages/ (NOT the dev site) reproduces it
100% of the time. That's why I forwarded this along, as it MAY give us
a clue to the cause.

I wonder... do we have some sort of apache level protections in place
for people trying to hit like "/phpmyadmin/" on the server? It could
be butting up against something like that

More information about the arch-dev-public mailing list