[arch-dev-public] included features/deps in packages

Dale Blount dale at archlinux.org
Thu Apr 1 19:47:43 CEST 2010


It has come to my attention that we're not very consistent in which
features/deps we compile into programs.  The latest case I've seen is
proftpd.  Proftpd doesn't include mysql/postgres support but does
include ldap/ssl.

Quite a few other packages include libmysqlclient/postgresql-libs
already so it's my opinion that they should be included.  I'd venture to
say 90% of my workstations have those 2 DB libraries already, and 100%
of my servers as they all run postfix which already requires both.

Bug report to comment on as well: http://bugs.archlinux.org/task/18876

Do we have an official stance as to which packages are OK to include in
most things?  It seems to me it's a developer by developer basis on what
gets included now.



More information about the arch-dev-public mailing list