[arch-dev-public] [arch-general] jack & qjackctl

Allan McRae allan at archlinux.org
Tue Apr 6 21:06:50 EDT 2010

On 07/04/10 10:21, Philipp wrote:
> Excerpts from fons's message of 2010-04-07 00:46:09 +0200:
>> It seems like Arch is currently offering Jack and qjackctl
>> packages that are not compatible.
>> The Jack authors changed one some command line options
>> in 0.118. '-R' for realtime is no longer available as
>> realtime is now the default, and the new '-r' means
>> 'no realtime'.
>> Qjackctl 0.3.6 is aware of this, but won't work well with
>> Jack 0.116 which is still the one available from Arch.
>> In other words, the update of qjackctl was probably a bit
>> premature.
>> Ciao,
> The real problem is that jack is still stuck at the rather old 0.116.
> One reason might be those, IMHO in the meanwhile annoying scripts that
> ship with the Arch jack package. It's tough to get them right it seems.
> I would be all in favor of splitting them into a separate package and
> install jack just the way it is supposed to. Much less hassle, less
> confused users and as a bonus those scripts can be easily used with
> other variants of jack.
> Either way, there's really no reason to still ship 0.116.2 when 0.118.0
> was released in November, almost 5 months ago.

jack 0.118 is in [testing].  Does anyone know the reason why it is there 
and whether it can be moved?


More information about the arch-dev-public mailing list