[arch-dev-public] kde 4.5.0

Ronald van Haren pressh at gmail.com
Wed Aug 18 05:06:43 EDT 2010

On Wed, Aug 18, 2010 at 10:30 AM, Pierre Schmitz <pierre at archlinux.de> wrote:
> On Wed, 18 Aug 2010 10:15:16 +0200, Ronald van Haren <pressh at gmail.com>
> wrote:
>> hey guys,
>> Yesterday I went through all open bug reports for kde 4.5.0 and was
>> able to close all of them (old user config issues/only updated part of
>> packages to testing/etc) except one [1], which seems to be ati/intel
>> related, causing the screen not to be updated when changing some
>> system settings if opengl compositing is used on some ati/intel cards.
>> opengl itself should work, just changing the settings hangs the
>> screen, xrender and no compositing are not affected (there is no fix
>> yet and it may as well be a bug in mesa or some).
>> As there are no other open kde 4.5.0 bug reports, I suppose it is time
>> to push it to extra and make place in testing now the translations are
>> in place. Should I write an announcement for the above issue?
>> regards,
>> Ronald
>> [1] http://bugs.archlinux.org/task/20469
> An announcement would be nice. Although there are not much information
> yet. Maybe we should disable composite by default (people are still able
> to enable it again in systemsettings). But that depends on how many
> drivers are actually affected.
> /usr/share/config/kwinrc:
> [Compositing]
> Enabled=false
> --
> Pierre Schmitz, https://users.archlinux.de/~pierre

so far I've seen people reporting the following chipsets to be
affected, but there may be others
intel 910
intel 945
intel 965
ati 3450

does that warrant to disable compositing by default?


More information about the arch-dev-public mailing list