[arch-dev-public] archbuild: building in a chroot for the lazy

Rémy Oudompheng remyoudompheng at gmail.com
Sun Aug 29 18:24:00 EDT 2010

Pierre Schmitz <pierre at archlinux.de>:
> On Sun, 29 Aug 2010 19:52:10 +0200, Rémy Oudompheng
> <remyoudompheng at gmail.com> wrote:
>> Rémy Oudompheng <remyoudompheng at gmail.com> :
>>> I get random catastrophes when starting the script while still having
>>> some shell open inside: I think it comes from binds not properly
>>> dismounted before calling the 'rm -rf' line. Would it be wise to add
>>> the --one-file-system option there ?
>> Gah, even with this change, I still get my packages cache deleted and
>> /dev gets broken (funny things like "/dev/null: permission denied). I
>> can't find the culprit line, makechrootpkg seems to use rsync -x,
>> rebooting...
> I don't really know what you are doing here. ;-) Some more detailed
> steps how to reproduce it would be helpful.

It happens with archbuild (which I used as staging-i686-build), and I
didn't tried with makechrootpkg (I don't really want to try anymore).
I think I get deterministic behaviour with the following steps:
* run archbuild for some package
* start a shell in the chroot during the build process
* wait for archbuild to finish or interrupt it with Ctrl-C
* run archbuild again with the same chroot.


More information about the arch-dev-public mailing list