[arch-dev-public] Warning 2/2: removing kde-unstable; KDE 4.4 in testing

Pierre Schmitz pierre at archlinux.de
Mon Feb 1 07:04:00 EST 2010

Hi DEVs and TUs,

I am about to move the first wave of KDE 4.4 RC3 packages into testing. These 
will be x86_64 at first; i686 packages might follow later this evening. There 
won't be any l10n packages. (they are not needed for testing and rebuild and 
we'll save disk space and bandwidth this way)

The same Information about kde-unstable now apply to testing: 
http://wiki.archlinux.org/index.php/DeveloperWiki:KDE#Users Note that the kde-
unstable repository will be removed soon.

If you update you have to use the following commands as pacman is not able to 
resolve the dependencies otherwise:

% pacman -Sy --asdeps qt
% pacman -Su

All developers and TUs should check their Qt or KDE related packages. Even if 
they still work you might want to adjust the dependencies. There are some like 
phonon etc. which are no longer covered by Qt. In general you want at least 
depend on kdebase-runtime for most apps. (use namcap but don't trust it ;-))



PS: I have problems with akonadi and mysql 5.1.43. Downgrading to mysql 5.1.42 
solves the problem. Can anybody confirm this issue? (test with "akonadictl 


Pierre Schmitz, https://users.archlinux.de/~pierre

More information about the arch-dev-public mailing list