[arch-dev-public] Please avoid versioned deps

Pierre Schmitz pierre at archlinux.de
Sun Jan 17 11:27:57 EST 2010

Hi all,

recently I have seen that there were a lot of commits introducing
versioned deps down to the pkgrel level. I think we should avoid such deps
if possible. There are possibly only some important packages in core where
this is useful and in such cases you should add not only an lower but upper
bound (see kernel modules for example).

For anything else this is not needed (at least for Arch), adds more
complexity or simply breaks stuff. For more detailed arguments please read
at least the first three messages in

This is just a general reminder and I did not intend to attack anyone. So
just keep it simple. :-)



Pierre Schmitz, https://users.archlinux.de/~pierre

More information about the arch-dev-public mailing list