[arch-dev-public] [PATCH 6/7] Remove FTP_OS_SUFFIX variable

Aaron Griffin aaronmgriffin at gmail.com
Thu Mar 11 23:29:26 CET 2010

On Thu, Mar 11, 2010 at 4:18 PM, Daenyth Blank <daenyth+arch at gmail.com> wrote:
> On Thu, Mar 11, 2010 at 17:07, Ghost1227 <ghost1227 at archlinux.us> wrote:
>> ---
>>  config                      |    1 -
>>  misc-scripts/ftpdir-cleanup |    2 +-
>>  2 files changed, 1 insertions(+), 2 deletions(-)
> While it does make the code a little more readable, I have to suggest
> against this. It makes it a little harder to use this on non-official
> repos because they won't always have the same directory structure.
> Ideally I'd like to see the paths and such defined outside of the
> script in a config file, but for now it would be a ton easier to at
> least keep the variable.

That's another ball game. This variable was used in *one* place, and
in about 30 other places "os" was hardcoded. Additionally, it had one
of those silly variable names that just told you what the VALUE was,
not the purpose. Like:

#define HELLO_WORLD_STRING "Hello World"
#define OUTPUT_STRING "Hello World"

Instead of "FTP_OS_SUFFIX" something like "FTP_EXTRA_PATH" would be
more ideal. If you want to add that, it'd be best to patch that in to
ALL the places that use "os"

As it stands, the variable and the single use are it is useless.

More information about the arch-dev-public mailing list