[arch-dev-public] poppler soname bump

Ionuț Bîru ibiru at archlinux.org
Tue Oct 12 15:54:02 EDT 2010

On 06/22/2010 11:29 PM, Jan de Groot wrote:
> The poppler/poppler-glib update to 0.14 includes a soname bump for
> poppler and poppler-glib. Packages depending on these libraries should
> be rebuilt.
> I already did all packages in extra, some packages in community still
> need an update. To track the rebuild, a todo list was created:
> http://www.archlinux.org/todo/38/
> Please rebuild these packages in community-testing and flag them as
> complete after that.

poppler < 0.14.4 has a vulnerability[1] and it needs to be moved as soon 
as possible. The only package from todo is koffice-filters.

koffice-filters is a bit special. koffice is already rebuilt in testing 
against python2 2.7.

to move it fast, i propose to rebuild koffice-filter extra against 
staging bumping pkgrel to 1.1 (testing repo disable) and push it in staging.

after poppler is moved in extra, rebuild the testing against extra.

Ronald, what do you think?

[1] http://securitytracker.com/alerts/2010/Oct/1024520.html


More information about the arch-dev-public mailing list