[arch-dev-public] makepkg bug with epoch code

Allan McRae allan at archlinux.org
Wed Feb 9 05:46:58 EST 2011

Have not had time to look into this, but I get this error with the 
kernel26 PKGBUILD in Arch Linux [core] repo:

 > makepkg -gc
==> Retrieving Sources...
   -> Found linux-2.6.37.tar.bz2
   -> Found patch-2.6.37-4-ARCH.bz2
   -> Found config
   -> Found config.x86_64
   -> Found kernel26.preset
==> Generating checksums for source files...

==> Cleaning up...
/usr/bin/makepkg: line 234: [[: 2.6.37: syntax error: invalid arithmetic 
operator (error token is ".6.37")


More information about the arch-dev-public mailing list