[arch-dev-public] [signoff] coreutils-8.12-2, initscripts-2011.06.2-1, net-tools-1.60-15, udev-171-2, yp-tools-2.12-2

Eric Bélanger snowmaniscool at gmail.com
Fri Jun 3 23:41:42 EDT 2011

On Fri, Jun 3, 2011 at 7:37 AM, Tom Gundersen <teg at jklm.no> wrote:
> On Fri, Jun 3, 2011 at 7:17 AM, Eric Bélanger <snowmaniscool at gmail.com> wrote:
>> On Thu, Jun 2, 2011 at 10:53 PM, Eric Bélanger <snowmaniscool at gmail.com> wrote:
>>> On Thu, Jun 2, 2011 at 11:28 AM, Tom Gundersen <teg at jklm.no> wrote:
>>>> Hi guys,
>>>> After the discussion regarding initscripts-2011.06.1 we decided that
>>>> things would be simpler if we move all the above packages in one go
>>>> (thanks to Gaetan and Thomas for the help!), so please test and sign
>>>> off.
>>> The error messages I mentionned in an earlier signoff thread are back:
>>> http://mailman.archlinux.org/pipermail/arch-dev-public/2011-May/020434.html
> What happens when you try to execute the commands in question manually
> after boot?

They work as expected. The error is not fatal.  My raid array gets
assembled without user intervention. Either it is eventually done by
the initscripts (I can't find where, I think that code parthas been
removed) or by something else.

>>> I'll reboot with udev_log set to debug. Maybe that will give us more info.
>> That won't help unless there's a way to save it. The text scroll so
>> fast that I can't read it. I booted the LTS kernel and I got the same
>> message.
> debug is probably too much information, try warning first. The
> messages should be in "dmesg", /var/log/boot or /var/log/everythnig.

FWIW, the instructive comments in udev.conf doesn't mention "warning"
as a valid value. I tried it and the error message doesn't get
printed.  Dmesg doesn't have the error message and the logs are
useless since the error happens when the kernel is booting, i.e.
rc.sysinit isn't running yet. I suppose it's mkinitcpio/udev related.

>> Also, my loopback interface  didn't started.  When I ran "/usr/sbin/ip
>> link set up dev lo" manually in a terminal, it started fine. I don't
>> know why it didn't work when booting up.
> Do you see anything in the above logs?

I found the source of this error. My /usr is on it's own partition. So
when rc.sysinit attemps to setup the loopback interface with
/usr/sbin/ip, my /usr partition is not mounted yet. So it fails.  I
don't know what would be the best way to fix. Maybe moving ip to /sbin
or to postpone the lo interface  setup after the partitions are

OT: I noticed that the /var/log/boot is somewhat hard to read because
of the presence of the ansi escape sequences for the colored output.
Would it be a good idea (or even possible) to removed these perhaps
with a sed line after bootlogd has finished its stuff?

> Thanks for reporting,
> Tom

More information about the arch-dev-public mailing list