[arch-dev-public] NOTICE glibc 2.14

Allan McRae allan at archlinux.org
Fri Jun 10 05:30:56 EDT 2011

On 10/06/11 06:46, Thomas Bächler wrote:
> Am 09.06.2011 22:41, schrieb Ionut Biru:
>> Hi,
>> stop compiling packages against testing and push them in extra before
>> glibc is moved out.
>> glibc 2.14 is a bitch
> Let's be a more precise here. For the first time since glibc 2.7, there
> is an ABI change that is not backward compatible. Thus, programs
> compiled with the new toolchain require a GLIBC_2.14 symbol.
> This has happened before, but not for several years.

This ususally happens with gcc and c++ programs so it is not really a 
new thing.

Anyway, I have found the issue in glibc and will hopefully have some 
time to push the fixed packages some time tomorrow.  Then I will be 
taking some signoffs and we can move this.


More information about the arch-dev-public mailing list