[arch-dev-public] qt4 replaces qt

Andrea Scarpino andrea at archlinux.org
Wed Feb 27 18:14:55 EST 2013

On Wednesday 27 February 2013 16:21:24 you wrote:
> When you install both qt5-base and qt4, qmake will refers to the 5.x
> version. To 'force' Qt 4.x, you can use the qmake4 symlink. There's also
> moc-qt4, uic- qt4 and rcc-qt4. We provide these symlinks as they are used
> by cmake and by the configure scripts to locate qt4.

Please maintainers fix your PKGBUILDs so they build on systems with both qt4 
and qt5-base installed; when your PKGBUILD needs qt4 and:
* use qmake, you can replace it with qmake4
* use cmake, you can add -DQT_QMAKE_EXECUTABLE=qmake4 to the cmake options


Arch Linux Developer

More information about the arch-dev-public mailing list