[arch-general] [arch-dev-public] initscripts changes

Karolina Lindqvist karolina.lindqvist at kramnet.se
Mon Apr 7 06:00:00 EDT 2008

måndag 07 april 2008 skrev Jan de Groot:

> /proc and /sys are already hardcoded. About your system being broken
> without these filesystems mounted:
> - SSH (both server and client) won't work without devpts mounted
> - None of the virtual X terminal things will work without devpts mounted

In a chroot, some of the filesystems have to be remounted manually.
Try chroot, do a "ps"
you will get:
Error, do this: mount -t proc none /proc
So the automatic hidden feature does not work in that case.
/sys does not get mounted either, nor /dev/pts etc.
I think that is a good reason why the mount commands should be in /etc/fstab 
and not in some obscure init script.

I just tried ssh without mounted /dev/pts in a chroot, and it worked. But 
xterm et al does not work unless I do "mount /dev/pts". ps does not work 
without "mount /proc".

Just keep it simple
To have important system crippling details hidden in some init scripts gives 
the windows syndrome - reinstall from scratch to make it work again!

More information about the arch-general mailing list