[arch-general] Can't see all of installation console

gipper gipper thegipp at gmail.com
Sun Apr 27 00:20:01 EDT 2008

I'm able to boot the installation cd no problem.  Everything looks fine.  I
can read the entire screen - for the boot prompt.
At the boot prompt I type: arch
As the kernel proceeds to load my video mode switches to an unusable mode.
The boot process proceeds and, from what I can tell, drops me into the shell
- as it should.
However, I can't see the prompt - it's way below the bottom of my screen.
The video mode is not the same as the boot CD or bios mode at powerup.  For
some reason the kernel decided to switch to some awful, unusable mode.

I've tried every combination that I can think of at the boot prompt:
- vga=normal
- vga=ask (tried a bunch of these with and without "scan" option)
still no luck.  I haven't been able to find a combination that gets the
console into a usable form.

I'm trying this fresh install on a separate partition because I had done a
pacman -Syu a week ago on a different partition (that I've used for years)
and that kernel update (last week) proceeded to cause this same sort of
crummy console behavior.  On that partition I am able to login on the
console and startx.  However, the console is unusable itself.  In the
process of trying to fix that I thought that a fresh install on another
partition would yield some clues.  But, the fresh install can't even get
into the /arch/setup step because I can't see the entire screen.

So, what's changed in the kernel in the last few months that has caused my
Diamond Viper V770 AGP  RIVA TNT2 to not play with the kernel anymore?

I expected a boot from an install CD to NOT have this problem.  But it
does.  So, my old (trusty) Arch partition has a crummy console mode - but I
can still get to X - but I'm annoyed at the crummy console video.  And my
test, new installation can't even really get going because I can't see the
/arch/setup stuff in the crummy console mode.

If I were new to Arch today, I'd be moving on, because I can't even see the
installation screen in its entirety.  But, for me, Arch is the only way to
go - so I've gotta fix this.

Do I have to roll my on kernel?  ACK!!! I hope not.

any ideas?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://archlinux.org/pipermail/arch-general/attachments/20080426/b464dd8c/attachment.htm>

More information about the arch-general mailing list