[arch-general] SSH. Can't open Xapps when su'ed to root

Nigel Henry cave.dnb2m97pp at aliceadsl.fr
Sun Feb 10 16:01:01 EST 2008

On Sunday 10 February 2008 20:06, Michael Towers wrote:
> Nigel Henry wrote:
> > I'm still looking at the jacman problem, and have sometimes found that
> > apps that won't work on the machine they are installed on, will work if I
> > ssh into the machine, and run them on another.
> >
> > IIRC I had problems initially using ssh when I installed Archlinux (don't
> > panic), but found some info somewhere or other, as below.
> >
> > Comment out "ALL: ALL: DENY" line in /etc/hosts/deny
> > Add sshd to /etc/rc.conf daemons list
> > Run /etc/rc.d/sshd start
> >
> > Now I can ssh into archlinux (this is just local, not from the Internet).
> > I have uncommented the following lines in /etc/ssh/sshd_config
> >
> > X11Forwarding yes
> > X11DisplayOffset 10
> >
> > I can open Xapps as user (gedit, jacman,etc), but not when I su to root,
> > as below for gedit.
> >
> > [djmons at myhost ~]$ su
> > Password:
> > [root at myhost djmons]# gedit
> > X11 connection rejected because of wrong authentication.
> > cannot open display:
> > Run 'gedit --help' to see a full list of available command line options.
> > [root at myhost djmons]#
> >
> > Same goes when I try to open jacman when su'ed to root.
> >
> > I tried accessing Xapps as root with Fedora 8, which is on the same
> > machine as Archlinux, and they open ok.
> >
> > I have compared the sshd_config on both F8, and Archlinux, and can't see
> > any apparent differences between the two.
> >
> > Anyone have any suggestions as to what may be the problem?
> >
> > All a bit puzzling.
> >
> > Nigel.
> I don't think this has anything to do with ssh - you'd get the same
> problem without it. It's x-server access. You can use kdesu/gksu/sux or
> xhost. Or, in the case of ssh, you can ssh to the root account on the
> remote machine (ssh [-Y] root at blah).

ssh -Y doesn't work, but have never had any success with that, but ssh -X 
works as below, and thanks for the pointers.

[djmons at localhost djmons]$ ssh -X root at
root at's password:
Last login: Mon Oct 15 19:23:13 2007
[root at myhost ~]# gedit
[root at myhost ~]# jacman
Exception in thread "AWT-EventQueue-0" java.lang.StackOverflowError
        at java.util.ArrayList.get(ArrayList.java:322)
        at ca.odell.glazedlists.BasicEventList.get(BasicEventList.java:196)
        at java.util.Collections.indexedBinarySearch(Collections.java:318)
        at java.util.Collections.binarySearch(Collections.java:307)

Jacman still doesn't perform, but at least Xapps now run as root.

Still not sure why with other distro's I can ssh into another machine, give my 
user password, then su, and give my root password, and Xapps run ok. Anyway 
I'm not complaining. Different distro's work in different ways. I'll just 
write down the Archlinux way in my notebook. No problemo.

Just an additional Q. While I was ssh'd into Archlinux, I installed hydrogen 
with pacman. I normally save the history from the installs, so that I can see 
which deps were installed for the package, and saving any other info at the 
same time. When I click on "Edit" "Save history as" it wants to save the 
history to the local FC2 machine, rather than , where I've 
installed hydrogen to. Ok I can save the history to the FC2 machine, then ftp 
it over to the archlinux one, but is there some way to save the history 
directly to the archlinux machine?

Well little problems are getting resolved one at a time, and that's good 
enough for me. Thanks for the help.


More information about the arch-general mailing list