[arch-general] Boot sequence stops at modules (rc.sysinit)

Stephen Wilkinson sw8511 at gmail.com
Fri Feb 29 15:04:48 EST 2008

Hello everyone,

After upgrading the kernel alone (and after fixing some kernel panics
-- see postscript) the boot sequence now stops at loading the modules
([DONE]) and goes no further: the cursor blinks and I can type
characters, but I never get a shell prompt. It seems the boot sequence
doesn't go beyond rc.sysinit

The only reference I found to a similar problem is in the forum:
where it was suggested to try the fallback image and removing modules
from the rc.conf. I've tried both, but hasn't helped (as expected: the
kernel loads properly, so not an ramdisk problem, and the modules also
load as I get [DONE] status...).

Before this problem, I knew nothing at all about the boot sequence in
linux so I read this:

Please correct me if I've misunderstood: after loading the kernel, the
boot sequence gets to the init stage, and rc.sysinit is executed --
which, according to my '/etc/rc.sysinit' ends with loading of
modules... but what happens next? I've looked at /etc/inittab but I
don't understand how the sequence of events (and scripts) is

I tried booting into different run levels (adding 1 or 3 to the kernel
line of grub), but it makes no difference.

Because I don't get to a login prompt, I resorted to using a live CD
to mount my root partition and tinker with /etc/rc.sysinit ...
although I admit I don't know what I'm doing. I thought that maybe the
initscripts package should have been upgraded at the same time as the

In summary, what I've tried:
- used a live CD to edit rc.conf (disable modules), and checked there
was nothing in rc.local -- made no difference
- tried booting with fallback image -- made no difference (didn't
think it would as the kernel loads properly) -- made no difference
- used a live CD to tinker with /etc/rc.sysinit but don't know what
I'm doing, and it seems to complete successfully anyway, as all
modules are loaded (status says [DONE])
- tried entering run level 1 by appending 1 to my Grub kernel line --
made no difference

Is there a way to bypass what comes between the end of rc.sysinit
(i.e. loading the modules) and the login prompt, so that I can at
least log in and then try to fix the problem? In other words, how do I
find out what happens after rc.sysinit and disable it?


P.S: in case it's relevant, here is a summary of the kernel panics I
got after upgrading the kernel and rebooting:

After kernel upgrade I got kernel panics because I hadn't changed
initrd26.img to kernel26.img and /dev/hda5 to /dev/sda5 in Grub's
menu.lst (as you can see I hadn't upgraded for a long time, and didn't
pay enough attention to the upgrade messages). Having done that, I
then had to correct /etc/fstab for the same /dev/hda5 mistake. Finally
the kernel booted properly, but the sequence stops at loading modules.

More information about the arch-general mailing list