[arch-general] how to migrate installs between hard drives?

Jozsef jozefk at gmx.com
Tue Jul 28 16:33:05 EDT 2009

What's the problem changing back the permitions?


"Fear God, and give Him glory, because the hour of His judgment has come;
worship Him who made the heaven and the earth and sea and springs of
waters." Revelation 14:7

On Wed, Jul 29, 2009 at 12:25 AM, Will Siddall <will.siddall at gmail.com>wrote:

> Roman,
> I did try the tar method with the same results.  The only method I
> could see working would be the dd, but even looking at the mounted iso
> afterwards, permissions were not set.  I should be seeing at least
> ownership by my username, or 'user #1000' but after copying (and yes,
> with 'cp -a') it still returns root.
> Will
> On Tue, Jul 28, 2009 at 5:15 PM, Roman Kyrylych<roman.kyrylych at gmail.com>
> wrote:
> > On Tue, Jul 28, 2009 at 22:20, Will Siddall<will.siddall at gmail.com>
> wrote:
> >> Hey everyone,
> >> After several attempts, I'm still back to trying to resolve this.  To
> >> explain in more detail, I had a 100G hd with a root partition (with my
> >> Arch Install), a data partition and a swap.  I managed to run dd on
> >> both partitions and in the new hd (200G) apply both.  But that only
> >> worked partially due to the fact that it copied the ratios of file
> >> sizes rather than the actual file size... Copying 80G of data from a
> >> 30G partition doesn't quite sit well with me.
> >> Next step was to mount the iso images and copy the files.  That's what
> >> I was in the process of doing of my last message and it worked...
> >> until I went to restart and update.  What I found that was that my
> >> permissions and ownership info was not kept.  Because of this, as soon
> >> as I went to update anything, the installers would run, but just
> >> delete the files (it deleted pacman and yaourt so I had to find a way
> >> to compile pacman to install again... until it tried to update all of
> >> my bin tools... then everything was gone).
> >> Now following all of your suggestions, I tried rsync -arpol and a
> >> variety of different other settings but it still doesn't keep the
> >> permissions.  I tried running tar on the partition, still not working.
> >>
> >> Does anyone have any other suggestions or know why I'm having this
> >> problem?  I'm going to try to wipe out the new hard drive and run dd
> >> on the whole 100g disk and reapply it to the 200G disk.  And by the
> >> way, I'm running a ubuntu livecd to run these processes.
> >
> > Did you try the tar method?
> > Also, when you copy files, did you use cp -a?
> > You can also try partimage which makes copies of partitions.
> > Doing full byte-to-byte copy of HDD and then doing partition/fs resize
> > or creating an additional partition in empty space is my preferred
> method.
> >
> > --
> > Roman Kyrylych (Роман Кирилич)
> >

More information about the arch-general mailing list